~ubuntu-branches/ubuntu/wily/micro-httpd/wily

« back to all changes in this revision

Viewing changes to debian/patches/12_micro_httpd.8--hyphen-fix.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Jari Aalto
  • Date: 2008-10-26 12:14:05 UTC
  • Revision ID: james.westby@ubuntu.com-20081026121405-beigvqqekry9yvoi
Tags: 20051212-10
* debian/README.Debian-source:
  - New file. Epxlain debian/*.8.
* debian/*.8
  - New file generated form *.8.pod. Original manual page is no longer
    used.
* debian/control:
  - (Description): Make more compact.
  - (Depends): Add alternatives 'micro-inetd | netcat-traditional'
    Closes: #482082. Remove unused ${misc:Depends}.
  - (Homepage): New field.
  - (Standards-Version): Update to 3.8.0.
  - (Suggests): move micro-inetd to 'Depends:' alternatives.
  - (Vcs-*): Add new fields.
* debian/micro-httpd.{postinst,prerm}:
  - Check if update-inetd command exists (superserver is not requirement).
  - Set PATH.
  - (IsInetd): New.
  - (MainInetd): New.
* debian/rules:
  - (man): New target.
  - (install): Adjust install calls
  - (binary-arch): Install manual page form debian/*.8
* debian/debian-vars.mk
  - New file

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## micro_httpd.8--hyphen-fix.diff.dpatch by  <jari.aalto@cante.net>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Hyphen fix
6
 
 
7
 
@DPATCH@
8
 
 
9
 
diff --git a/micro_httpd.8 b/micro_httpd.8
10
 
index 255425a..8167af0 100644
11
 
--- a/micro_httpd.8
12
 
+++ b/micro_httpd.8
13
 
@@ -1,15 +1,15 @@
14
 
-.TH micro-httpd 8 "15 March 1999"
15
 
+.TH micro\-httpd 8 "15 March 1999"
16
 
 .SH NAME
17
 
-micro-httpd - really small HTTP server
18
 
+micro\-httpd \- really small HTTP server
19
 
 .SH SYNOPSIS
20
 
-.B micro-httpd
21
 
+.B micro\-httpd
22
 
 .I directory
23
 
 .SH DESCRIPTION
24
 
 .PP
25
 
-.I micro-httpd
26
 
+.I micro\-httpd
27
 
 is a very small HTTP server.
28
 
 It runs from inetd, which means its performance is poor.
29
 
-But for low-traffic sites, it's quite adequate.
30
 
+But for low\-traffic sites, it's quite adequate.
31
 
 It implements all the basic features of an HTTP server, including:
32
 
 .TP 3
33
 
 *
34
 
@@ -19,7 +19,7 @@ Security against ".." filename snooping.
35
 
 The common MIME types.
36
 
 .TP 3
37
 
 *
38
 
-Trailing-slash redirection.
39
 
+Trailing\-slash redirection.
40
 
 .TP 3
41
 
 *
42
 
 index.html
43
 
@@ -31,37 +31,37 @@ All in 150 lines of code.
44
 
 .PP
45
 
 To install it, add a line like this to /etc/inetd.conf:
46
 
 .nf
47
 
-    micro-http  stream tcp nowait nobody  /usr/local/sbin/micro-httpd micro-httpd dir
48
 
+    micro\-http  stream tcp nowait nobody  /usr/local/sbin/micro\-httpd micro\-httpd dir
49
 
 .fi
50
 
 Make sure the path to the executable is correct, and change "dir" to be
51
 
 the directory you want to serve.
52
 
 Then add a line like this to /etc/services:
53
 
 .nf
54
 
-    micro-http   port/tcp   #Micro HTTP server
55
 
+    micro\-http   port/tcp   #Micro HTTP server
56
 
 .fi
57
 
-Change "port" to the port number you want to use - 80, 8000, whatever.
58
 
+Change "port" to the port number you want to use \- 80, 8000, whatever.
59
 
 Then restart inetd by sending it a "HUP" signal, or rebooting.
60
 
 .PP
61
 
-On some systems, inetd has a maximum spawn rate - if you try to run
62
 
+On some systems, inetd has a maximum spawn rate \- if you try to run
63
 
 inetd services faster than a certain number of times per minute, it
64
 
 assumed there's either a bug of an attack going on and it shuts down
65
 
 for a few minutes.
66
 
-If you run into this problem - look for syslog messages about too-rapid
67
 
-looping - you'll need to find out how to increase the limit.
68
 
+If you run into this problem \- look for syslog messages about too\-rapid
69
 
+looping \- you'll need to find out how to increase the limit.
70
 
 Unfortunately this varies from OS to OS.
71
 
-On FreeBSD, you add a "-R 10000" flag to inetd's initial command line.
72
 
-On some Linux systems, you can set the limit on a per-service basis
73
 
+On FreeBSD, you add a "\-R 10000" flag to inetd's initial command line.
74
 
+On some Linux systems, you can set the limit on a per\-service basis
75
 
 in inetd.conf, by changing "nowait" to "nowait.10000".
76
 
 .PP
77
 
-Note that you can use micro-httpd to serve HTTPS, if you like, by running
78
 
+Note that you can use micro\-httpd to serve HTTPS, if you like, by running
79
 
 it from stunnel.
80
 
-First fetch and install stunnel - FreeBSD users can just go to
81
 
+First fetch and install stunnel \- FreeBSD users can just go to
82
 
 /usr/ports/security/stunnel and do a "make cert ; make install".
83
 
 Then as root run:
84
 
 .nf
85
 
-    stunnel -p /usr/local/certs/stunnel.pem -d 443 \
86
 
-       -l /usr/local/sbin/micro-httpd -- \
87
 
-       micro-httpd dir
88
 
+    stunnel \-p /usr/local/certs/stunnel.pem \-d 443 \
89
 
+       \-l /usr/local/sbin/micro\-httpd \-\- \
90
 
+       micro\-httpd dir
91
 
 .fi
92
 
 Make sure the paths to the certificate and executable are correct, and
93
 
 again don't forget to change "dir" to the directory you want to serve.