~ubuntu-branches/ubuntu/wily/morse/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/03hardening.patch

  • Committer: Package Import Robot
  • Author(s): Nanakos Chrysostomos
  • Date: 2015-06-10 11:26:20 UTC
  • mfrom: (1.1.4)
  • mto: This revision was merged to the branch mainline in revision 11.
  • Revision ID: package-import@ubuntu.com-20150610112620-v6wvrpjyt6txhs0m
* New upstream release.
* Bump S-V to 3.9.6.
* Clean Lintian messages.
* Fix AlarmSet declaration and definition match (Closes: Bug#749420).
* Update watch file (Closes: Bug#784861).
* Fix build (omit morseALSA and morseLinux) for non-Linux arches
  - drop 02makefile.patch, build and install via debian/rules
* Fix -X crash (Closes: #716099, #716111, #716218, #716298)
* Adjust Maintainer/Uploaders fields

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Hardening
 
2
Author: Nanakos Chrysostomos <nanakos@wired-net.gr>
 
3
 
 
4
Index: morse-2.5/morse.d/Makefile
 
5
===================================================================
 
6
--- morse-2.5.orig/morse.d/Makefile
 
7
+++ morse-2.5/morse.d/Makefile
 
8
@@ -22,19 +22,19 @@ morse:      morse${DEVICE}
 
9
        ln morse${DEVICE} $@
 
10
 
 
11
 morseX11:      morse.o beepX11.o alarm.o
 
12
-       $(CC) $(X11LIBS) -o $@ morse.o beepX11.o alarm.o
 
13
+       $(CC) $(X11LIBS) $(LDFLAGS) -o $@ morse.o beepX11.o alarm.o
 
14
 
 
15
 morseLinux:    morse.o beepLinux.o alarm.o
 
16
-       $(CC) -o $@ morse.o beepLinux.o alarm.o -lm
 
17
+       $(CC) $(LDFLAGS) -o $@ morse.o beepLinux.o alarm.o -lm
 
18
 
 
19
 morseOSS:      morse.o beepOSS.o
 
20
-       $(CC) $(CFLAGS) -o $@ morse.o beepOSS.o -lm
 
21
+       $(CC) $(CFLAGS) $(LDFLAGS) -o $@ morse.o beepOSS.o -lm
 
22
 
 
23
 morsePA:       morse.o beepPA.o
 
24
-       $(CC) $(CFLAGS) $(PA_CFLAGS) -o $@ morse.o beepPA.o -lm $(PA_LIBS)
 
25
+       $(CC) $(CFLAGS) $(LDFLAGS) $(PA_CFLAGS) -o $@ morse.o beepPA.o -lm $(PA_LIBS)
 
26
 
 
27
 morseALSA:     morse.o beepALSA.o
 
28
-       $(CC) $(CFLAGS) $(ALSA_CFLAGS) -o $@ morse.o beepALSA.o -lm $(ALSA_LIBS)
 
29
+       $(CC) $(CFLAGS) $(LDFLAGS) $(ALSA_CFLAGS) -o $@ morse.o beepALSA.o -lm $(ALSA_LIBS)
 
30
 
 
31
 morse.o:       beep.h Makefile
 
32
 beepX11.o:     beep.h alarm.h
 
33
Index: morse-2.5/qso.d/Makefile
 
34
===================================================================
 
35
--- morse-2.5.orig/qso.d/Makefile
 
36
+++ morse-2.5/qso.d/Makefile
 
37
@@ -7,7 +7,7 @@ INCLUDES = antenna.h callsign.h city.h c
 
38
 all:   QSO
 
39
 
 
40
 QSO:   $(OBJECTS)
 
41
-       $(CC) -o $@ $(OBJECTS)
 
42
+       $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJECTS)
 
43
 
 
44
 init_str.o:    $(INCLUDES)
 
45