~ubuntu-branches/ubuntu/wily/mouseemu/wily

« back to all changes in this revision

Viewing changes to debian/patches/cross_build.dpatch

  • Committer: Package Import Robot
  • Author(s): Colin Watson
  • Date: 2012-11-22 02:00:01 UTC
  • Revision ID: package-import@ubuntu.com-20121122020001-hoebxfejomel5r02
Tags: 0.16-0ubuntu9
* Support cross-building.
* Use dpkg-buildflags.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## cross_build.dpatch by Colin Watson <cjwatson@ubuntu.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Honour CC, CPPFLAGS, CFLAGS, and LDFLAGS.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' mouseemu-0.16~/Makefile mouseemu-0.16/Makefile
 
9
--- mouseemu-0.16~/Makefile     2006-03-14 16:19:05.000000000 +0000
 
10
+++ mouseemu-0.16/Makefile      2012-11-22 01:44:41.000000000 +0000
 
11
@@ -1,5 +1,7 @@
 
12
+CC := gcc
 
13
+
 
14
 all:
 
15
-       gcc -Wall -g -o mouseemu mouseemu.c
 
16
+       $(CC) $(CPPFLAGS) $(CFLAGS) -Wall -g $(LDFLAGS) -o mouseemu mouseemu.c
 
17
 clean:
 
18
        rm -f *.o core* mouseemu
 
19
 install: