~ubuntu-branches/ubuntu/wily/mp3check/wily

« back to all changes in this revision

Viewing changes to debian/patches/01_restore_pristine_code.dpatch

  • Committer: Package Import Robot
  • Author(s): Sandro Tosi
  • Date: 2012-05-12 16:08:03 UTC
  • mfrom: (1.1.3)
  • Revision ID: package-import@ubuntu.com-20120512160803-o064g848g3lnvrzc
Tags: 0.8.4-1
* New upstream release
* debian/watch
  - updated
* debian/control
  - added Vcs-{Git, Browser} fields
  - added ${misc:Depends} to Depends line
  - bump Standards-Version to 3.9.3 (no changes needed)
* Converted to 3.0 (quilt) source format
* Converted to debhelper 9 and dh sequencer
* debian/copyright
  - updated to DEP5 and to new upstream release
* debian/patches/20_use_destdir_to_install.patch
  - install using DESTDIR variable
* debian/rules
  - upstream doesn't ship doc anymore
  - install the manpage (no longer done by upstream Makefile)
* debian/patches/15-bts667288-gcc-4.7.patch
  - fix FTBFS with GCC-4.7 (due to uncoordinated upload by gcc "maintainer");
    thanks to Jari Aalto for the patch; Closes: #667288
* debian/patches/30_bts624138_manpage_typo.patch
  - fix a typo in the manpage; thanks to Reuben Thomas for the report;
    Closes: #624138

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 01_restore_pristine_code.dpatch by Sandro Tosi <morph@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: New patch generated from mp3check 0.8.0-5 diff.gz
6
 
 
7
 
@DPATCH@
8
 
diff -urNad mp3check~/mp3check.cc mp3check/mp3check.cc
9
 
--- mp3check~/mp3check.cc       2008-03-19 22:36:02.000000000 +0100
10
 
+++ mp3check/mp3check.cc        2008-03-19 22:54:00.529146931 +0100
11
 
@@ -1137,7 +1137,7 @@
12
 
            // rewrite tag
13
 
            if(have_a_tag)
14
 
            {
15
 
-              if(tag->restore((unsigned char*)p)) {
16
 
+              if(tag->restore((unsigned char*)p )) {
17
 
                  fmes(name, "%scut-junk-end: tag successfully restored%s\n", cok, cnor);
18
 
               } else {
19
 
                  fmes(name, "%scut-junk-end: unable to restore tag, sorry%s\n", cok, cnor);
20
 
diff -urNad mp3check~/tstring.cc mp3check/tstring.cc
21
 
--- mp3check~/tstring.cc        2008-03-19 22:52:42.000000000 +0100
22
 
+++ mp3check/tstring.cc 2008-03-19 22:54:52.924132749 +0100
23
 
@@ -716,7 +716,7 @@
24
 
 
25
 
 void tstring::replaceUnprintable(bool only_ascii) {
26
 
    for(size_t i = 0; i < rep->len; i++) {
27
 
-      unsigned char& c = (unsigned char &)(*rep)[i];
28
 
+      char& c = (*rep)[i];
29
 
       if(!isprint(c)) {
30
 
         if(c < ' ') {
31
 
            c = '!';