~ubuntu-branches/ubuntu/wily/mupen64plus/wily

« back to all changes in this revision

Viewing changes to debian/patches/system-libpng.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sven Eckelmann
  • Date: 2011-07-24 14:23:26 UTC
  • mfrom: (10.1.2 experimental)
  • Revision ID: james.westby@ubuntu.com-20110724142326-x9z5qu8j9jecrmod
Tags: 1.99.4+2
* Upload to unstable
* Remove overrides for lintian warning about change to native package
* Update Vcs-* fields to new anonscm.debian.org URLs in debian/control
* Fix spelling of "Flexible" in debian/control (Closes: #633693)
* Mark all targets in debian/rules as phony
* Add some information about the mupen64plus 2.0 vision in debian/NEWS

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Use libpng from system instead of buildin one
2
 
Origin: backport, commit:1391
3
 
Bug: http://code.google.com/p/mupen64plus/issues/detail?id=235
4
 
Author: Sven Eckelmann <sven@narfation.org>
5
 
 
6
 
---
7
 
diff --git a/rice_video/Makefile b/rice_video/Makefile
8
 
index 3de7316d39f05db7e4a24fed47c96b8574e1be6b..02c9ad4ad834ea3f4575b5b87ff3569f1589eded 100644
9
 
--- a/rice_video/Makefile
10
 
+++ b/rice_video/Makefile
11
 
@@ -76,26 +76,12 @@ OBJECTS = OGLGraphicsContext.o \
12
 
        DecodedMux.o \
13
 
        RenderTexture.o \
14
 
        liblinux/BMGUtils.o \
15
 
-       liblinux/pngread.o \
16
 
-       liblinux/png.o \
17
 
-       liblinux/pngget.o \
18
 
-       liblinux/pngrtran.o \
19
 
-       liblinux/pngtrans.o \
20
 
-       liblinux/pngwrite.o \
21
 
-       liblinux/pngset.o \
22
 
-       liblinux/pngmem.o \
23
 
        OGLDecodedMux.o \
24
 
        CNvTNTCombiner.o \
25
 
        GeneralCombiner.o \
26
 
        DirectXDecodedMux.o \
27
 
-       liblinux/pngerror.o \
28
 
        liblinux/inflate.o \
29
 
-       liblinux/pngrio.o \
30
 
-       liblinux/pngrutil.o \
31
 
        liblinux/crc32.o \
32
 
-       liblinux/pngwutil.o \
33
 
-       liblinux/pngwio.o \
34
 
-       liblinux/pngwtran.o \
35
 
        liblinux/deflate.o \
36
 
        CombinerTable.o \
37
 
        liblinux/infblock.o \
38
 
@@ -131,7 +117,7 @@ targets:
39
 
 all: version.h ricevideo.so
40
 
 
41
 
 ricevideo.so: $(OBJECTS)
42
 
-       $(LD) $(OBJECTS) $(LDFLAGS) $(GTK_LIBS) -o $@
43
 
+       $(LD) $(OBJECTS) $(LDFLAGS) $(CORE_LDFLAGS) $(GTK_LIBS) -o $@
44
 
        $(STRIP) $@
45
 
 
46
 
 clean:
47
 
diff --git a/rice_video/liblinux/pngrw.c b/rice_video/liblinux/pngrw.c
48
 
index 039cb9838bc2796a52f906af7fb3ac4554136378..673741adbc1d75499100624572a6512fdefd39dc 100644
49
 
--- a/rice_video/liblinux/pngrw.c
50
 
+++ b/rice_video/liblinux/pngrw.c
51
 
@@ -29,13 +29,12 @@
52
 
 #include <ctype.h>
53
 
 #include <stdio.h>
54
 
 #include <stdlib.h>
55
 
-#include <setjmp.h>
56
 
 #ifdef _BMG_LIBPNG_STANDALONE
57
 
 #include "BMGLibPNG.h"
58
 
 #else
59
 
 #include "pngrw.h"
60
 
 #endif
61
 
-#include "png.h"
62
 
+#include <png.h>
63
 
 
64
 
 #ifndef png_jmpbuf
65
 
 #  define png_jmpbuf(png_ptr) ((png_ptr)->jmpbuf)