~ubuntu-branches/ubuntu/wily/net-dns-fingerprint/wily

« back to all changes in this revision

Viewing changes to debian/patches/02-apps-fpdns

  • Committer: Bazaar Package Importer
  • Author(s): Thorsten Alteholz
  • Date: 2009-10-09 18:00:00 UTC
  • Revision ID: james.westby@ubuntu.com-20091009180000-jqm13awijpkjs9lz
Tags: 0.9.3-3
* new maintainer (closes: #508842)
* debian/control: moved Homepage: field from description to header
* debian/control: changed Homepage: to new URL
* debian/rules: no upstream changelog -> used debian/changelog
* debian/rules: nothing to do for binary arch, so removed it
* debian/compat changed from 4 to 5
* watch file added
* changes in src moved to patches
* debian/README.source added
* debian/control: standards raised from 3.6.2 to 3.8.3 (no change required)
* debian/control: changed priority from extra to optional
* debian/control: changed typo in description (closes: #343707)
* applied patch from Thomas Parmelan (closes: #548307)
* Fingerprint.pm: - marked NLD versions as uncertain (closes: #282096)
                  - changed bind entries to latest version

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 02-apps-fpdns patch made by <debian@alteholz.de>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: 
 
6
 
 
7
 
 
8
@DPATCH@
 
9
 
 
10
--- Net-DNS-Fingerprint-0.9.3/apps/fpdns        2005-03-04 15:17:28.000000000 +0100
 
11
+++ net-dns-fingerprint-0.9.3/apps/fpdns        2009-10-08 22:23:37.000000000 +0200
 
12
@@ -52,12 +52,13 @@
 
13
     $opt{F} = 10;
 
14
     $opt{T} = undef;
 
15
     $opt{Q} = undef;
 
16
+    $opt{S} = " ";
 
17
 
 
18
     my %children;
 
19
 
 
20
     my $concurrent = 0;
 
21
 
 
22
-    getopts('Q:DF:p:t:r:cfsdTv', \%opt);
 
23
+    getopts('Q:DF:p:t:r:cfsS:dTv', \%opt);
 
24
 
 
25
     if ($opt{v}) {
 
26
        print STDERR "$progname version $version\n";
 
27
@@ -77,6 +78,7 @@
 
28
         forcetcp => $opt{T},
 
29
        qversion => $opt{v},
 
30
        qchaos   => $opt{f},
 
31
+       separator=> $opt{S},
 
32
     );
 
33
 
 
34
     if ($ARGV[0] eq "-") {
 
35
@@ -127,7 +129,7 @@
 
36
            }
 
37
        }
 
38
     } else {
 
39
-       print STDERR "host not found ($server)";
 
40
+       print STDERR "host not found ($server)\n";
 
41
     }
 
42
 }
 
43
 
 
44
@@ -150,6 +152,14 @@
 
45
                    push @addresses, $address_rr->address if $address_rr->type eq "A";
 
46
                 }
 
47
              }
 
48
+
 
49
+             my $query_address6 = $resolver->send($rr->rdatastr, "AAAA") if $rr->type eq "NS";
 
50
+             if ($query_address6) {
 
51
+                foreach my $address_rr ($query_address6->answer) {
 
52
+                   push @addresses, $address_rr->address if $address_rr->type eq "AAAA";
 
53
+                }
 
54
+             }
 
55
+
 
56
           }
 
57
        }
 
58
     } else { 
 
59
@@ -159,6 +169,16 @@
 
60
             push @addresses, $rr->address if $rr->type eq "A";
 
61
          }
 
62
        }
 
63
+
 
64
+       my $query6 = $resolver->send($arg, "AAAA");
 
65
+
 
66
+       if ($query6) {
 
67
+          foreach my $rr ($query6->answer) {
 
68
+             push @addresses, $rr->address if $rr->type eq "AAAA";
 
69
+          }
 
70
+       }
 
71
+
 
72
+
 
73
     }
 
74
 
 
75
     return @addresses;
 
76
@@ -179,6 +199,7 @@
 
77
        -Q srcaddr (source IP address) [0.0.0.0]
 
78
        -r retry   (set number of attempts) [1]
 
79
        -s        (short form) [off]
 
80
+       -S        (separator) [" "]
 
81
        -t time    (set query timeout) [5]
 
82
        -T         (use TCP) [off]
 
83
        -v         (show version)
 
84
@@ -199,7 +220,7 @@
 
85
 
 
86
 B<fpdns> S<[ B<-c> ]> S<[ B<-d> ]> S<[ B<-f> ]> S<[ B<-F> I<nchild> ]>
 
87
    S<[ B<-p> I<port> ]> S<[ B<-Q> I<srcaddr> ]> S<[ B<-r> I<retry> ]>
 
88
-   S<[ B<-s> ]>  S<[ B<-t> I<timeout> ]> S<[ B<-v> ]> [I<server(s)>]
 
89
+   S<[ B<-s> ]>  S<[ B<-S> I<separator> ]> S<[ B<-t> I<timeout> ]> S<[ B<-v> ]> [I<server(s)>]
 
90
 
 
91
 =head1 DESCRIPTION
 
92
 
 
93
@@ -254,6 +275,10 @@
 
94
 
 
95
 Short display form. Useful for surveys. 
 
96
 
 
97
+=item B<-S>
 
98
+
 
99
+Separator. Defaults to " ".
 
100
+
 
101
 =item B<-t> I<timeout>
 
102
 
 
103
 Set the query timeout in seconds. Defaults to 5.