~ubuntu-branches/ubuntu/wily/net-snmp/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/61_vacm_missing_dependency_check.patch

  • Committer: Bazaar Package Importer
  • Author(s): Chuck Short
  • Date: 2010-06-28 14:59:36 UTC
  • mfrom: (1.2.3 upstream) (1.1.12 sid)
  • Revision ID: james.westby@ubuntu.com-20100628145936-cbiallic69pn044g
Tags: 5.4.3~dfsg-1ubuntu1
* Merge from debian unstable.  Remaining changes:
  - Set Ubuntu maintainer address.
  - net-snmp-config: Use bash. (LP: #104738)
  - Removed multiuser option when calling update-rc.d. (LP: #254261)
  - debian/snmpd.init: LSBify the init script.
  - debian/patches/52_fix_snmpcmd_1_typo.patch: Adjust a typo in snmpcmd.1
    (LP: #250459)
  - debian/snmpd.postinst: source debconf before doing work, LP: #589056
  - debian/snmp.preinst, debian/snmp.prerm: kill any/all processes owned by
    snmp user before install/uninstall, LP: #573391
  - Add apport hook (LP: #533603):
  - debian/{snmp,snmpd}.apport: Added.
  - debian/control: Build-depends on dh-apport.
  - debian/rules: 
    + Add --with apport.
    + override_dh_apport to install hook on snmpd package only.
 * Dropped patches:
   - debian/patches/99-fix-ubuntu-div0.patch: Fix dvision by zero.. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/agent/agent_read_config.c
 
2
+++ b/agent/agent_read_config.c
 
3
@@ -282,7 +282,9 @@
 
4
     snmp_call_callbacks(SNMP_CALLBACK_APPLICATION,
 
5
                         SNMPD_CALLBACK_PRE_UPDATE_CONFIG, NULL);
 
6
     free_config();
 
7
+#ifdef USING_MIBII_VACM_CONF_MODULE
 
8
     vacm_standard_views(0,0,NULL,NULL);
 
9
+#endif
 
10
     read_configs();
 
11
 }
 
12
 
 
13
--- a/apps/snmptrapd.c
 
14
+++ b/apps/snmptrapd.c
 
15
@@ -1477,7 +1477,9 @@
 
16
 trapd_update_config(void)
 
17
 {
 
18
     free_config();
 
19
+#ifdef USING_MIBII_VACM_CONF_MODULE
 
20
     vacm_standard_views(0,0,NULL,NULL);
 
21
+#endif
 
22
     read_configs();
 
23
 }
 
24
 
 
25
--- a/apps/snmptrapd_auth.c
 
26
+++ b/apps/snmptrapd_auth.c
 
27
@@ -32,8 +32,10 @@
 
28
                                            netsnmp_trapd_auth);
 
29
     traph->authtypes = TRAP_AUTH_NONE;
 
30
 
 
31
+#ifdef USING_MIBII_VACM_CONF_MODULE
 
32
     /* register our configuration tokens for VACM configs */
 
33
     init_vacm_config_tokens();
 
34
+#endif
 
35
 
 
36
     /* register a config token for turning off the authorization entirely */
 
37
     netsnmp_ds_register_config(ASN_BOOLEAN, "snmptrapd", "disableAuthorization",
 
38
@@ -109,6 +111,7 @@
 
39
         return NETSNMPTRAPD_HANDLER_FINISH;
 
40
     }
 
41
 
 
42
+#ifdef USING_MIBII_VACM_CONF_MODULE
 
43
     /* check the pdu against each typo of VACM access we may want to
 
44
        check up on later.  We cache the results for future lookup on
 
45
        each call to netsnmp_trapd_check_auth */
 
46
@@ -125,6 +128,7 @@
 
47
         }
 
48
     }
 
49
     DEBUGMSGTL(("snmptrapd:auth", "Final bitmask auth: %x\n", ret));
 
50
+#endif
 
51
 
 
52
     if (ret) {
 
53
         /* we have policy to at least do "something".  Remember and continue. */