~ubuntu-branches/ubuntu/wily/netkit-telnet-ssl/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/045-avoid_unsetting_term.diff

  • Committer: Package Import Robot
  • Author(s): Mats Erik Andersson
  • Date: 2015-04-27 23:20:22 UTC
  • mfrom: (7.1.2 sid)
  • Revision ID: package-import@ubuntu.com-20150427232022-c2f04nl1gr4qyqom
Tags: 0.17.40+0.2-1
* Bring in package changes from experimental to unstable.
* Update to source version 0.17-40 of netkit-telnet.
  + debian/rules: Define and use the variable LDDEFS.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Avoid unsetting environment variable TERM.
 
2
 Do not reset TERM to "UNKNOWN", when it is unknown in the local host.
 
3
Author: Philippe Troin
 
4
Bug-Debian: http://bugs.debian.org/237324
 
5
Comment: interdiff netkit-telnet_0.17-{34,36}.diff
 
6
Forwarded: no
 
7
Last-Update: 2008-06-22
 
8
 
 
9
diff -u netkit-telnet-0.17/telnet/telnet.cc netkit-telnet-0.17/telnet/telnet.cc
 
10
--- netkit-telnet-0.17/telnet/telnet.cc
 
11
+++ netkit-telnet-0.17/telnet/telnet.cc
 
12
@@ -640,7 +640,7 @@
 
13
   if (resettermname) {
 
14
     resettermname = 0;
 
15
     tname = env_getvalue("TERM", 0);
 
16
-    if (!tname || my_setupterm(tname, 1, &err)) {
 
17
+    if (!tname /* || my_setupterm(tname, 1, &err) */) {
 
18
       termbuf[0] = 0;
 
19
       tname = "UNKNOWN";
 
20
     }