~ubuntu-branches/ubuntu/wily/network-manager-applet/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/lp330608_dxteam_gsm_connect_text.patch

  • Committer: Package Import Robot
  • Author(s): Mathieu Trudel-Lapierre
  • Date: 2015-01-26 23:08:58 UTC
  • mfrom: (1.2.37)
  • Revision ID: package-import@ubuntu.com-20150126230858-fmlex10ew00r1u9p
Tags: 0.9.10.1-0ubuntu1
* New upstream release: 0.9.10.1.
* Resync packaging with Debian:
  - debian/rules: Set DEB_HOST_MULTIARCH, use dh_install exclusions rather
    than removing .la and .a files separately. 
  - debian/control: Build-depends: update NM b-deps, 
    bump to dh 9, update libgtk/libglib2.0 b-deps versions and make
    libnm-gtk Multi-Arch-aware.
  - debian/*.install: update paths for multi-arch.
  - debian/compat: bump to compat level 9.
* debian/patches dropped because they were applied upstream:
  - git_use_paths_in_vpn_name_files_4867951.patch,
  - git_revert_system_ca_cert.patch,
  - lp289466_always_show_tray_icon.patch,
  - key-certificate-extensions.patch,
  - lp829673_gconf_hide_applet.patch,
  - 0001_Move_on_with_enter_in_the_country_page_of_the_new_mobile_wizard.patch
* debian/patches/lp328572-dxteam-connect-text.patch,
  debian/patches/lp330571_dxteam_wired_connect_text.patch,
  debian/patches/lp330608_dxteam_gsm_connect_text.patch: stop carrying
  needless string changes causing delta with upstream; any changes to the
  strings should happen there so we stay in sync.
  dropped; included upstream.
* Refreshed remaining patches.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
=== modified file 'src/applet-device-gsm.c'
2
 
---
3
 
 src/applet-device-broadband.c |   17 ++++++-----------
4
 
 src/applet-device-bt.c        |   12 ++++--------
5
 
 src/applet-device-cdma.c      |   17 ++++++-----------
6
 
 src/applet-device-gsm.c       |   13 ++++---------
7
 
 src/applet-device-wimax.c     |   13 ++++---------
8
 
 5 files changed, 24 insertions(+), 48 deletions(-)
9
 
 
10
 
Index: b/src/applet-device-gsm.c
11
 
===================================================================
12
 
--- a/src/applet-device-gsm.c
13
 
+++ b/src/applet-device-gsm.c
14
 
@@ -387,24 +387,19 @@ gsm_device_state_changed (NMDevice *devi
15
 
        if (new_state == NM_DEVICE_STATE_ACTIVATED) {
16
 
                NMConnection *connection;
17
 
                NMSettingConnection *s_con = NULL;
18
 
-               char *str = NULL;
19
 
+               const char *str = NULL;
20
 
 
21
 
                connection = applet_find_active_connection_for_device (device, applet, NULL);
22
 
                if (connection) {
23
 
-                       const char *id;
24
 
-
25
 
                        s_con = nm_connection_get_setting_connection (connection);
26
 
-                       id = s_con ? nm_setting_connection_get_id (s_con) : NULL;
27
 
-                       if (id)
28
 
-                               str = g_strdup_printf (_("You are now connected to '%s'."), id);
29
 
+                       str = s_con ? nm_setting_connection_get_id (s_con) : NULL;
30
 
                }
31
 
 
32
 
                applet_do_notify_with_pref (applet,
33
 
-                                           _("Connection Established"),
34
 
-                                           str ? str : _("You are now connected to the GSM network."),
35
 
+                                           _("Connected"),
36
 
+                                           str ? str : _("GSM network."),
37
 
                                            "nm-device-wwan",
38
 
                                            PREF_DISABLE_CONNECTED_NOTIFICATIONS);
39
 
-               g_free (str);
40
 
        }
41
 
 
42
 
        /* Start/stop polling of quality and registration when device state changes */
43
 
Index: b/src/applet-device-cdma.c
44
 
===================================================================
45
 
--- a/src/applet-device-cdma.c
46
 
+++ b/src/applet-device-cdma.c
47
 
@@ -333,24 +333,19 @@ cdma_device_state_changed (NMDevice *dev
48
 
        if (new_state == NM_DEVICE_STATE_ACTIVATED) {
49
 
                NMConnection *connection;
50
 
                NMSettingConnection *s_con = NULL;
51
 
-               char *str = NULL;
52
 
+               const char *str = NULL;
53
 
 
54
 
                connection = applet_find_active_connection_for_device (device, applet, NULL);
55
 
                if (connection) {
56
 
-                       const char *id;
57
 
-
58
 
                        s_con = nm_connection_get_setting_connection (connection);
59
 
-                       id = s_con ? nm_setting_connection_get_id (s_con) : NULL;
60
 
-                       if (id)
61
 
-                               str = g_strdup_printf (_("You are now connected to '%s'."), id);
62
 
+                       str = s_con ? nm_setting_connection_get_id (s_con) : NULL;
63
 
                }
64
 
 
65
 
                applet_do_notify_with_pref (applet,
66
 
-                                           _("Connection Established"),
67
 
-                                           str ? str : _("You are now connected to the CDMA network."),
68
 
+                                           _("Connected"),
69
 
+                                           str ? str : _("CDMA network"),
70
 
                                            "nm-device-wwan",
71
 
                                            PREF_DISABLE_CONNECTED_NOTIFICATIONS);
72
 
-               g_free (str);
73
 
        }
74
 
 
75
 
        /* Start/stop polling of quality and registration when device state changes */
76
 
@@ -414,13 +409,13 @@ notify_user_of_cdma_reg_change (CdmaDevi
77
 
 
78
 
        if (mb_state == MB_STATE_HOME) {
79
 
                applet_do_notify_with_pref (info->applet,
80
 
-                                           _("CDMA network."),
81
 
+                                           _("CDMA network"),
82
 
                                            _("You are now registered on the home network."),
83
 
                                            "nm-signal-100",
84
 
                                            PREF_DISABLE_CONNECTED_NOTIFICATIONS);
85
 
        } else if (mb_state == MB_STATE_ROAMING) {
86
 
                applet_do_notify_with_pref (info->applet,
87
 
-                                           _("CDMA network."),
88
 
+                                           _("CDMA network"),
89
 
                                            _("You are now registered on a roaming network."),
90
 
                                            "nm-signal-100",
91
 
                                            PREF_DISABLE_CONNECTED_NOTIFICATIONS);
92
 
Index: b/src/applet-device-bt.c
93
 
===================================================================
94
 
--- a/src/applet-device-bt.c
95
 
+++ b/src/applet-device-bt.c
96
 
@@ -184,23 +184,19 @@ bt_device_state_changed (NMDevice *devic
97
 
        if (new_state == NM_DEVICE_STATE_ACTIVATED) {
98
 
                NMConnection *connection;
99
 
                NMSettingConnection *s_con = NULL;
100
 
-               char *str = NULL;
101
 
+               const char *str = NULL;
102
 
 
103
 
                connection = applet_find_active_connection_for_device (device, applet, NULL);
104
 
                if (connection) {
105
 
-                       const char *id;
106
 
                        s_con = nm_connection_get_setting_connection (connection);
107
 
-                       id = s_con ? nm_setting_connection_get_id (s_con) : NULL;
108
 
-                       if (id)
109
 
-                               str = g_strdup_printf (_("You are now connected to '%s'."), id);
110
 
+                       str = s_con ? nm_setting_connection_get_id (s_con) : NULL;
111
 
                }
112
 
 
113
 
                applet_do_notify_with_pref (applet,
114
 
-                                           _("Connection Established"),
115
 
-                                           str ? str : _("You are now connected to the mobile broadband network."),
116
 
+                                           _("Connected"),
117
 
+                                           str ? str : _("Mobile Broadband network"),
118
 
                                            "nm-device-wwan",
119
 
                                            PREF_DISABLE_CONNECTED_NOTIFICATIONS);
120
 
-               g_free (str);
121
 
        }
122
 
 }
123
 
 
124
 
Index: b/src/applet-device-broadband.c
125
 
===================================================================
126
 
--- a/src/applet-device-broadband.c
127
 
+++ b/src/applet-device-broadband.c
128
 
@@ -796,27 +796,22 @@ device_state_changed (NMDevice *device,
129
 
 {
130
 
        NMConnection *connection;
131
 
        NMSettingConnection *s_con = NULL;
132
 
-       char *str = NULL;
133
 
+       const char *str = NULL;
134
 
 
135
 
        if (new_state != NM_DEVICE_STATE_ACTIVATED)
136
 
                return;
137
 
 
138
 
        connection = applet_find_active_connection_for_device (device, applet, NULL);
139
 
        if (connection) {
140
 
-               const char *id;
141
 
-
142
 
                s_con = nm_connection_get_setting_connection (connection);
143
 
-               id = s_con ? nm_setting_connection_get_id (s_con) : NULL;
144
 
-               if (id)
145
 
-                       str = g_strdup_printf (_("You are now connected to '%s'."), id);
146
 
+               str = s_con ? nm_setting_connection_get_id (s_con) : NULL;
147
 
        }
148
 
 
149
 
        applet_do_notify_with_pref (applet,
150
 
-                                   _("Connection Established"),
151
 
-                                   str ? str : _("You are now connected to the Mobile Broadband network."),
152
 
+                                   _("Connected"),
153
 
+                                   str ? str : _("Mobile Broadband network"),
154
 
                                    "nm-device-wwan",
155
 
                                    PREF_DISABLE_CONNECTED_NOTIFICATIONS);
156
 
-       g_free (str);
157
 
 }
158
 
 
159
 
 /********************************************************************/
160
 
@@ -949,13 +944,13 @@ modem_state_changed (MMModem *object,
161
 
                mb_state = broadband_state_to_mb_state (info);
162
 
                if (mb_state == MB_STATE_HOME) {
163
 
                        applet_do_notify_with_pref (info->applet,
164
 
-                                                   _("Mobile Broadband network."),
165
 
+                                                   _("Mobile Broadband network"),
166
 
                                                    _("You are now registered on the home network."),
167
 
                                                    "nm-signal-100",
168
 
                                                    PREF_DISABLE_CONNECTED_NOTIFICATIONS);
169
 
                } else if (mb_state == MB_STATE_ROAMING) {
170
 
                        applet_do_notify_with_pref (info->applet,
171
 
-                                                   _("Mobile Broadband network."),
172
 
+                                                   _("Mobile Broadband network"),
173
 
                                                    _("You are now registered on a roaming network."),
174
 
                                                    "nm-signal-100",
175
 
                                                    PREF_DISABLE_CONNECTED_NOTIFICATIONS);
176
 
Index: b/src/applet-device-wimax.c
177
 
===================================================================
178
 
--- a/src/applet-device-wimax.c
179
 
+++ b/src/applet-device-wimax.c
180
 
@@ -407,24 +407,19 @@ wimax_device_state_changed (NMDevice *de
181
 
        if (new_state == NM_DEVICE_STATE_ACTIVATED) {
182
 
                NMConnection *connection;
183
 
                NMSettingConnection *s_con = NULL;
184
 
-               char *str = NULL;
185
 
+               const char *str = NULL;
186
 
 
187
 
                connection = applet_find_active_connection_for_device (device, applet, NULL);
188
 
                if (connection) {
189
 
-                       const char *id;
190
 
-
191
 
                        s_con = nm_connection_get_setting_connection (connection);
192
 
-                       id = s_con ? nm_setting_connection_get_id (s_con) : NULL;
193
 
-                       if (id)
194
 
-                               str = g_strdup_printf (_("You are now connected to '%s'."), id);
195
 
+                       str = s_con ? nm_setting_connection_get_id (s_con) : NULL;
196
 
                }
197
 
 
198
 
                applet_do_notify_with_pref (applet,
199
 
-                                           _("Connection Established"),
200
 
-                                           str ? str : _("You are now connected to the WiMAX network."),
201
 
+                                           _("Connected"),
202
 
+                                           str ? str : _("WiMAX network"),
203
 
                                            "nm-device-wwan",
204
 
                                            PREF_DISABLE_CONNECTED_NOTIFICATIONS);
205
 
-               g_free (str);
206
 
        }
207
 
 }
208