~ubuntu-branches/ubuntu/wily/nilfs-tools/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01-ldd.patch

  • Committer: Package Import Robot
  • Author(s): Daniel Baumann
  • Date: 2011-10-30 20:26:51 UTC
  • Revision ID: package-import@ubuntu.com-20111030202651-rz80qxjim4fl49co
Tags: 2.1.0~rc2-2
* Using compression level 9 also for binary packages.
* Adding patch from Ilya Barygin <randomaction@ubuntu.com> to fix
  FTBFS with as-needed linker option (Closes: #646967).
* Updating year in copyright.
* Sorting overrides alphabetically in rules.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Ilya Barygin <randomaction@ubuntu.com>
 
2
Description:
 
3
 Fix FTBFS with as-needed linker option (Closes: #646967).
 
4
 .
 
5
 libnilfscleaner.so uses symbols from libnilfs.so, so it should come first in
 
6
 the argument list
 
7
 
 
8
diff -Naurp nilfs-tools.orig/sbin/nilfs-clean/Makefile.am nilfs-tools/sbin/nilfs-clean/Makefile.am
 
9
--- nilfs-tools.orig/sbin/nilfs-clean/Makefile.am       2011-10-28 21:18:38.993837954 +0200
 
10
+++ nilfs-tools/sbin/nilfs-clean/Makefile.am    2011-10-28 21:18:52.273899009 +0200
 
11
@@ -2,8 +2,8 @@
 
12
 
 
13
 AM_CFLAGS = -Wall
 
14
 AM_CPPFLAGS = -I$(top_srcdir)/include
 
15
-LDADD = $(top_builddir)/lib/libnilfs.la \
 
16
-       $(top_builddir)/lib/libnilfscleaner.la
 
17
+LDADD = $(top_builddir)/lib/libnilfscleaner.la \
 
18
+       $(top_builddir)/lib/libnilfs.la
 
19
 
 
20
 sbin_PROGRAMS = nilfs-clean
 
21
 
 
22
diff -Naurp nilfs-tools.orig/sbin/nilfs-clean/Makefile.in nilfs-tools/sbin/nilfs-clean/Makefile.in
 
23
--- nilfs-tools.orig/sbin/nilfs-clean/Makefile.in       2011-10-28 21:18:38.993837954 +0200
 
24
+++ nilfs-tools/sbin/nilfs-clean/Makefile.in    2011-10-28 21:18:52.273899009 +0200
 
25
@@ -182,8 +182,8 @@ top_builddir = @top_builddir@
 
26
 top_srcdir = @top_srcdir@
 
27
 AM_CFLAGS = -Wall
 
28
 AM_CPPFLAGS = -I$(top_srcdir)/include
 
29
-LDADD = $(top_builddir)/lib/libnilfs.la \
 
30
-       $(top_builddir)/lib/libnilfscleaner.la
 
31
+LDADD = $(top_builddir)/lib/libnilfscleaner.la \
 
32
+       $(top_builddir)/lib/libnilfs.la
 
33
 
 
34
 nilfs_clean_SOURCES = nilfs-clean.c
 
35
 all: all-am