~ubuntu-branches/ubuntu/wily/octave-miscellaneous/wily

« back to all changes in this revision

Viewing changes to debian/patches/partcnt-test-succeeds.patch

  • Committer: Package Import Robot
  • Author(s): Sébastien Villemot, Rafael Laboissiere, Sébastien Villemot
  • Date: 2012-10-17 13:40:55 UTC
  • mfrom: (1.2.1) (12 sid)
  • mto: This revision was merged to the branch mainline in revision 13.
  • Revision ID: package-import@ubuntu.com-20121017134055-vatltexghy77fnv7
Tags: 1.2.0-1
[ Rafael Laboissiere ]
* Imported Upstream version 1.2.0
* Bump Standards-Version to 3.9.4 (no changes needed)
* Refresh for new upstream release
* Use Sébastien Villemot's @debian.org email address
* Remove obsolete DM-Upload-Allowed flag
* Add patch autoload-yes.patch
* Add copyright info for file lauchli.m (included in a Debian patch)
* Add patch partcnt-test-succeeds.patch
* Build-depends on octave-pkg-dev >= 1.0.3

[ Sébastien Villemot ]
* debian/control: fix versioned dependency on debhelper
* Add lintian override for false positive on hardening (fortify)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Make the unit testing for partcnt succeed
 
2
 The partcnt function is defined in the partint.cc file, hence it is necessary
 
3
 to run the autoload comamnd first.  This is needed only when building the
 
4
 Debian package, since the autoload command is run through the PKG_ADD file for
 
5
 the installed octave-miscellaneous package.
 
6
Author: Rafael Laboissiere <rafael@laboissiere.net>
 
7
Forwarded: not-needed
 
8
Last-Update: 2012-10-17
 
9
 
 
10
--- octave-miscellaneous-1.2.0.orig/src/partint.cc
 
11
+++ octave-miscellaneous-1.2.0/src/partint.cc
 
12
@@ -110,11 +110,13 @@ Joerg Arndt: Algorithms for programmers
 
13
 
 
14
 /*
 
15
 
 
16
-%!assert(partcnt(1), 1);
 
17
-%!assert(partcnt(17), 297);
 
18
-%!fail("partcnt()", "partcnt");
 
19
-%!fail("partcnt(1,2)", "partcnt");
 
20
-%!fail("partcnt('xyz')", "partcnt");
 
21
+%!test
 
22
+%! autoload ("partcnt", "partint.oct")
 
23
+%! assert(partcnt(1), 1);
 
24
+%! assert(partcnt(17), 297); 
 
25
+%! fail("partcnt()", "partcnt");
 
26
+%! fail("partcnt(1,2)", "partcnt");
 
27
+%! fail("partcnt('xyz')", "partcnt");
 
28
 %!demo
 
29
 %! p = partcnt([1, 5; 17 -5])
 
30