~ubuntu-branches/ubuntu/wily/openjdk-7/wily

« back to all changes in this revision

Viewing changes to debian/patches/kfreebsd-support-jdk.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2012-04-11 07:21:41 UTC
  • mfrom: (1.3.8) (8.1.20 sid)
  • Revision ID: package-import@ubuntu.com-20120411072141-v8i0x0ejg8sf7i5p
Tags: 7~u3-2.1.1~pre1-1ubuntu1
Regenerate the control file.

Show diffs side-by-side

added added

removed removed

Lines of Context:
20
20
Author: Damien Raude-Morvan <drazzib@debian.org>
21
21
Last-Update: 2011-09-14
22
22
Forwarded: no
23
 
Index: openjdk/jdk/make/com/sun/nio/Makefile
24
 
===================================================================
25
23
--- openjdk/jdk/make/com/sun/nio/Makefile.orig
26
24
+++ openjdk/jdk/make/com/sun/nio/Makefile
27
25
@@ -30,11 +30,11 @@
40
38
 clean clobber::
41
39
-       $(RM) -r $(CLASSDESTDIR)/com/sun/nio
42
40
+#      $(RM) -r $(CLASSDESTDIR)/com/sun/nio
43
 
Index: openjdk/jdk/make/common/shared/Defs-versions.gmk
44
 
===================================================================
45
41
--- openjdk/jdk/make/common/shared/Defs-versions.gmk.orig
46
42
+++ openjdk/jdk/make/common/shared/Defs-versions.gmk
47
43
@@ -148,7 +148,9 @@
55
51
   REQUIRED_COMPILER_NAME      = GCC4
56
52
   REQUIRED_COMPILER_VERSION   = GCC4
57
53
   REQUIRED_GCC_VER            = 2.95
58
 
Index: openjdk/jdk/make/common/shared/Platform.gmk
59
 
===================================================================
60
54
--- openjdk/jdk/make/common/shared/Platform.gmk.orig
61
55
+++ openjdk/jdk/make/common/shared/Platform.gmk
62
56
@@ -152,7 +152,7 @@
68
62
   PLATFORM = linux
69
63
   # Arch and OS name/version
70
64
   ifdef CROSS_COMPILE_ARCH
71
 
Index: openjdk/jdk/make/common/shared/Sanity-Settings.gmk
72
 
===================================================================
73
65
--- openjdk/jdk/make/common/shared/Sanity-Settings.gmk.orig
74
66
+++ openjdk/jdk/make/common/shared/Sanity-Settings.gmk
75
67
@@ -186,8 +186,10 @@
83
75
 endif
84
76
 ALL_SETTINGS+=$(call addRequiredVersionSetting,OS_VERSION)
85
77
 ALL_SETTINGS+=$(call addOptionalSetting,OS_VARIANT_NAME)
86
 
Index: openjdk/jdk/make/common/shared/Sanity.gmk
87
 
===================================================================
88
78
--- openjdk/jdk/make/common/shared/Sanity.gmk.orig
89
79
+++ openjdk/jdk/make/common/shared/Sanity.gmk
90
80
@@ -114,12 +114,14 @@
102
92
 
103
93
 ifeq ($(PLATFORM), windows)
104
94
   # Windows 2000 is 5.0, Windows XP is 5.1, Windows 2003 is 5.2
105
 
Index: openjdk/jdk/make/java/nio/Makefile
106
 
===================================================================
107
95
--- openjdk/jdk/make/java/nio/Makefile.orig
108
96
+++ openjdk/jdk/make/java/nio/Makefile
109
97
@@ -94,6 +94,70 @@
223
211
 ifndef USE_SYSTEM_GIO
224
212
 FILES_c += \
225
213
        gio_fp.c
226
 
Index: openjdk/jdk/make/javax/sound/Makefile
227
 
===================================================================
228
214
--- openjdk/jdk/make/javax/sound/Makefile.orig
229
215
+++ openjdk/jdk/make/javax/sound/Makefile
230
216
@@ -99,10 +99,12 @@
240
226
 endif # PLATFORM linux
241
227
 
242
228
 ifeq ($(PLATFORM), solaris)
243
 
Index: openjdk/jdk/src/share/classes/com/sun/servicetag/Installer.java
244
 
===================================================================
245
229
--- openjdk/jdk/src/share/classes/com/sun/servicetag/Installer.java.orig
246
230
+++ openjdk/jdk/src/share/classes/com/sun/servicetag/Installer.java
247
231
@@ -549,7 +549,7 @@
253
237
             // Traverse the directories under <JRE>/lib.
254
238
             // If <JRE>/lib/<arch>/libjava.so exists, add <arch>
255
239
             // to the product defined ID
256
 
Index: openjdk/jdk/src/share/classes/com/sun/servicetag/Registry.java
257
 
===================================================================
258
240
--- openjdk/jdk/src/share/classes/com/sun/servicetag/Registry.java.orig
259
241
+++ openjdk/jdk/src/share/classes/com/sun/servicetag/Registry.java
260
242
@@ -84,7 +84,7 @@
266
248
                 stclient = new File(STCLIENT_LINUX);
267
249
             } else if (os.startsWith("Windows")) {
268
250
                 stclient = getWindowsStClientFile();
269
 
Index: openjdk/jdk/src/share/classes/com/sun/servicetag/SystemEnvironment.java
270
 
===================================================================
271
251
--- openjdk/jdk/src/share/classes/com/sun/servicetag/SystemEnvironment.java.orig
272
252
+++ openjdk/jdk/src/share/classes/com/sun/servicetag/SystemEnvironment.java
273
253
@@ -61,7 +61,7 @@
279
259
                 sysEnv = new LinuxSystemEnvironment();
280
260
             } else if (os.startsWith("Windows")) {
281
261
                 sysEnv = new WindowsSystemEnvironment();
282
 
Index: openjdk/jdk/src/share/classes/java/awt/GraphicsEnvironment.java
283
 
===================================================================
284
262
--- openjdk/jdk/src/share/classes/java/awt/GraphicsEnvironment.java.orig
285
263
+++ openjdk/jdk/src/share/classes/java/awt/GraphicsEnvironment.java
286
264
@@ -172,7 +172,7 @@
292
270
                                                 (System.getenv("DISPLAY") == null));
293
271
                         }
294
272
                     } else if (nm.equals("true")) {
295
 
Index: openjdk/jdk/src/share/classes/sun/font/FontUtilities.java
296
 
===================================================================
297
273
--- openjdk/jdk/src/share/classes/sun/font/FontUtilities.java.orig
298
274
+++ openjdk/jdk/src/share/classes/sun/font/FontUtilities.java
299
275
@@ -74,7 +74,7 @@
305
281
 
306
282
                 String t2kStr = System.getProperty("sun.java2d.font.scaler");
307
283
                 if (t2kStr != null) {
308
 
Index: openjdk/jdk/src/share/classes/sun/nio/cs/ext/ExtendedCharsets.java
309
 
===================================================================
310
284
--- openjdk/jdk/src/share/classes/sun/nio/cs/ext/ExtendedCharsets.java.orig
311
285
+++ openjdk/jdk/src/share/classes/sun/nio/cs/ext/ExtendedCharsets.java
312
286
@@ -1279,7 +1279,7 @@
318
292
             charset("x-COMPOUND_TEXT", "COMPOUND_TEXT",
319
293
                     new String[] {
320
294
                         "COMPOUND_TEXT",        // JDK historical
321
 
Index: openjdk/jdk/src/share/classes/sun/print/PSPrinterJob.java
322
 
===================================================================
323
295
--- openjdk/jdk/src/share/classes/sun/print/PSPrinterJob.java.orig
324
296
+++ openjdk/jdk/src/share/classes/sun/print/PSPrinterJob.java
325
297
@@ -1534,7 +1534,7 @@
331
303
             execCmd = new String[ncomps];
332
304
             execCmd[n++] = "/usr/bin/lpr";
333
305
             if ((pFlags & PRINTER) != 0) {
334
 
Index: openjdk/jdk/src/share/classes/sun/security/jgss/GSSManagerImpl.java
335
 
===================================================================
336
306
--- openjdk/jdk/src/share/classes/sun/security/jgss/GSSManagerImpl.java.orig
337
307
+++ openjdk/jdk/src/share/classes/sun/security/jgss/GSSManagerImpl.java
338
308
@@ -48,6 +48,7 @@
343
313
                                 osname.startsWith("Linux")) {
344
314
                                 return new Boolean(System.getProperty
345
315
                                     (USE_NATIVE_PROP));
346
 
Index: openjdk/jdk/src/share/classes/sun/security/krb5/internal/ccache/FileCredentialsCache.java
347
 
===================================================================
348
316
--- openjdk/jdk/src/share/classes/sun/security/krb5/internal/ccache/FileCredentialsCache.java.orig
349
317
+++ openjdk/jdk/src/share/classes/sun/security/krb5/internal/ccache/FileCredentialsCache.java
350
318
@@ -403,6 +403,7 @@
355
323
                 (osname.startsWith("Linux"))) {
356
324
                 try {
357
325
                     Class<?> c = Class.forName
358
 
Index: openjdk/jdk/src/share/native/java/lang/fdlibm/include/jfdlibm.h
359
 
===================================================================
360
326
--- openjdk/jdk/src/share/native/java/lang/fdlibm/include/jfdlibm.h.orig
361
327
+++ openjdk/jdk/src/share/native/java/lang/fdlibm/include/jfdlibm.h
362
328
@@ -61,7 +61,7 @@
368
334
 #define __ieee754_sqrt          __j__ieee754_sqrt
369
335
 #define __ieee754_acos          __j__ieee754_acos
370
336
 #define __ieee754_log           __j__ieee754_log
371
 
Index: openjdk/jdk/src/share/native/sun/security/ec/impl/ecc_impl.h
372
 
===================================================================
373
337
--- openjdk/jdk/src/share/native/sun/security/ec/impl/ecc_impl.h.orig
374
338
+++ openjdk/jdk/src/share/native/sun/security/ec/impl/ecc_impl.h
375
339
@@ -49,7 +49,7 @@
381
345
 #define B_FALSE FALSE
382
346
 #define B_TRUE TRUE
383
347
 typedef unsigned char uint8_t;
384
 
Index: openjdk/jdk/src/solaris/bin/ergo_i586.c
385
 
===================================================================
386
348
--- openjdk/jdk/src/solaris/bin/ergo_i586.c.orig
387
349
+++ openjdk/jdk/src/solaris/bin/ergo_i586.c
388
350
@@ -106,7 +106,7 @@
394
356
 
395
357
 /*
396
358
  * A utility method for asking the CPU about itself.
397
 
Index: openjdk/jdk/src/solaris/bin/java_md.c
398
 
===================================================================
399
359
--- openjdk/jdk/src/solaris/bin/java_md.c.orig
400
360
+++ openjdk/jdk/src/solaris/bin/java_md.c
401
361
@@ -37,7 +37,7 @@
443
403
     const char *substr = "-Dsun.java.launcher.pid=";
444
404
     char *pid_prop_str = (char *)JLI_MemAlloc(JLI_StrLen(substr) + MAX_PID_STR_SZ + 1);
445
405
     sprintf(pid_prop_str, "%s%d", substr, getpid());
446
 
Index: openjdk/jdk/src/solaris/bin/jexec.c
447
 
===================================================================
448
406
--- openjdk/jdk/src/solaris/bin/jexec.c.orig
449
407
+++ openjdk/jdk/src/solaris/bin/jexec.c
450
408
@@ -76,7 +76,7 @@
519
477
 /*
520
478
  * Check if the given file is a JAR file.
521
479
  *
522
 
Index: openjdk/jdk/src/solaris/classes/sun/awt/X11/XScrollbarPeer.java
523
 
===================================================================
524
480
--- openjdk/jdk/src/solaris/classes/sun/awt/X11/XScrollbarPeer.java.orig
525
481
+++ openjdk/jdk/src/solaris/classes/sun/awt/X11/XScrollbarPeer.java
526
482
@@ -74,7 +74,7 @@
532
488
             return DEFAULT_WIDTH_LINUX;
533
489
         } else {
534
490
             return DEFAULT_WIDTH_SOLARIS;
535
 
Index: openjdk/jdk/src/solaris/classes/sun/font/FcFontConfiguration.java
536
 
===================================================================
537
491
--- openjdk/jdk/src/solaris/classes/sun/font/FcFontConfiguration.java.orig
538
492
+++ openjdk/jdk/src/solaris/classes/sun/font/FcFontConfiguration.java
539
493
@@ -294,7 +294,7 @@
545
499
             return;
546
500
         }
547
501
         try {
548
 
Index: openjdk/jdk/src/solaris/classes/sun/nio/ch/DefaultAsynchronousChannelProvider.java
549
 
===================================================================
550
502
--- openjdk/jdk/src/solaris/classes/sun/nio/ch/DefaultAsynchronousChannelProvider.java.orig
551
503
+++ openjdk/jdk/src/solaris/classes/sun/nio/ch/DefaultAsynchronousChannelProvider.java
552
504
@@ -48,7 +48,7 @@
558
510
             return new LinuxAsynchronousChannelProvider();
559
511
         throw new InternalError("platform not recognized");
560
512
     }
561
 
Index: openjdk/jdk/src/solaris/classes/sun/nio/fs/DefaultFileSystemProvider.java
562
 
===================================================================
563
513
--- openjdk/jdk/src/solaris/classes/sun/nio/fs/DefaultFileSystemProvider.java.orig
564
514
+++ openjdk/jdk/src/solaris/classes/sun/nio/fs/DefaultFileSystemProvider.java
565
515
@@ -66,7 +66,7 @@
571
521
             return createProvider("sun.nio.fs.LinuxFileSystemProvider");
572
522
         throw new AssertionError("Platform not recognized");
573
523
     }
574
 
Index: openjdk/jdk/src/solaris/classes/sun/nio/fs/LinuxDosFileAttributeView.java
575
 
===================================================================
576
524
--- openjdk/jdk/src/solaris/classes/sun/nio/fs/LinuxDosFileAttributeView.java.orig
577
525
+++ openjdk/jdk/src/solaris/classes/sun/nio/fs/LinuxDosFileAttributeView.java
578
526
@@ -238,9 +238,6 @@
585
533
             throw x;
586
534
         } finally {
587
535
             buffer.release();
588
 
Index: openjdk/jdk/src/solaris/classes/sun/nio/fs/LinuxFileStore.java
589
 
===================================================================
590
536
--- openjdk/jdk/src/solaris/classes/sun/nio/fs/LinuxFileStore.java.orig
591
537
+++ openjdk/jdk/src/solaris/classes/sun/nio/fs/LinuxFileStore.java
592
538
@@ -101,9 +101,7 @@
600
546
             } finally {
601
547
                 UnixNativeDispatcher.close(fd);
602
548
             }
603
 
Index: openjdk/jdk/src/solaris/classes/sun/print/UnixPrintServiceLookup.java
604
 
===================================================================
605
549
--- openjdk/jdk/src/solaris/classes/sun/print/UnixPrintServiceLookup.java.orig
606
550
+++ openjdk/jdk/src/solaris/classes/sun/print/UnixPrintServiceLookup.java
607
551
@@ -119,7 +119,7 @@
613
557
     }
614
558
 
615
559
     static final int UNINITIALIZED = -1;
616
 
Index: openjdk/jdk/src/solaris/native/com/sun/management/UnixOperatingSystem_md.c
617
 
===================================================================
618
560
--- openjdk/jdk/src/solaris/native/com/sun/management/UnixOperatingSystem_md.c.orig
619
561
+++ openjdk/jdk/src/solaris/native/com/sun/management/UnixOperatingSystem_md.c
620
562
@@ -35,7 +35,9 @@
650
592
 #endif
651
593
 }
652
594
 
653
 
Index: openjdk/jdk/src/solaris/native/java/io/io_util_md.c
654
 
===================================================================
655
595
--- openjdk/jdk/src/solaris/native/java/io/io_util_md.c.orig
656
596
+++ openjdk/jdk/src/solaris/native/java/io/io_util_md.c
657
597
@@ -36,7 +36,7 @@
663
603
         /* Remove trailing slashes, since the kernel won't */
664
604
         char *p = (char *)ps + strlen(ps) - 1;
665
605
         while ((p > ps) && (*p == '/'))
666
 
Index: openjdk/jdk/src/solaris/native/java/lang/UNIXProcess_md.c
667
 
===================================================================
668
606
--- openjdk/jdk/src/solaris/native/java/lang/UNIXProcess_md.c.orig
669
607
+++ openjdk/jdk/src/solaris/native/java/lang/UNIXProcess_md.c
670
608
@@ -93,7 +93,7 @@
685
623
     #define START_CHILD_USE_VFORK 1
686
624
   #else
687
625
     #define START_CHILD_USE_VFORK 0
688
 
Index: openjdk/jdk/src/solaris/native/java/lang/java_props_md.c
689
 
===================================================================
690
626
--- openjdk/jdk/src/solaris/native/java/lang/java_props_md.c.orig
691
627
+++ openjdk/jdk/src/solaris/native/java/lang/java_props_md.c
692
628
@@ -23,7 +23,7 @@
734
670
 #if __BYTE_ORDER == __LITTLE_ENDIAN
735
671
     sprops.unicode_encoding = "UnicodeLittle";
736
672
 #else
737
 
Index: openjdk/jdk/src/solaris/native/java/lang/locale_str.h
738
 
===================================================================
739
673
--- openjdk/jdk/src/solaris/native/java/lang/locale_str.h.orig
740
674
+++ openjdk/jdk/src/solaris/native/java/lang/locale_str.h
741
675
@@ -48,7 +48,7 @@
798
732
     "RN", "US", // used on Linux, not clear what it stands for
799
733
 #endif
800
734
     "YU", "CS", // YU has been removed from ISO 3166
801
 
Index: openjdk/jdk/src/solaris/native/java/net/Inet4AddressImpl.c
802
 
===================================================================
803
735
--- openjdk/jdk/src/solaris/native/java/net/Inet4AddressImpl.c.orig
804
736
+++ openjdk/jdk/src/solaris/native/java/net/Inet4AddressImpl.c
805
737
@@ -64,7 +64,7 @@
829
761
         case EINVAL:
830
762
           /*
831
763
            * On some Linuxes, when bound to the loopback interface, connect
832
 
Index: openjdk/jdk/src/solaris/native/java/net/Inet6AddressImpl.c
833
 
===================================================================
834
764
--- openjdk/jdk/src/solaris/native/java/net/Inet6AddressImpl.c.orig
835
765
+++ openjdk/jdk/src/solaris/native/java/net/Inet6AddressImpl.c
836
766
@@ -70,7 +70,7 @@
860
790
         case EINVAL:
861
791
           /*
862
792
            * On some Linuxes, when bound to the loopback interface, connect
863
 
Index: openjdk/jdk/src/solaris/native/java/net/NetworkInterface.c
864
 
===================================================================
865
793
--- openjdk/jdk/src/solaris/native/java/net/NetworkInterface.c.orig
866
794
+++ openjdk/jdk/src/solaris/native/java/net/NetworkInterface.c
867
795
@@ -53,6 +53,17 @@
1197
1125
+
1198
1126
+
1199
1127
 
1200
 
Index: openjdk/jdk/src/solaris/native/java/net/PlainDatagramSocketImpl.c
1201
 
===================================================================
1202
1128
--- openjdk/jdk/src/solaris/native/java/net/PlainDatagramSocketImpl.c.orig
1203
1129
+++ openjdk/jdk/src/solaris/native/java/net/PlainDatagramSocketImpl.c
1204
1130
@@ -33,7 +33,7 @@
1265
1191
 #else
1266
1192
     JVM_Connect(fd, 0, 0);
1267
1193
 #endif
1268
 
Index: openjdk/jdk/src/solaris/native/java/net/PlainSocketImpl.c
1269
 
===================================================================
1270
1194
--- openjdk/jdk/src/solaris/native/java/net/PlainSocketImpl.c.orig
1271
1195
+++ openjdk/jdk/src/solaris/native/java/net/PlainSocketImpl.c
1272
1196
@@ -32,7 +32,7 @@
1296
1220
         /*
1297
1221
          * Linux/GNU distribution setup /etc/hosts so that
1298
1222
          * InetAddress.getLocalHost gets back the loopback address
1299
 
Index: openjdk/jdk/src/solaris/native/java/net/net_util_md.c
1300
 
===================================================================
1301
1223
--- openjdk/jdk/src/solaris/native/java/net/net_util_md.c.orig
1302
1224
+++ openjdk/jdk/src/solaris/native/java/net/net_util_md.c
1303
1225
@@ -46,6 +46,11 @@
1312
1234
 #ifndef IPV6_FLOWINFO_SEND
1313
1235
 #define IPV6_FLOWINFO_SEND      33
1314
1236
 #endif
1315
 
Index: openjdk/jdk/src/solaris/native/java/net/net_util_md.h
1316
 
===================================================================
1317
1237
--- openjdk/jdk/src/solaris/native/java/net/net_util_md.h.orig
1318
1238
+++ openjdk/jdk/src/solaris/native/java/net/net_util_md.h
1319
1239
@@ -37,7 +37,7 @@
1334
1254
 extern int kernelIsV22();
1335
1255
 extern int kernelIsV24();
1336
1256
 #endif
1337
 
Index: openjdk/jdk/src/solaris/native/java/nio/MappedByteBuffer.c
1338
 
===================================================================
1339
1257
--- openjdk/jdk/src/solaris/native/java/nio/MappedByteBuffer.c.orig
1340
1258
+++ openjdk/jdk/src/solaris/native/java/nio/MappedByteBuffer.c
1341
1259
@@ -40,7 +40,7 @@
1347
1265
     unsigned char *vec = (unsigned char *)malloc(numPages * sizeof(char));
1348
1266
 #else
1349
1267
     char *vec = (char *)malloc(numPages * sizeof(char));
1350
 
Index: openjdk/jdk/src/solaris/native/java/util/TimeZone_md.c
1351
 
===================================================================
1352
1268
--- openjdk/jdk/src/solaris/native/java/util/TimeZone_md.c.orig
1353
1269
+++ openjdk/jdk/src/solaris/native/java/util/TimeZone_md.c
1354
1270
@@ -49,7 +49,7 @@
1396
1312
         /*
1397
1313
          * Ignore "posix/" prefix.
1398
1314
          */
1399
 
Index: openjdk/jdk/src/solaris/native/sun/awt/VDrawingArea.c
1400
 
===================================================================
1401
1315
--- openjdk/jdk/src/solaris/native/sun/awt/VDrawingArea.c.orig
1402
1316
+++ openjdk/jdk/src/solaris/native/sun/awt/VDrawingArea.c
1403
1317
@@ -33,7 +33,7 @@
1409
1323
 /* XXX: Shouldn't be necessary. */
1410
1324
 #include "awt_p.h"
1411
1325
 #endif /* __linux__ */
1412
 
Index: openjdk/jdk/src/solaris/native/sun/awt/awt_Font.c
1413
 
===================================================================
1414
1326
--- openjdk/jdk/src/solaris/native/sun/awt/awt_Font.c.orig
1415
1327
+++ openjdk/jdk/src/solaris/native/sun/awt/awt_Font.c
1416
1328
@@ -334,7 +334,7 @@
1422
1334
             if (!strcmp(family, "lucidasans")) {
1423
1335
                 family = "lucida";
1424
1336
             }
1425
 
Index: openjdk/jdk/src/solaris/native/sun/awt/awt_GraphicsEnv.c
1426
 
===================================================================
1427
1337
--- openjdk/jdk/src/solaris/native/sun/awt/awt_GraphicsEnv.c.orig
1428
1338
+++ openjdk/jdk/src/solaris/native/sun/awt/awt_GraphicsEnv.c
1429
1339
@@ -122,7 +122,7 @@
1480
1390
     int x,y;
1481
1391
 
1482
1392
     AWT_LOCK();
1483
 
Index: openjdk/jdk/src/solaris/native/sun/awt/awt_InputMethod.c
1484
 
===================================================================
1485
1393
--- openjdk/jdk/src/solaris/native/sun/awt/awt_InputMethod.c.orig
1486
1394
+++ openjdk/jdk/src/solaris/native/sun/awt/awt_InputMethod.c
1487
1395
@@ -67,7 +67,7 @@
1661
1569
     AWT_LOCK();
1662
1570
     adjustStatusWindow(window);
1663
1571
     AWT_UNLOCK();
1664
 
Index: openjdk/jdk/src/solaris/native/sun/awt/awt_MToolkit.c
1665
 
===================================================================
1666
1572
--- openjdk/jdk/src/solaris/native/sun/awt/awt_MToolkit.c.orig
1667
1573
+++ openjdk/jdk/src/solaris/native/sun/awt/awt_MToolkit.c
1668
1574
@@ -63,7 +63,7 @@
1683
1589
               statusWindowEventHandler(xev);
1684
1590
 #endif
1685
1591
               xembed_eventHandler(&xev);
1686
 
Index: openjdk/jdk/src/solaris/native/sun/awt/awt_Robot.c
1687
 
===================================================================
1688
1592
--- openjdk/jdk/src/solaris/native/sun/awt/awt_Robot.c.orig
1689
1593
+++ openjdk/jdk/src/solaris/native/sun/awt/awt_Robot.c
1690
1594
@@ -45,7 +45,7 @@
1696
1600
 #include <sys/socket.h>
1697
1601
 #endif
1698
1602
 
1699
 
Index: openjdk/jdk/src/solaris/native/sun/awt/awt_util.c
1700
 
===================================================================
1701
1603
--- openjdk/jdk/src/solaris/native/sun/awt/awt_util.c.orig
1702
1604
+++ openjdk/jdk/src/solaris/native/sun/awt/awt_util.c
1703
1605
@@ -605,7 +605,7 @@
1718
1620
 static XRectangle geometryRect;
1719
1621
 XVaNestedList awt_util_getXICStatusAreaList(Widget w)
1720
1622
 {
1721
 
Index: openjdk/jdk/src/solaris/native/sun/awt/awt_util.h
1722
 
===================================================================
1723
1623
--- openjdk/jdk/src/solaris/native/sun/awt/awt_util.h.orig
1724
1624
+++ openjdk/jdk/src/solaris/native/sun/awt/awt_util.h
1725
1625
@@ -195,7 +195,7 @@
1731
1631
 typedef struct _XmImRefRec {
1732
1632
   Cardinal      num_refs;       /* Number of referencing widgets. */
1733
1633
   Cardinal      max_refs;       /* Maximum length of refs array. */
1734
 
Index: openjdk/jdk/src/solaris/native/sun/awt/awt_xembed_server.c
1735
 
===================================================================
1736
1634
--- openjdk/jdk/src/solaris/native/sun/awt/awt_xembed_server.c.orig
1737
1635
+++ openjdk/jdk/src/solaris/native/sun/awt/awt_xembed_server.c
1738
1636
@@ -35,7 +35,7 @@
1753
1651
 void
1754
1652
 print_stack (void)
1755
1653
 {
1756
 
Index: openjdk/jdk/src/solaris/native/sun/awt/extutil.h
1757
 
===================================================================
1758
1654
--- openjdk/jdk/src/solaris/native/sun/awt/extutil.h.orig
1759
1655
+++ openjdk/jdk/src/solaris/native/sun/awt/extutil.h
1760
1656
@@ -58,7 +58,7 @@
1766
1662
 
1767
1663
 #ifndef _EXTUTIL_H_
1768
1664
 #define _EXTUTIL_H_
1769
 
Index: openjdk/jdk/src/solaris/native/sun/awt/fontpath.c
1770
 
===================================================================
1771
1665
--- openjdk/jdk/src/solaris/native/sun/awt/fontpath.c.orig
1772
1666
+++ openjdk/jdk/src/solaris/native/sun/awt/fontpath.c
1773
1667
@@ -23,7 +23,7 @@
1833
1727
     }
1834
1728
 #endif
1835
1729
 #endif /* !HEADLESS */
1836
 
Index: openjdk/jdk/src/solaris/native/sun/awt/multi_font.c
1837
 
===================================================================
1838
1730
--- openjdk/jdk/src/solaris/native/sun/awt/multi_font.c.orig
1839
1731
+++ openjdk/jdk/src/solaris/native/sun/awt/multi_font.c
1840
1732
@@ -348,7 +348,7 @@
1855
1747
             len = buf[0] << 24 | buf[1] << 16 | buf[2] << 8 | buf[3];
1856
1748
             /* Motif XmStringCreate() API requests "text must be a NULL-terminated
1857
1749
                string" and its implementation uses "strlen()" to calculate the length
1858
 
Index: openjdk/jdk/src/solaris/native/sun/java2d/j2d_md.h
1859
 
===================================================================
1860
1750
--- openjdk/jdk/src/solaris/native/sun/java2d/j2d_md.h.orig
1861
1751
+++ openjdk/jdk/src/solaris/native/sun/java2d/j2d_md.h
1862
1752
@@ -30,7 +30,7 @@
1868
1758
 #include <stdint.h>
1869
1759
 #endif /* __linux__ */
1870
1760
 
1871
 
Index: openjdk/jdk/src/solaris/native/sun/java2d/loops/vis_FuncArray.c
1872
 
===================================================================
1873
1761
--- openjdk/jdk/src/solaris/native/sun/java2d/loops/vis_FuncArray.c.orig
1874
1762
+++ openjdk/jdk/src/solaris/native/sun/java2d/loops/vis_FuncArray.c
1875
1763
@@ -804,7 +804,7 @@
1881
1769
 #   define ULTRA_CHIP   "sparc64"
1882
1770
 #else
1883
1771
 #   define ULTRA_CHIP   "sun4u"
1884
 
Index: openjdk/jdk/src/solaris/native/sun/net/dns/ResolverConfigurationImpl.c
1885
 
===================================================================
1886
1772
--- openjdk/jdk/src/solaris/native/sun/net/dns/ResolverConfigurationImpl.c.orig
1887
1773
+++ openjdk/jdk/src/solaris/native/sun/net/dns/ResolverConfigurationImpl.c
1888
1774
@@ -33,7 +33,7 @@
1894
1780
 #include <string.h>
1895
1781
 #endif
1896
1782
 
1897
 
Index: openjdk/jdk/src/solaris/native/sun/net/spi/DefaultProxySelector.c
1898
 
===================================================================
1899
1783
--- openjdk/jdk/src/solaris/native/sun/net/spi/DefaultProxySelector.c.orig
1900
1784
+++ openjdk/jdk/src/solaris/native/sun/net/spi/DefaultProxySelector.c
1901
1785
@@ -29,7 +29,7 @@
1907
1791
 #include <string.h>
1908
1792
 #else
1909
1793
 #include <strings.h>
1910
 
Index: openjdk/jdk/src/solaris/native/sun/nio/ch/DatagramChannelImpl.c
1911
 
===================================================================
1912
1794
--- openjdk/jdk/src/solaris/native/sun/nio/ch/DatagramChannelImpl.c.orig
1913
1795
+++ openjdk/jdk/src/solaris/native/sun/nio/ch/DatagramChannelImpl.c
1914
1796
@@ -35,7 +35,7 @@
1929
1811
     {
1930
1812
         int len;
1931
1813
         SOCKADDR sa;
1932
 
Index: openjdk/jdk/src/solaris/native/sun/nio/ch/DatagramDispatcher.c
1933
 
===================================================================
1934
1814
--- openjdk/jdk/src/solaris/native/sun/nio/ch/DatagramDispatcher.c.orig
1935
1815
+++ openjdk/jdk/src/solaris/native/sun/nio/ch/DatagramDispatcher.c
1936
1816
@@ -73,7 +73,7 @@
1951
1831
     m.msg_control = NULL;
1952
1832
     m.msg_controllen = 0;
1953
1833
 #endif
1954
 
Index: openjdk/jdk/src/solaris/native/sun/nio/ch/FileChannelImpl.c
1955
 
===================================================================
1956
1834
--- openjdk/jdk/src/solaris/native/sun/nio/ch/FileChannelImpl.c.orig
1957
1835
+++ openjdk/jdk/src/solaris/native/sun/nio/ch/FileChannelImpl.c
1958
1836
@@ -37,6 +37,12 @@
2000
1878
 #else
2001
1879
     return IOS_UNSUPPORTED_CASE;
2002
1880
 #endif
2003
 
Index: openjdk/jdk/src/solaris/native/sun/nio/ch/NativeThread.c
2004
 
===================================================================
2005
1881
--- openjdk/jdk/src/solaris/native/sun/nio/ch/NativeThread.c.orig
2006
1882
+++ openjdk/jdk/src/solaris/native/sun/nio/ch/NativeThread.c
2007
1883
@@ -33,7 +33,7 @@
2040
1916
     if (pthread_kill((pthread_t)thread, INTERRUPT_SIGNAL))
2041
1917
         JNU_ThrowIOExceptionWithLastError(env, "Thread signal failed");
2042
1918
 #endif
2043
 
Index: openjdk/jdk/src/solaris/native/sun/nio/ch/Net.c
2044
 
===================================================================
2045
1919
--- openjdk/jdk/src/solaris/native/sun/nio/ch/Net.c.orig
2046
1920
+++ openjdk/jdk/src/solaris/native/sun/nio/ch/Net.c
2047
1921
@@ -86,7 +86,7 @@
2071
1945
         /* Include-mode filtering broken on Linux at least to 2.6.24 */
2072
1946
         return IOS_UNAVAILABLE;
2073
1947
 #else
2074
 
Index: openjdk/jdk/src/solaris/native/sun/nio/ch/Sctp.h
2075
 
===================================================================
2076
1948
--- openjdk/jdk/src/solaris/native/sun/nio/ch/Sctp.h.orig
2077
1949
+++ openjdk/jdk/src/solaris/native/sun/nio/ch/Sctp.h
2078
1950
@@ -67,7 +67,7 @@
2122
1994
 jboolean loadSocketExtensionFuncs(JNIEnv* env);
2123
1995
 
2124
1996
 #endif /* !SUN_NIO_CH_SCTP_H */
2125
 
Index: openjdk/jdk/src/solaris/native/sun/nio/ch/SctpChannelImpl.c
2126
 
===================================================================
2127
1997
--- openjdk/jdk/src/solaris/native/sun/nio/ch/SctpChannelImpl.c.orig
2128
1998
+++ openjdk/jdk/src/solaris/native/sun/nio/ch/SctpChannelImpl.c
2129
1999
@@ -337,7 +337,7 @@
2144
2014
             } else if (errno == ENOTCONN) {
2145
2015
                 /* ENOTCONN when EOF reached */
2146
2016
                 rv = 0;
2147
 
Index: openjdk/jdk/src/solaris/native/sun/nio/ch/SctpNet.c
2148
 
===================================================================
2149
2017
--- openjdk/jdk/src/solaris/native/sun/nio/ch/SctpNet.c.orig
2150
2018
+++ openjdk/jdk/src/solaris/native/sun/nio/ch/SctpNet.c
2151
2019
@@ -58,6 +58,7 @@
2164
2032
 
2165
2033
     funcsLoaded = JNI_TRUE;
2166
2034
     return JNI_TRUE;
2167
 
Index: openjdk/jdk/src/solaris/native/sun/nio/ch/ServerSocketChannelImpl.c
2168
 
===================================================================
2169
2035
--- openjdk/jdk/src/solaris/native/sun/nio/ch/ServerSocketChannelImpl.c.orig
2170
2036
+++ openjdk/jdk/src/solaris/native/sun/nio/ch/ServerSocketChannelImpl.c
2171
2037
@@ -28,7 +28,7 @@
2177
2043
 #include <netinet/in.h>
2178
2044
 #endif
2179
2045
 
2180
 
Index: openjdk/jdk/src/solaris/native/sun/nio/ch/SocketChannelImpl.c
2181
 
===================================================================
2182
2046
--- openjdk/jdk/src/solaris/native/sun/nio/ch/SocketChannelImpl.c.orig
2183
2047
+++ openjdk/jdk/src/solaris/native/sun/nio/ch/SocketChannelImpl.c
2184
2048
@@ -31,7 +31,7 @@
2190
2054
 #include <netinet/in.h>
2191
2055
 #endif
2192
2056
 
2193
 
Index: openjdk/jdk/src/solaris/native/sun/nio/fs/GnomeFileTypeDetector.c
2194
 
===================================================================
2195
2057
--- openjdk/jdk/src/solaris/native/sun/nio/fs/GnomeFileTypeDetector.c.orig
2196
2058
+++ openjdk/jdk/src/solaris/native/sun/nio/fs/GnomeFileTypeDetector.c
2197
2059
@@ -35,7 +35,7 @@
2203
2065
 #include <string.h>
2204
2066
 #endif
2205
2067
 
2206
 
Index: openjdk/jdk/src/solaris/native/sun/nio/fs/UnixNativeDispatcher.c
2207
 
===================================================================
2208
2068
--- openjdk/jdk/src/solaris/native/sun/nio/fs/UnixNativeDispatcher.c.orig
2209
2069
+++ openjdk/jdk/src/solaris/native/sun/nio/fs/UnixNativeDispatcher.c
2210
2070
@@ -26,7 +26,7 @@
2225
2085
 #include <string.h>
2226
2086
 #include <mntent.h>
2227
2087
 #endif
2228
 
Index: openjdk/jdk/src/solaris/native/sun/nio/fs/genUnixConstants.c
2229
 
===================================================================
2230
2088
--- openjdk/jdk/src/solaris/native/sun/nio/fs/genUnixConstants.c.orig
2231
2089
+++ openjdk/jdk/src/solaris/native/sun/nio/fs/genUnixConstants.c
2232
2090
@@ -106,7 +106,9 @@
2239
2097
     DEF(ERANGE);
2240
2098
 
2241
2099
     // flags used with openat/unlinkat/etc.
2242
 
Index: openjdk/jdk/src/solaris/native/sun/xawt/XToolkit.c
2243
 
===================================================================
2244
2100
--- openjdk/jdk/src/solaris/native/sun/xawt/XToolkit.c.orig
2245
2101
+++ openjdk/jdk/src/solaris/native/sun/xawt/XToolkit.c
2246
2102
@@ -27,7 +27,7 @@
2252
2108
 #include <execinfo.h>
2253
2109
 #endif
2254
2110
 
2255
 
@@ -783,7 +783,7 @@
 
2111
@@ -785,7 +785,7 @@
2256
2112
     return ret;
2257
2113
 }
2258
2114
 
2261
2117
 void print_stack(void)
2262
2118
 {
2263
2119
   void *array[10];
2264
 
Index: openjdk/jdk/src/solaris/transport/socket/socket_md.c
2265
 
===================================================================
2266
2120
--- openjdk/jdk/src/solaris/transport/socket/socket_md.c.orig
2267
2121
+++ openjdk/jdk/src/solaris/transport/socket/socket_md.c
2268
2122
@@ -36,7 +36,7 @@