~ubuntu-branches/ubuntu/wily/osmpbf/wily

« back to all changes in this revision

Viewing changes to debian/patches/00-fix_build_flags.patch

  • Committer: Package Import Robot
  • Author(s): David Paleino, Giovanni Mascellani, David Paleino
  • Date: 2013-01-28 20:32:44 UTC
  • mfrom: (1.1.2)
  • Revision ID: package-import@ubuntu.com-20130128203244-y44ztt7sumiu6470
Tags: 1.3.0-1
[ Giovanni Mascellani ]
* Remove myself from the uploaders list, since I have no time
  anymore to look after this package.

[ David Paleino ]
* New upstream version.
* Bump debhelper compatibility to 9.
* Standards-Version bump to 3.9.4, no changes needed.
* Use canonical Vcs-* urls in debian/control.
* Updated debian/copyright.
* Install ReleaseNotes.txt as upstream changelog.
* Correctly clean up after builds.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Giovanni Mascellani <gio@debian.org>
 
2
Subject: fix Makefile so Debian build flags are honoured.
 
3
Origin: vendor
 
4
Forwarded: not-needed
 
5
 
 
6
---
 
7
 src/Makefile   |    2 +-
 
8
 tools/Makefile |    4 ++--
 
9
 2 files changed, 3 insertions(+), 3 deletions(-)
 
10
 
 
11
--- osmpbf.orig/tools/Makefile
 
12
+++ osmpbf/tools/Makefile
 
13
@@ -1,7 +1,7 @@
 
14
 
 
15
 CXX = g++
 
16
-CXXFLAGS = -g -I../include
 
17
-LDFLAGS = -L../src -lpthread -lz -lprotobuf-lite -losmpbf
 
18
+CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS) -g -I../include
 
19
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS) -L../src -lpthread -lz -lprotobuf-lite -losmpbf
 
20
 
 
21
 all: osmpbf-outline
 
22
 
 
23
--- osmpbf.orig/src/Makefile
 
24
+++ osmpbf/src/Makefile
 
25
@@ -1,6 +1,6 @@
 
26
 
 
27
 CXX = g++
 
28
-CXXFLAGS = -O3
 
29
+CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS) -O3
 
30
 AR = ar
 
31
 
 
32
 all: libosmpbf.a ../include/osmpbf/fileformat.pb.h ../include/osmpbf/osmformat.pb.h