~ubuntu-branches/ubuntu/wily/performous/wily

« back to all changes in this revision

Viewing changes to debian/patches/libav_api_change.patch

  • Committer: Package Import Robot
  • Author(s): Markus Koschany
  • Date: 2013-06-30 11:59:10 UTC
  • mfrom: (9.1.6 sid)
  • Revision ID: package-import@ubuntu.com-20130630115910-o8sfqnbkpss0my71
Tags: 0.7.0-2
* Team upload.
* debian/control:
  - Use canonical VCS-URI.
  - Remove versioned dependencies on boost libraries because they are
    trivially satisfied now.
  - Remove superfluous ${shlibs:Depends} substvar from performous-dbg
    package.
  - Bump Standards-Version to 3.9.4, no changes.
* debian/copyright: Fix lintian issue copyright-refers-to-symlink-license and
  point to GPL-2 license.
* Add use-Boost-TIME_UTC_-constant-unconditionally.patch. Use always the new
  Boost constant TIME_UTC_ and fix FTBFS with libboost1.49. (Closes: #710625)
* Drop boost_filesystem_v2.patch. Not necessary for newer boost versions.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
libav 0.7 API change
2
 
Index: performous-0.6.1/game/ffmpeg.cc
3
 
===================================================================
4
 
--- performous-0.6.1.orig/game/ffmpeg.cc        2011-08-08 09:36:02.596685105 -0400
5
 
+++ performous-0.6.1/game/ffmpeg.cc     2011-08-08 09:37:24.380685064 -0400
6
 
@@ -60,8 +60,8 @@
7
 
        for (unsigned int i=0; i<pFormatCtx->nb_streams; i++) {
8
 
                AVCodecContext* cc = pFormatCtx->streams[i]->codec;
9
 
                cc->workaround_bugs = FF_BUG_AUTODETECT;
10
 
-               if (videoStream == -1 && cc->codec_type==CODEC_TYPE_VIDEO) videoStream = i;
11
 
-               if (audioStream == -1 && cc->codec_type==CODEC_TYPE_AUDIO) audioStream = i;
12
 
+               if (videoStream == -1 && cc->codec_type==AVMEDIA_TYPE_VIDEO) videoStream = i;
13
 
+               if (audioStream == -1 && cc->codec_type==AVMEDIA_TYPE_AUDIO) audioStream = i;
14
 
        }
15
 
        if (videoStream == -1 && decodeVideo) throw std::runtime_error("No video stream found");
16
 
        if (audioStream == -1 && decodeAudio) throw std::runtime_error("No audio stream found");