~ubuntu-branches/ubuntu/wily/perl/wily

« back to all changes in this revision

Viewing changes to debian/patches/debian/hurd_test_skip_libc.diff

  • Committer: Package Import Robot
  • Author(s): Dominic Hargreaves, Niko Tyni, Dominic Hargreaves
  • Date: 2011-11-28 19:48:05 UTC
  • mfrom: (8.1.30 sid)
  • Revision ID: package-import@ubuntu.com-20111128194805-8bkpc1gmgnakssjk
Tags: 5.14.2-6
[ Niko Tyni ]
* debian/rules: correctly handle subject line wraps in patch headers.

[ Dominic Hargreaves ]
* Add versioned Conflicts on update-inetd (<< 4.41) (Closes: #649177)
* Conflict on rather than Break doc-base (<< 0.10.3); aptitude
  runs doc-base triggers before the new version has been unpacked
* Update Lintian override for perl-module-uses-perl4-libs-without-dep
  to reflect new path to CGI.pm
* Disable various tests which fail on GNU/Hurd (see #648623)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From ccdda2f5cd1844f4e968070d191b6c321cd13236 Mon Sep 17 00:00:00 2001
 
2
From: Dominic Hargreaves <dom@earth.li>
 
3
Date: Sun, 27 Nov 2011 16:38:05 +0000
 
4
Subject: Disable failing GNU/Hurd tests dist/threads/t/libc.t
 
5
 
 
6
These tests currently fail on GNU/Hurd, so disable them
 
7
 
 
8
Bug-Debian: http://bugs.debian.org/650097
 
9
 
 
10
Patch-Name: debian/hurd_test_skip_libc.diff
 
11
---
 
12
 dist/threads/t/libc.t |    3 +++
 
13
 1 files changed, 3 insertions(+), 0 deletions(-)
 
14
 
 
15
diff --git a/dist/threads/t/libc.t b/dist/threads/t/libc.t
 
16
index 4f6f6ed..ec074f6 100644
 
17
--- a/dist/threads/t/libc.t
 
18
+++ b/dist/threads/t/libc.t
 
19
@@ -8,6 +8,9 @@ BEGIN {
 
20
     if (! $Config{'useithreads'}) {
 
21
         skip_all(q/Perl not compiled with 'useithreads'/);
 
22
     }
 
23
+    if ($^O eq 'gnu') {
 
24
+        skip_all(q|fails on GNU/Hurd (Debian #650097)|);
 
25
+    }
 
26
 
 
27
     plan(11);
 
28
 }