~ubuntu-branches/ubuntu/wily/proj/wily

« back to all changes in this revision

Viewing changes to debian/patches/nad2bin-data.patch

  • Committer: Package Import Robot
  • Author(s): Bas Couwenberg
  • Date: 2014-05-20 20:05:43 UTC
  • Revision ID: package-import@ubuntu.com-20140520200543-24vj64o9k3gtp3kf
Tags: 4.8.0-5
* Add patch to install nad2bin produced data files in /usr/lib/proj.
  (closes: 747862)
* Symlink moved data files from /usr/lib/proj to /usr/share/proj.
* Remove debian/TODO, nad2bin data files moved to /usr/lib/proj.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Install the data files produced by nad2bin to /usr/lib/proj.
 
2
 The simple binary format produced by nad2bin is not endianess-aware,
 
3
 making the resulting data files architecture specific.
 
4
Author: Bas Couwenberg <sebastic@xs4all.nl>
 
5
Bug-Debian: https://bugs.debian.org/747862
 
6
--- a/nad/Makefile.am
 
7
+++ b/nad/Makefile.am
 
8
@@ -32,10 +32,10 @@ process-nad2bin:
 
9
        fi 
 
10
 
 
11
 install-data-local: process-nad2bin
 
12
-       $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)
 
13
+       $(mkinstalldirs) $(DESTDIR)$(pkgdatadir) $(DESTDIR)$(pkglibdir)
 
14
        @if [ -f conus.lla ] ; then \
 
15
          for x in *.lla ; do \
 
16
-           DEST=$(DESTDIR)$(pkgdatadir)/`basename $$x .lla`; \
 
17
+           DEST=$(DESTDIR)$(pkglibdir)/`basename $$x .lla`; \
 
18
            echo "../src/nad2bin$(EXEEXT) $$DEST < $$x"; \
 
19
            ../src/nad2bin$(EXEEXT) $$DEST < $$x ; \
 
20
            if [ $$? -ne 0 ] ; then \