~ubuntu-branches/ubuntu/wily/python-imaging/wily

« back to all changes in this revision

Viewing changes to debian/patches/changes-1.1.7.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2013-01-31 20:49:20 UTC
  • mfrom: (1.1.4)
  • mto: This revision was merged to the branch mainline in revision 29.
  • Revision ID: package-import@ubuntu.com-20130131204920-7tnuhqhlsqdza4c2
Rewrite build dependencies to allow cross builds.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: b/setup.py
 
2
===================================================================
 
3
--- a/setup.py
 
4
+++ b/setup.py
 
5
@@ -114,13 +114,6 @@
 
6
             _add_directory(include_dirs, "/usr/X11/include")
 
7
 
 
8
         elif sys.platform.startswith("linux"):
 
9
-            if platform.processor() == "x86_64":
 
10
-                _add_directory(library_dirs, "/lib64")
 
11
-                _add_directory(library_dirs, "/usr/lib64")
 
12
-                _add_directory(library_dirs, "/usr/lib/x86_64-linux-gnu")
 
13
-            else:
 
14
-                _add_directory(library_dirs, "/usr/lib/i386-linux-gnu")
 
15
-
 
16
             # XXX Kludge. Above /\ we brute force support multiarch. Here we
 
17
             # try Barry's more general approach. Afterward, something should
 
18
             # work ;-)
 
19
Index: b/Scripts/pilfont.py
 
20
===================================================================
 
21
--- a/Scripts/pilfont.py
 
22
+++ b/Scripts/pilfont.py
 
23
@@ -1,3 +1,5 @@
 
24
+#! /usr/bin/python
 
25
+
 
26
 #
 
27
 # The Python Imaging Library
 
28
 # $Id$
 
29
Index: b/libImaging/Imaging.h
 
30
===================================================================
 
31
--- a/libImaging/Imaging.h
 
32
+++ b/libImaging/Imaging.h
 
33
@@ -75,7 +75,7 @@
 
34
 struct ImagingMemoryInstance {
 
35
 
 
36
     /* Format */
 
37
-    char mode[4+1];    /* Band names ("1", "L", "P", "RGB", "RGBA", "CMYK") */
 
38
+    char mode[6+1];    /* Band names ("1", "L", "P", "RGB", "RGBA", "CMYK", "YCbCr", "BGR;xy") */
 
39
     int type;          /* Data type (IMAGING_TYPE_*) */
 
40
     int depth;         /* Depth (ignored in this version) */
 
41
     int bands;         /* Number of bands (1, 2, 3, or 4) */