~ubuntu-branches/ubuntu/wily/python-imaging/wily

« back to all changes in this revision

Viewing changes to debian/patches/lcms2.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2013-01-31 20:49:20 UTC
  • mfrom: (27.1.1 raring-proposed)
  • Revision ID: package-import@ubuntu.com-20130131204920-b5zshy6vgfvdionl
Tags: 1.1.7+1.7.8-1ubuntu1
Rewrite build dependencies to allow cross builds.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: b/_imagingcms.c
 
2
===================================================================
 
3
--- a/_imagingcms.c
 
4
+++ b/_imagingcms.c
 
5
@@ -24,7 +24,7 @@
 
6
 "
 
7
 
 
8
 #include "Python.h"
 
9
-#include "lcms.h"
 
10
+#include "lcms2.h"
 
11
 #include "Imaging.h"
 
12
 #include "py3.h"
 
13
 
 
14
Index: b/setup.py
 
15
===================================================================
 
16
--- a/setup.py
 
17
+++ b/setup.py
 
18
@@ -238,8 +238,8 @@
 
19
                 if dir:
 
20
                     _add_directory(self.compiler.include_dirs, dir, 0)
 
21
 
 
22
-        if _find_include_file(self, "lcms.h"):
 
23
-            if _find_library_file(self, "lcms"):
 
24
+        if _find_include_file(self, "lcms2.h"):
 
25
+            if _find_library_file(self, "lcms2"):
 
26
                 feature.lcms = "lcms"
 
27
 
 
28
         if _tkinter and _find_include_file(self, "tk.h"):
 
29
@@ -299,7 +299,7 @@
 
30
             if sys.platform == "win32":
 
31
                 extra.extend(["user32", "gdi32"])
 
32
             exts.append(Extension(
 
33
-                "_imagingcms", ["_imagingcms.c"], libraries=["lcms"] + extra))
 
34
+                "_imagingcms", ["_imagingcms.c"], libraries=["lcms2"] + extra))
 
35
 
 
36
         if sys.platform == "darwin":
 
37
             # locate Tcl/Tk frameworks