~ubuntu-branches/ubuntu/wily/qtdeclarative-opensource-src/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/fix_qqmlobjectcreator.patch

  • Committer: Package Import Robot
  • Author(s): Ricardo Salveti de Araujo, Ricardo Salveti de Araujo, Timo Jyrinki
  • Date: 2014-06-19 02:39:21 UTC
  • mfrom: (0.1.18 experimental)
  • Revision ID: package-import@ubuntu.com-20140619023921-yb2oasnuetz9b0fc
Tags: 5.3.0-3ubuntu4
[ Ricardo Salveti de Araujo ]
* debian/control:
  - Updating dependencies as we now also have libqt5quickwidgets5-gles
* libqt5quickwidgets5.symbols: updating to allow gles variant

[ Timo Jyrinki ]
* Update libqt5quickparticles5.symbols from build logs

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -rub qtdeclarative-opensource-src-5.3.0/src/qml/qml/qqmlobjectcreator.cpp with_patch/src/qml/qml/qqmlobjectcreator.cpp
 
2
--- qtdeclarative-opensource-src-5.3.0/src/qml/qml/qqmlobjectcreator.cpp        2014-05-15 19:12:44.000000000 +0200
 
3
+++ with_patch/src/qml/qml/qqmlobjectcreator.cpp        2014-06-17 10:54:01.457068937 +0200
 
4
@@ -153,6 +153,10 @@
 
5
             if (ps)
 
6
                 ps->d = 0;
 
7
         }
 
8
+        while (sharedState->componentAttached) {
 
9
+            QQmlComponentAttached *a = sharedState->componentAttached;
 
10
+            a->rem();
 
11
+        }
 
12
         delete sharedState.data();
 
13
     }
 
14
 }
 
15
@@ -1253,6 +1257,11 @@
 
16
     while (!sharedState->allCreatedObjects.isEmpty())
 
17
         delete sharedState->allCreatedObjects.pop();
 
18
 
 
19
+    while (sharedState->componentAttached) {
 
20
+        QQmlComponentAttached *a = sharedState->componentAttached;
 
21
+        a->rem();
 
22
+    }
 
23
+
 
24
     phase = Done;
 
25
 }
 
26