~ubuntu-branches/ubuntu/wily/qtdeclarative-opensource-src/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/parenttosubcreator_qqmlobjectcreator.patch

  • Committer: Package Import Robot
  • Author(s): Timo Jyrinki, Michał Sawicz, Timo Jyrinki
  • Date: 2014-08-04 10:58:28 UTC
  • Revision ID: package-import@ubuntu.com-20140804105828-51gvmpqdd7hm7x9u
Tags: 5.3.0-3ubuntu8
[ Michał Sawicz ]
* debian/patches/8454a21b-Flickable-Cancel-interaction-on-interactive-changes.patch
  - Fix flickable interaction (LP: #1349705)
* debian/control
* debian/rules
  - Force gcc-4.8 to avoid symbols changes

[ Timo Jyrinki ]
* debian/patches/parenttosubcreator_qqmlobjectcreator.patch:
  - Drop, rejected by upstream
* debian/patches/Fix-crash-when-deleting-component-in-Component.onCom.patch
  debian/patches/Fix-interaction-of-garbage-collector-with-JS-objects.patch:
  - Replace the old patch with accepted upstream approach (LP: #1349297)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
commit 249b1a73fdb01fc27e036fc4334925674c281793
2
 
Author: Albert Astals Cid <albert.astals@canonical.com>
3
 
Date:   Mon Jun 30 17:22:55 2014 +0200
4
 
 
5
 
    Pass down parent to subCreator
6
 
    
7
 
    Otherwise the object might get garbage collected while it's being created
8
 
    
9
 
    Change-Id: I553c3432d5242bcd89723b72d8f8ae82577abaf9
10
 
    Task-number: QTBUG-39966
11
 
 
12
 
diff --git a/src/qml/qml/qqmlobjectcreator.cpp b/src/qml/qml/qqmlobjectcreator.cpp
13
 
index 36c7dfb..cceb9b2 100644
14
 
--- a/src/qml/qml/qqmlobjectcreator.cpp
15
 
+++ b/src/qml/qml/qqmlobjectcreator.cpp
16
 
@@ -1076,7 +1076,7 @@ QObject *QQmlObjectCreator::createInstance(int index, QObject *parent, bool isCo
17
 
             }
18
 
 
19
 
             QQmlObjectCreator subCreator(context, typeRef->component, sharedState.data());
20
 
-            instance = subCreator.create();
21
 
+            instance = subCreator.create(-1, parent);
22
 
             if (!instance) {
23
 
                 errors += subCreator.errors;
24
 
                 return 0;