~ubuntu-branches/ubuntu/wily/scrot/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/04-focused.patch

  • Committer: Package Import Robot
  • Author(s): Joao Eriberto Mota Filho
  • Date: 2015-05-03 23:33:01 UTC
  • mfrom: (9.1.2 experimental)
  • Revision ID: package-import@ubuntu.com-20150503233301-senwdwon1ctt8j9r
Tags: 0.8-16
* Upload to unstable.
* debian/rules: removed some unused lines.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: src/options.c (scrot_parse_option_array): add --focused option.
 
2
             src/main.c (scrot_get_geometry, scrot_nice_clip): new functions
 
3
             src/main.c (scrot_grab_focused): new function to grab currently
1
4
Author: James Cameron <quozl@us.netrek.org>
2
 
Description: src/options.c (scrot_parse_option_array): add --focused option.
3
 
src/main.c (scrot_get_geometry, scrot_nice_clip): new functions
4
 
src/main.c (scrot_grab_focused): new function to grab currently
5
 
--- a/src/options.h
6
 
+++ b/src/options.h
7
 
@@ -32,6 +32,7 @@
 
5
Last-Update: 2009-05-19
 
6
Index: scrot-0.8/src/options.h
 
7
===================================================================
 
8
--- scrot-0.8.orig/src/options.h
 
9
+++ scrot-0.8/src/options.h
 
10
@@ -32,6 +32,7 @@ struct __scrotoptions
8
11
    int delay;
9
12
    int countdown;
10
13
    int select;
12
15
    int quality;
13
16
    int border;
14
17
    int multidisp;
15
 
--- a/src/options.c
16
 
+++ b/src/options.c
17
 
@@ -44,13 +44,15 @@
 
18
Index: scrot-0.8/src/options.c
 
19
===================================================================
 
20
--- scrot-0.8.orig/src/options.c
 
21
+++ scrot-0.8/src/options.c
 
22
@@ -44,13 +44,15 @@ init_parse_options(int argc, char **argv
18
23
 static void
19
24
 scrot_parse_option_array(int argc, char **argv)
20
25
 {
31
36
       {"border", 0, 0, 'b'},
32
37
       {"multidisp", 0, 0, 'm'},
33
38
       /* toggles */
34
 
@@ -95,6 +97,9 @@
 
39
@@ -95,6 +97,9 @@ scrot_parse_option_array(int argc, char
35
40
         case 's':
36
41
            opt.select = 1;
37
42
            break;
41
46
         case '+':
42
47
            opt.debug_level = atoi(optarg);
43
48
            break;
44
 
@@ -231,6 +236,7 @@
 
49
@@ -231,6 +236,7 @@ show_usage(void)
45
50
            "                            and join them together.\n"
46
51
            "  -s, --select              interactively choose a window or rectangle\n"
47
52
            "                            with the mouse\n"
49
54
            "  -t, --thumb NUM           generate thumbnail too. NUM is the percentage\n"
50
55
            "                            of the original size for the thumbnail to be,\n"
51
56
            "                            or the geometry in percent, e.g. 50x60 or 80x20.\n"
52
 
--- a/src/scrot.h
53
 
+++ b/src/scrot.h
54
 
@@ -72,7 +72,10 @@
 
57
Index: scrot-0.8/src/scrot.h
 
58
===================================================================
 
59
--- scrot-0.8.orig/src/scrot.h
 
60
+++ scrot-0.8/src/scrot.h
 
61
@@ -72,7 +72,10 @@ void scrot_exec_app(Imlib_Image image, s
55
62
                     char *filename_im, char *filename_thumb);
56
63
 void scrot_do_delay(void);
57
64
 Imlib_Image scrot_sel_and_grab_image(void);
62
69
 Window scrot_get_window(Display *display,Window window,int x,int y);
63
70
 Window scrot_get_client_window(Display * display, Window target);
64
71
 Window scrot_find_window_by_property(Display * display, const Window window,
65
 
--- a/src/main.c
66
 
+++ b/src/main.c
67
 
@@ -48,7 +48,9 @@
 
72
Index: scrot-0.8/src/main.c
 
73
===================================================================
 
74
--- scrot-0.8.orig/src/main.c
 
75
+++ scrot-0.8/src/main.c
 
76
@@ -48,7 +48,9 @@ main(int argc,
68
77
   }
69
78
 
70
79
 
75
84
     image = scrot_sel_and_grab_image();
76
85
   else {
77
86
     scrot_do_delay();
78
 
@@ -171,6 +173,22 @@
 
87
@@ -171,6 +173,22 @@ scrot_exec_app(Imlib_Image image, struct
79
88
 }
80
89
 
81
90
 Imlib_Image
98
107
 scrot_sel_and_grab_image(void)
99
108
 {
100
109
   Imlib_Image im = NULL;
101
 
@@ -313,57 +331,10 @@
 
110
@@ -313,57 +331,10 @@ scrot_sel_and_grab_image(void)
102
111
         rh = 0 - rh;
103
112
       }
104
113
     } else {
158
167
 
159
168
     XBell(disp, 0);
160
169
     im = gib_imlib_create_image_from_drawable(root, 0, rx, ry, rw, rh, 1);
161
 
@@ -371,6 +342,72 @@
 
170
@@ -371,6 +342,72 @@ scrot_sel_and_grab_image(void)
162
171
   return im;
163
172
 }
164
173