~ubuntu-branches/ubuntu/wily/sessioninstaller/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/fix-defer-callback.patch

  • Committer: Package Import Robot
  • Author(s): Martin Pitt
  • Date: 2012-08-21 08:50:56 UTC
  • mfrom: (1.1.9)
  • Revision ID: package-import@ubuntu.com-20120821085056-y14a277r80llr45f
Tags: 0.20+bzr131-0ubuntu1
* debian/control: Update Vcs-* to Quantal branch.
* New upstream snapshot:
  - Fix typo in error message. (LP: #790500)
  - Make sure not to accidentally call defer.callback() twice (LP #848605)
  - Work around static vs. GI gobject binding crash. (LP: #1028640)
* Drop fix-defer-callback.patch, included upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- sessioninstaller-0.20+bzr128.orig/sessioninstaller/backends/aptd.py
2
 
+++ sessioninstaller-0.20+bzr128/sessioninstaller/backends/aptd.py
3
 
@@ -44,12 +44,11 @@ class AptDaemonBackend(object):
4
 
     def _run_trans(self, trans, parent, interaction):
5
 
         deferred = defer.Deferred()
6
 
         dia = aptdaemon.gtk3widgets.AptProgressDialog(trans)
7
 
-        dia.connect("finished", lambda x: deferred.callback())
8
 
         if parent:
9
 
             dia.realize()
10
 
             dia.set_transient_for(parent)
11
 
         dia.run(close_on_finished=True, show_error=True,
12
 
-                reply_handler=lambda: True,
13
 
+                reply_handler=deferred.callback,
14
 
                 error_handler=deferred.errback)
15
 
         return deferred
16