~ubuntu-branches/ubuntu/wily/trafficserver/wily

« back to all changes in this revision

Viewing changes to debian/patches/as-needed

  • Committer: Bazaar Package Importer
  • Author(s): Arno Töll
  • Date: 2011-08-02 22:58:37 UTC
  • mfrom: (5.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20110802225837-9za69cy1kq4vh93m
Tags: 3.0.1-2
* Fix "please add armhf to the arch list" - add armhf to the list of supported
  architectures. Thanks Konstantinos Margaritis for the hint (Closes: #636338)
* Remove IA64 from the list of supported architectures. The upgrade to the gcc
  4.6 toolchain disclosed portability issues with it, which caused the resul-
  ting binary package to produce no-op code in some functions. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: change order of libraries so that it's possible to link with
2
 
 --as-needed option.
3
 
Author: Ilya Barygin <barygin@gmail.com>
4
 
--- trafficserver-3.0.0.orig/mgmt/Makefile.am
5
 
+++ trafficserver-3.0.0/mgmt/Makefile.am
6
 
@@ -97,7 +97,7 @@
7
 
   $(top_builddir)/mgmt/tools/libinkconfigapi.a \
8
 
   $(top_builddir)/lib/ts/libtsutil.la \
9
 
   @LIBEXPAT@ @LIBPCRE@ \
10
 
-  @LIBSSL@ @LIBTCL@ @LIBICONV@ \
11
 
+  @LIBTCL@ @LIBICONV@ \
12
 
   -lm @LIBDL@ @LIBSOCKET@ @LIBNSL@ @LIBRESOLV@ \
13
 
   @LIBTHREAD@ @LIBRT@ @LIBEXECINFO@ @LIBCAP@
14
 
 
15
 
@@ -107,3 +107,5 @@
16
 
   $(top_builddir)/lib/wccp/libwccp.a \
17
 
   $(top_builddir)/lib/tsconfig/libtsconfig.la
18
 
 endif
19
 
+
20
 
+traffic_manager_LDADD += @LIBSSL@
21
 
--- trafficserver-3.0.0.orig/mgmt/Makefile.in
22
 
+++ trafficserver-3.0.0/mgmt/Makefile.in
23
 
@@ -546,9 +546,9 @@
24
 
        $(top_builddir)/mgmt/tools/libinksysapi.a \
25
 
        $(top_builddir)/mgmt/tools/libinkconfigapi.a \
26
 
        $(top_builddir)/lib/ts/libtsutil.la @LIBEXPAT@ @LIBPCRE@ \
27
 
-       @LIBSSL@ @LIBTCL@ @LIBICONV@ -lm @LIBDL@ @LIBSOCKET@ @LIBNSL@ \
28
 
+       @LIBTCL@ @LIBICONV@ -lm @LIBDL@ @LIBSOCKET@ @LIBNSL@ \
29
 
        @LIBRESOLV@ @LIBTHREAD@ @LIBRT@ @LIBEXECINFO@ @LIBCAP@ \
30
 
-       $(am__append_1)
31
 
+       $(am__append_1) @LIBSSL@
32
 
 all: all-recursive
33
 
 
34
 
 .SUFFIXES: