~ubuntu-branches/ubuntu/wily/wicd/wily

« back to all changes in this revision

Viewing changes to debian/patches/08-fix_GetIP.patch

  • Committer: Bazaar Package Importer
  • Author(s): David Paleino
  • Date: 2009-03-16 00:51:43 UTC
  • mfrom: (6.1.3 sid)
  • Revision ID: james.westby@ubuntu.com-20090316005143-j73slsk2023jzaly
Tags: 1.5.9-5
* debian/patches/:
  - 08-fix_GetIP.patch added, thanks to Giuseppe Martino
    (Closes: #519433)
  - 09-fix_wire_plugging_detection.patch, added, thanks to Giuseppe 
    Martino (Closes: #503738)
* debian/control:
  - Standards-Version bumped to 3.8.1:
    + debian/init fixed, /var/run/wicd created on init.d script 
    start, since /var/run may be mounted as a temporary filesystem 
    (§9.3.2)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Fixes bug in GetIP(), see #519433 for full description.
 
2
Patch by Giuseppe Martino <denever@truelite.it>, thank you!
 
3
---
 
4
 wicd/wnettools.py |    2 +-
 
5
 1 file changed, 1 insertion(+), 1 deletion(-)
 
6
 
 
7
--- wicd-1.5.9.orig/wicd/wnettools.py
 
8
+++ wicd-1.5.9/wicd/wnettools.py
 
9
@@ -563,7 +563,7 @@ class Interface(object):
 
10
         The IP address of the interface in dotted quad form.
 
11
 
 
12
         """
 
13
-        if not self.iface: return False
 
14
+        if not self.iface: return None
 
15
         cmd = 'ifconfig ' + self.iface
 
16
         if self.verbose: print cmd
 
17
         output = misc.Run(cmd)