~ubuntu-desktop/gbrainy/ubuntu

« back to all changes in this revision

Viewing changes to debian/patches/01_lpi.patch

  • Committer: Mathieu Trudel-Lapierre
  • Date: 2011-07-12 15:22:17 UTC
  • Revision ID: mathieu-tl@ubuntu.com-20110712152217-534f8mnmgq3x9t96
* Merge from debian unstable.  Remaining changes:
  - Add Launchpad integration
  - Pass --disable-gnome
  - Reorder includes so that dh-autoreconf doesn't leave debhelper log file
    around (ref Debian bug #569099)

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
Author: Robert Ancell <robert.ancell@canonical.com>
3
3
Last-Update: 2010-12-20
4
4
 
5
 
Index: gbrainy-1.62/configure.ac
 
5
Index: gbrainy-2.0/configure.ac
6
6
===================================================================
7
 
--- gbrainy-1.62.orig/configure.ac      2011-02-08 10:54:47.000000000 +1100
8
 
+++ gbrainy-1.62/configure.ac   2011-02-10 11:29:10.912806701 +1100
9
 
@@ -62,7 +62,7 @@
 
7
--- gbrainy-2.0.orig/configure.ac       2011-07-01 11:23:11.000000000 -0400
 
8
+++ gbrainy-2.0/configure.ac    2011-07-12 10:27:39.802858999 -0400
 
9
@@ -76,7 +76,7 @@
10
10
 PKG_CHECK_MODULES(GBRAINY_CORE, mono >= $MONO_REQUIRED)
11
11
 
12
12
 
15
15
 AC_SUBST(GBRAINY_LIBS)
16
16
 
17
17
 AC_ARG_ENABLE(addins, AC_HELP_STRING([--disable-addins], [Disable mono-addins support]), , enable_addins="yes")
18
 
Index: gbrainy-1.62/src/Clients/Classical/gbrainy.cs
 
18
Index: gbrainy-2.0/src/Clients/Classical/gbrainy.cs
19
19
===================================================================
20
 
--- gbrainy-1.62.orig/src/Clients/Classical/gbrainy.cs  2011-01-18 08:37:10.000000000 +1100
21
 
+++ gbrainy-1.62/src/Clients/Classical/gbrainy.cs       2011-02-10 11:28:49.662638602 +1100
 
20
--- gbrainy-2.0.orig/src/Clients/Classical/gbrainy.cs   2011-06-27 14:33:15.000000000 -0400
 
21
+++ gbrainy-2.0/src/Clients/Classical/gbrainy.cs        2011-07-12 10:30:42.272857703 -0400
22
22
@@ -23,6 +23,7 @@
23
 
 using Mono.Unix;
24
23
 using System.Diagnostics;
25
24
 using Gdk;
 
25
 using System.Reflection;
26
26
+using LaunchpadIntegration;
27
27
 
28
28
 using gbrainy.Core.Main;
29
29
 using gbrainy.Core.Platform;
30
 
@@ -66,6 +67,7 @@
31
 
                [GtkBeans.Builder.Object] Gtk.MenuItem memory_menuitem;
32
 
                [GtkBeans.Builder.Object] Gtk.MenuItem verbal_menuitem;
33
 
                [GtkBeans.Builder.Object] Gtk.MenuItem extensions_menuitem;
 
30
@@ -70,6 +71,7 @@
 
31
                [GtkBeans.Builder.Object] Gtk.RadioMenuItem vertical_radiomenuitem;
 
32
                [GtkBeans.Builder.Object] Gtk.RadioMenuItem horizontal_radiomenuitem;
 
33
                [GtkBeans.Builder.Object] Gtk.MenuItem toolbar_orientation_menuitem;
34
34
+               [GtkBeans.Builder.Object] Gtk.MenuItem contents_menuitem;
35
35
 
36
 
                DrawingArea drawing_area;
37
 
                GameSession session;
38
 
@@ -127,6 +129,9 @@
39
 
                        GtkBeans.Builder builder = new GtkBeans.Builder ("gbrainy.ui");
40
 
                        builder.Autoconnect (this);
 
36
                Widgets.Toolbar toolbar;
 
37
 
 
38
@@ -146,6 +148,9 @@
 
39
                        toolbar.PauseButton.Clicked += OnPauseGame;
 
40
                        toolbar.FinishButton.Clicked += OnEndGame;
41
41
 
42
42
+                       LaunchpadIntegration.LaunchpadIntegration.SetSourcePackageName ("gbrainy");
43
43
+                       LaunchpadIntegration.LaunchpadIntegration.AddItems (contents_menuitem.Parent, -1, true, true);
44
44
+
45
 
                        BuildToolBar ();
46
 
 
47
 
                        drawing_area = new DrawingArea ();
 
45
                        drawing_area = new GameDrawingArea ();
 
46
                        drawing_area.Drawable = session;
 
47
                        GameSensitiveUI ();