~ubuntu-desktop/gtk/gtk3precise

« back to all changes in this revision

Viewing changes to debian/patches/git_shrinkable_widget.patch

  • Committer: Martin Pitt
  • Date: 2012-04-16 05:46:46 UTC
  • Revision ID: martin.pitt@canonical.com-20120416054646-j5fpzk7houuqy5ua
* New upstream bug fix release:
  - Custom theme can crash apps with GtkEntryCompletion
  - Window expands horizontally rather than the text entry growing
  - conflict between srcdir != builddir and generated enum types
  - Wayland and X11 backends simultaneously enabled is broken
  - Anchored widgets inside GtkTextView are drawn out of place
  - gtk file-chooser: Autocompletion - Dropdown-list: selection fails
  - windows draw as unfocused/backdrop on window managers
  - URL to mailing lists in README incorrect
  - gactionmuxer: Fix list_actions
  - After clicking empty parts of a toolbar/menubar the next mouse click
    (button release) does not work
  - shouldn't set GDK_SOURCE_TOUCHSCREEN based on the name
  - GtkTreeView should not handle extra mouse buttons
  - GdkEventButton contains wrong buttons in modifier mask for button
    releases
  - entrycompletion: set_property() should use property setter functions
  - application-window: try to use the desktop name in the fallback menu
  - Deal more gracefully with a flood of scroll events
  - Translation updates.
* Drop patches which are upstream now:
  -upstream_treeview_rendering.patch
  -git_filechooser_selection.patch
  -git_gtkcellrenderer_grabbing_modifier.patch
  -no_touchscreen_name_hack.patch
  -git_dont_ignore_button_release_event.patch
  -git_shrinkable_widget.patch
  -git_scrolling_performances.patch
* debian/control.in: Bump Build dependencies as per upstream configure.ac.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 12d6b0fe6251e77dbda8c3daeefacb028a267750 Mon Sep 17 00:00:00 2001
2
 
From: Benjamin Otte <otte@redhat.com>
3
 
Date: Thu, 05 Apr 2012 09:30:41 +0000
4
 
Subject: paned: Shrinkable widgets don't require a size
5
 
 
6
 
This could otherwise lead to very funny size request behaviors, in
7
 
particular in empathy.
8
 
 
9
 
https://bugzilla.gnome.org/show_bug.cgi?id=587441
10
 
---
11
 
diff --git a/gtk/gtkpaned.c b/gtk/gtkpaned.c
12
 
index f2fbe13..5b374b2 100644
13
 
--- a/gtk/gtkpaned.c
14
 
+++ b/gtk/gtkpaned.c
15
 
@@ -904,7 +904,10 @@ gtk_paned_get_preferred_size (GtkWidget      *widget,
16
 
   if (priv->child1 && gtk_widget_get_visible (priv->child1))
17
 
     {
18
 
       get_preferred_size_for_size (priv->child1, orientation, size, &child_min, &child_nat);
19
 
-      *minimum = child_min;
20
 
+      if (priv->child1_shrink && priv->orientation == orientation)
21
 
+        *minimum = 0;
22
 
+      else
23
 
+        *minimum = child_min;
24
 
       *natural = child_nat;
25
 
     }
26
 
 
27
 
@@ -914,7 +917,8 @@ gtk_paned_get_preferred_size (GtkWidget      *widget,
28
 
 
29
 
       if (priv->orientation == orientation)
30
 
         {
31
 
-          *minimum += child_min;
32
 
+          if (!priv->child2_shrink)
33
 
+            *minimum += child_min;
34
 
           *natural += child_nat;
35
 
         }
36
 
       else
37
 
--
38
 
cgit v0.9.0.2
39