~ubuntu-desktop/gtk/ubuntu

« back to all changes in this revision

Viewing changes to debian/patches/001_static-linking-dont-query-immodules.patch

  • Committer: Gianfranco Costamagna
  • Date: 2018-07-02 10:05:37 UTC
  • Revision ID: costamagnagianfranco@yahoo.it-20180702100537-q9b1n6o6cmd9q9ev
Tags: 2.24.32-2ubuntu1
releasing package gtk+2.0 version 2.24.32-2ubuntu1

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Don't query immodules for the local tree when cross-compiling or
2
 
             when --disable-shared was given
 
1
From: =?utf-8?q?Lo=C3=AFc_Minier?= <lool@dooz.org>
 
2
Date: Sat, 21 Sep 2013 23:37:03 +0200
 
3
Subject: Don't query immodules for the local tree under --disable-shared
 
4
 
 
5
[mbiebl: follow upstream and use immodules.cache instead of gtk.immodules]
 
6
 
3
7
Bug: http://bugzilla.gnome.org/show_bug.cgi?id=346531
 
8
Forwarded: yes
 
9
Applied-upstream: no, bug was closed due to lack of feedback
 
10
---
 
11
 configure.ac              |  1 +
 
12
 modules/input/Makefile.am | 17 ++++++++++++++++-
 
13
 2 files changed, 17 insertions(+), 1 deletion(-)
4
14
 
5
 
Index: gtk+-2.24.19/configure.ac
6
 
===================================================================
7
 
--- gtk+-2.24.19.orig/configure.ac      2013-06-28 23:39:49.071200389 +0200
8
 
+++ gtk+-2.24.19/configure.ac   2013-06-28 23:39:49.063200297 +0200
9
 
@@ -150,6 +150,7 @@
10
 
 dnl Initialize libtool
11
 
 AC_PROG_CC
12
 
 AM_DISABLE_STATIC
13
 
+AM_CONDITIONAL([ENABLE_STATIC], [test "$enable_static" = yes])
14
 
 
15
 
 dnl 
16
 
 dnl Check for a working C++ compiler, but do not bail out, if none is found.
17
 
Index: gtk+-2.24.19/modules/input/Makefile.am
18
 
===================================================================
19
 
--- gtk+-2.24.19.orig/modules/input/Makefile.am 2013-06-28 23:39:49.071200389 +0200
20
 
+++ gtk+-2.24.19/modules/input/Makefile.am      2013-06-28 23:39:49.063200297 +0200
21
 
@@ -189,8 +189,12 @@
 
15
diff --git a/configure.ac b/configure.ac
 
16
index b75f9c6..58d3492 100644
 
17
--- a/configure.ac
 
18
+++ b/configure.ac
 
19
@@ -182,6 +182,7 @@ fi
 
20
 
 
21
 AC_LIBTOOL_WIN32_DLL
 
22
 AM_PROG_LIBTOOL
 
23
+AM_CONDITIONAL([ENABLE_SHARED], [test "$enable_shared" = yes])
 
24
 dnl when using libtool 2.x create libtool early, because it's used in configure
 
25
 m4_ifdef([LT_OUTPUT], [LT_OUTPUT])
 
26
 
 
27
diff --git a/modules/input/Makefile.am b/modules/input/Makefile.am
 
28
index c8610fa..bfe5085 100644
 
29
--- a/modules/input/Makefile.am
 
30
+++ b/modules/input/Makefile.am
 
31
@@ -189,7 +189,11 @@ dist_imconffile_DATA = im-multipress.conf
22
32
 if CROSS_COMPILING
23
33
 RUN_QUERY_IMMODULES_TEST=false
24
34
 else
25
 
+if ENABLE_STATIC
 
35
+if ENABLE_SHARED
 
36
 RUN_QUERY_IMMODULES_TEST=test -z "$(DESTDIR)"
 
37
+else
26
38
+RUN_QUERY_IMMODULES_TEST=false
27
 
+else
28
 
 RUN_QUERY_IMMODULES_TEST=test -z "$(DESTDIR)"
 
39
+endif
29
40
 endif
30
 
+endif
31
41
 
32
42
 # Running this if cross compiling or if DESTDIR is set is going to
33
 
 # not work at all, so skip it.
34
 
@@ -253,7 +257,18 @@
 
43
@@ -253,7 +257,18 @@ noinst_LTLIBRARIES =                               \
35
44
 included-modules: $(noinst_LTLIBRARIES)
36
45
 
37
46
 immodules.cache: Makefile.am $(module_LTLIBRARIES)