~ubuntu-desktop/gtk/ubuntu

« back to all changes in this revision

Viewing changes to debian/patches/005_support_disabling_x11_extensions.patch

  • Committer: Gianfranco Costamagna
  • Date: 2018-07-02 10:05:37 UTC
  • Revision ID: costamagnagianfranco@yahoo.it-20180702100537-q9b1n6o6cmd9q9ev
Tags: 2.24.32-2ubuntu1
releasing package gtk+2.0 version 2.24.32-2ubuntu1

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Cyril Brulebois <kibi@debian.org>
 
2
Date: Fri, 6 Apr 2018 09:22:20 +0100
 
3
Subject: Support disabling X11 extensions
 
4
 
 
5
We want this in Debian as we build GTK+ with extensions enabled for the
 
6
normal build, but disable them for the special build that will be used
 
7
in the graphical installer, because it needs to be as small as possible.
 
8
 
1
9
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=612918
2
 
Author: Cyril Brulebois <kibi@debian.org>
3
 
 
4
 
Support disabling X11 extensions
5
 
 
6
 
Index: b/configure.ac
7
 
===================================================================
 
10
Applied-upstream: 2.99.1, commit:ec15c405cf6354e9267e7e6b7ce878c519bffe4c
 
11
---
 
12
 configure.ac | 23 +++++++++++++++++++----
 
13
 1 file changed, 19 insertions(+), 4 deletions(-)
 
14
 
 
15
diff --git a/configure.ac b/configure.ac
 
16
index 7eb26f1..560afbf 100644
8
17
--- a/configure.ac
9
18
+++ b/configure.ac
10
 
@@ -241,6 +241,18 @@
 
19
@@ -241,6 +241,18 @@ AC_ARG_ENABLE(xinerama,
11
20
               [AC_HELP_STRING([--enable-xinerama],
12
21
                              [support xinerama extension if available [default=yes]])],,
13
22
               [enable_xinerama="yes"])
26
35
 AC_ARG_ENABLE(rebuilds,
27
36
               [AC_HELP_STRING([--disable-rebuilds],
28
37
                               [disable all source autogeneration rules])],,
29
 
@@ -1190,7 +1202,8 @@
 
38
@@ -1190,7 +1202,8 @@ if test "x$gdktarget" = "xx11"; then
30
39
   AM_CONDITIONAL(XINPUT_XFREE, test x$with_xinput = xxfree || test x$with_xinput = xyes)
31
40
 
32
41
   # Check for the RANDR extension
36
45
      AC_DEFINE(HAVE_RANDR, 1, [Have the Xrandr extension library])
37
46
 
38
47
      if $PKG_CONFIG --exists "xrandr >= 1.5.0" ; then
39
 
@@ -1209,7 +1222,8 @@
 
48
@@ -1209,7 +1222,8 @@ if test "x$gdktarget" = "xx11"; then
40
49
 
41
50
   # Checks for XFixes extension
42
51
   
46
55
     AC_DEFINE(HAVE_XFIXES, 1, [Have the XFIXES X extension])
47
56
     
48
57
     X_PACKAGES="$X_PACKAGES xfixes"
49
 
@@ -1218,7 +1232,8 @@
 
58
@@ -1218,7 +1232,8 @@ if test "x$gdktarget" = "xx11"; then
50
59
 
51
60
   # Checks for Xcomposite extension
52
61
 
56
65
     AC_DEFINE(HAVE_XCOMPOSITE, 1, [Have the XCOMPOSITE X extension])
57
66
 
58
67
     X_PACKAGES="$X_PACKAGES xcomposite"
59
 
@@ -1227,7 +1242,7 @@
 
68
@@ -1227,7 +1242,7 @@ if test "x$gdktarget" = "xx11"; then
60
69
 
61
70
   # Checks for Xdamage extension
62
71