~ubuntu-desktop/gtk/ubuntu

« back to all changes in this revision

Viewing changes to debian/patches/005_support_disabling_x11_extensions.patch

  • Committer: Iain Lane
  • Date: 2018-07-24 16:02:42 UTC
  • Revision ID: iain@orangesquash.org.uk-20180724160242-ggbnqhoswku5wpvl
Moved to git: lp:~ubuntu-desktop/ubuntu/+source/gtk+2.0

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Cyril Brulebois <kibi@debian.org>
2
 
Date: Fri, 6 Apr 2018 09:22:20 +0100
3
 
Subject: Support disabling X11 extensions
4
 
 
5
 
We want this in Debian as we build GTK+ with extensions enabled for the
6
 
normal build, but disable them for the special build that will be used
7
 
in the graphical installer, because it needs to be as small as possible.
8
 
 
9
 
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=612918
10
 
Applied-upstream: 2.99.1, commit:ec15c405cf6354e9267e7e6b7ce878c519bffe4c
11
 
---
12
 
 configure.ac | 23 +++++++++++++++++++----
13
 
 1 file changed, 19 insertions(+), 4 deletions(-)
14
 
 
15
 
diff --git a/configure.ac b/configure.ac
16
 
index 7eb26f1..560afbf 100644
17
 
--- a/configure.ac
18
 
+++ b/configure.ac
19
 
@@ -241,6 +241,18 @@ AC_ARG_ENABLE(xinerama,
20
 
               [AC_HELP_STRING([--enable-xinerama],
21
 
                              [support xinerama extension if available [default=yes]])],,
22
 
               [enable_xinerama="yes"])
23
 
+AC_ARG_ENABLE(xrandr,
24
 
+             [AC_HELP_STRING([--enable-xrandr],
25
 
+                             [support XRandR extension if available [default=yes]])])
26
 
+AC_ARG_ENABLE(xfixes,
27
 
+             [AC_HELP_STRING([--enable-xfixes],
28
 
+                             [support XFixes extension if available [default=yes]])])
29
 
+AC_ARG_ENABLE(xcomposite,
30
 
+             [AC_HELP_STRING([--enable-xcomposite],
31
 
+                             [support X Composite extension if available [default=yes]])])
32
 
+AC_ARG_ENABLE(xdamage,
33
 
+             [AC_HELP_STRING([--enable-xdamage],
34
 
+                             [support X Damage extension if available [default=yes]])])
35
 
 AC_ARG_ENABLE(rebuilds,
36
 
               [AC_HELP_STRING([--disable-rebuilds],
37
 
                               [disable all source autogeneration rules])],,
38
 
@@ -1190,7 +1202,8 @@ if test "x$gdktarget" = "xx11"; then
39
 
   AM_CONDITIONAL(XINPUT_XFREE, test x$with_xinput = xxfree || test x$with_xinput = xyes)
40
 
 
41
 
   # Check for the RANDR extension
42
 
-  if $PKG_CONFIG --exists "xrandr >= 1.2.99" ; then
43
 
+  if test x"$enable_xrandr" != xno && \
44
 
+     $PKG_CONFIG --exists "xrandr >= 1.2.99" ; then
45
 
      AC_DEFINE(HAVE_RANDR, 1, [Have the Xrandr extension library])
46
 
 
47
 
      if $PKG_CONFIG --exists "xrandr >= 1.5.0" ; then
48
 
@@ -1209,7 +1222,8 @@ if test "x$gdktarget" = "xx11"; then
49
 
 
50
 
   # Checks for XFixes extension
51
 
   
52
 
-  if $PKG_CONFIG --exists xfixes ; then
53
 
+  if test x"$enable_xfixes" != xno && \
54
 
+     $PKG_CONFIG --exists xfixes ; then
55
 
     AC_DEFINE(HAVE_XFIXES, 1, [Have the XFIXES X extension])
56
 
     
57
 
     X_PACKAGES="$X_PACKAGES xfixes"
58
 
@@ -1218,7 +1232,8 @@ if test "x$gdktarget" = "xx11"; then
59
 
 
60
 
   # Checks for Xcomposite extension
61
 
 
62
 
-  if $PKG_CONFIG --exists xcomposite ; then
63
 
+  if test x"$enable_xcomposite" != xno && \
64
 
+     $PKG_CONFIG --exists xcomposite ; then
65
 
     AC_DEFINE(HAVE_XCOMPOSITE, 1, [Have the XCOMPOSITE X extension])
66
 
 
67
 
     X_PACKAGES="$X_PACKAGES xcomposite"
68
 
@@ -1227,7 +1242,7 @@ if test "x$gdktarget" = "xx11"; then
69
 
 
70
 
   # Checks for Xdamage extension
71
 
 
72
 
-  if $PKG_CONFIG --exists xdamage ; then
73
 
+  if test x"$enable_xdamage" != xno && $PKG_CONFIG --exists xdamage ; then
74
 
     AC_DEFINE(HAVE_XDAMAGE, 1, [Have the XDAMAGE X extension])
75
 
 
76
 
     X_PACKAGES="$X_PACKAGES xdamage"