~ubuntu-dev/ubuntu/lucid/dovecot/lucid-201002101901

« back to all changes in this revision

Viewing changes to debian/patches/dovecot-mboxlocking.dpatch

  • Committer: Chuck Short
  • Date: 2010-01-21 20:21:25 UTC
  • mfrom: (4.1.11 squeeze)
  • Revision ID: zulcss@ubuntu.com-20100121202125-pme73o491kfwj5nc
* Merge from debian testing, remaining changes:
  + Add new binary pkg dovecot-postfix that integrates postfix and dovecot
    automatically: (LP: #164837)
  + debian/control:
    - add new binary with short description
    - set Architecture all for dovecot-postfix (LP: #329878)
  + debian/dovecot-postfix.postinst:
    - create initial certificate symlinks to snakeoil.
    - set up postfix with postconf to:
      - use Maildir/ as the default mailbox.
      - use dovecot as the sasl authentication server.
      - use dovecot LDA (deliver).
      - use tls for smtp{d} services.
    - fix certificates paths in postfix' main.cf
    - add reject_unauth_destination to postfix' recipient restrictions
    - add reject_unknown_sender_domain to postfix' sender restriction
    - rename configuration name on remove, delete on purge
    - restart dovecot after linking certificates
    - handle use case when postfix is unconfigurated
  + debian/dovecot-postfix.dirs: create backup directory for postfix's config
    configuration
  + restart postfix and dovecot.
  + debian/dovecot-postfix.postrm:
    - remove all dovecot related configuration from postfix.
    - restart postfix and dovecot.
  + debian/dovecot-common.init:
    - check if /etc/dovecot/dovecot-postfix.conf exists and use it
      as the configuration file if so.
  + debian/patches/warning-ubuntu-postfix.dpatch
    - add warning about dovecot-postfix.conf in dovecot default
      configuration file
  + debian/patches/dovecot-postfix.conf.diff:
    - Ubuntu server custom changes to the default dovecot configuration for
      better interfation with postfix.
    - enable sieve plugin.
    - Ubuntu server custom changes to the default dovecot configuration for
      better integration with postfix:
      - enable imap, pop3, imaps, pop3s and managesieve by default.
      - enable dovecot LDA (deliver).
      - enable SASL auth socket in postfix private directory
   + debian/rules:
     - copy, patch and install dovecot-postfix.conf in /etc/dovecot/.
     - build architecure independent packages too
   + Use Snakeoil SSL certificates by default.
     - debian/control: Depend on ssl-cert.
     - debian/patches/ssl-cert-snakeoil.dpatch: Change default SSL cert
       paths to snakeoil.
     - debian/dovecot-common.postinst: Relax grep for SSL_* a bit.
   + Add autopkgtest to debian/tests/*.
   + Fast TearDown: Update the lsb init header to not stop in level 6.
   + Add ufw integration:
     - Created debian/dovecot-common.ufw.profile.
     - debian/rules: install profile.
     - debian/control: suggest ufw.
   + debian/{control,rules}: enable PIE hardening.
   + dovecot-imapd, dovecot-pop3: Replaces dovecot-common (<< 1:1.1). (LP: #254721)
   + debian/control: Update Vcs-* headers.
   + Add SMTP-AUTH support for Outlook (login auth mechanism)
* New upstream release.
* debian/patches/gold-fix.patch: Removed. Fixed upstream.
* Moved libexec to lib corrections in dovecot-managesieve.patch and
  dovecot-managesieve-dist.patch to dovecot-example.patch
* debian/patches/dovecot-mboxlocking.patch: Regenerated to avoid FTBFS
  when quilt isn't installed.
* debian/patches/quota-mountpoint.patch: Removed. Not needed anymore.
* debian/patches/dovecot-quota.patch: Removed. Quotas aren't properly
  enabled unless mail_plugins = quota imap_quota.
* debian/patches/gold-fix.patch: Fixed configure script to build even
  with binutils-gold or --no-add-needed linker flag (Closes: #554306)
* debian/dovecot-common.init: fixed LSB headers. Thanks to Pascal Volk.
  (Closes: #558040)
* debian/changelog: added CVE references to previous changelog entry.
* debian/rules: checked up the build system. It's not fragile anymore.
  (Closes: 493803)
* debian/dovecot-common.postinst: Now invoking dpkg-reconfigure
  on dovecot-common is enough to generate new certificates
  if the previous ones were removed. (Closes: #545582)
* debian/rules: No longer install convert-tool in /usr/bin.
  It isn't an user utility and it should stay in /usr/lib/dovecot
  like all other similar tool.
* New upstream release. (Closes: #557601)
* [SECURITY] Fixes local information disclosure and denial of service.
  (see: http://www.dovecot.org/list/dovecot-news/2009-November/000143.html
  and CVE-2009-3897)
* Added myself to uploaders.
* Switched to the new source format "3.0 (quilt)":
  - removed dpatch from build-depends
  - removed debian/README.source because now we use only standard
    dpkg features
  - regenerated all patches
* Prepared to switch to multi-origin source:
  - recreated dovecot-libsieve.patch and dovecot-managesieve-dist.patch
    starting from the upstream tarball
  - removed all autotools related build-depends and build-conflict
  - renamed dovecot-libsieve and dovecot-managesieve directories
    to libsieve and managesieve.
* debian/rules: Moved the configuration of libsieve and managesieve from
  the build phase to the configuration phase
* Added dovecot-dbg package  with debugging symbols.  Thanks Stephan Bosch.
  (Closes: #554710)
* Fixed some stray libexec'isms in the default configuration.
* New upstream release.
* debian/dovecot-common.init:
  - use $CONF when starting the daemon. (Closes: #549944)
  - always output start/stop messages. (Closes: #523810)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
 
3
 
## DP: Change default Debian value in accordance with Debian Policy
4
 
## DP: Author: Joel Johnson <mrjoel@lixil.net>
5
 
 
6
 
. $(dirname $0)/DPATCH
7
 
 
8
 
exit 0
9
 
@DPATCH@
10
 
diff -urN dovecot-1.2.1/dovecot-example.conf dovecot-1.2.1-debian/dovecot-example.conf
11
 
--- dovecot-1.2.1/dovecot-example.conf  2009-06-11 12:19:47.000000000 -0600
12
 
+++ dovecot-1.2.1-debian/dovecot-example.conf   2009-07-17 08:33:23.000000000 -0600
13
 
@@ -481,8 +481,14 @@
14
 
 # in is important to avoid deadlocks if other MTAs/MUAs are using multiple
15
 
 # locking methods as well. Some operating systems don't allow using some of
16
 
 # them simultaneously.
17
 
+#
18
 
+# The Debian value for mbox_write_locks differs from upstream Dovecot. It is
19
 
+# changed to be compliant with Debian Policy (section 11.6) for NFS safety.
20
 
+#       Dovecot: mbox_write_locks = dotlock fcntl
21
 
+#       Debian:  mbox_write_locks = fcntl dotlock
22
 
+#
23
 
 #mbox_read_locks = fcntl
24
 
-#mbox_write_locks = dotlock fcntl
25
 
+#mbox_write_locks = fcntl dotlock
26
 
 
27
 
 # Maximum time in seconds to wait for lock (all of them) before aborting.
28
 
 #mbox_lock_timeout = 300
29
 
diff -urN dovecot-1.2.1/src/master/master-settings.c dovecot-1.2.1-debian/src/master/master-settings.c
30
 
--- dovecot-1.2.1/src/master/master-settings.c  2009-06-30 09:02:57.000000000 -0600
31
 
+++ dovecot-1.2.1-debian/src/master/master-settings.c   2009-07-17 08:37:05.000000000 -0600
32
 
@@ -255,7 +255,7 @@
33
 
        MEMBER(maildir_copy_preserve_filename) FALSE,
34
 
        MEMBER(maildir_very_dirty_syncs) FALSE,
35
 
        MEMBER(mbox_read_locks) "fcntl",
36
 
-       MEMBER(mbox_write_locks) "dotlock fcntl",
37
 
+       MEMBER(mbox_write_locks) "fcntl dotlock",
38
 
        MEMBER(mbox_lock_timeout) 300,
39
 
        MEMBER(mbox_dotlock_change_timeout) 120,
40
 
        MEMBER(mbox_min_index_size) 0,
41
 
@@ -1822,7 +1822,15 @@
42
 
        const char *set_names[4];
43
 
        unsigned int count;
44
 
 
45
 
-       sets[0] = &default_settings;
46
 
+       /* Debian change - the Debian default for mbox_write_lock differs from
47
 
+               upstream Dovecot, however we still want 'dovecot -n' to report
48
 
+               based on Dovecot defaults to make it clear that the setting is
49
 
+               different, so we make a copy of the default_settings and force
50
 
+               it to report based on strict Dovecot defaults
51
 
+       */
52
 
+       struct settings dovecot_default_settings = default_settings;
53
 
+       dovecot_default_settings.mbox_write_locks = "dotlock fcntl";
54
 
+       sets[0] = &dovecot_default_settings;
55
 
        sets[1] = set->defaults;
56
 
 
57
 
        set_names[0] = NULL;