~ubuntu-multiseat/ubuntu/trusty/udisks2/full-logind-support

« back to all changes in this revision

Viewing changes to debian/patches/00git_dev_t_annotation.patch

  • Committer: Package Import Robot
  • Author(s): Martin Pitt
  • Date: 2012-09-20 12:04:46 UTC
  • mfrom: (1.1.3)
  • Revision ID: package-import@ubuntu.com-20120920120446-bero0m8f04k96yod
Tags: 1.99.0+git20120919-1
* Update to current upstream git head:
  - configure.ac: raise gudev dependency
  - Update list of recovery/system partitions
  - Add support for creating exFAT filesystems and changing exFAT labels
  - Add textual descriptions for IMSM Raid members
  - Use all-caps for RAID in descriptions
  - Lots of test suite robustifications and added tests
  - Enable large file support (LP: #1039022)
  - Mount vfat with "flush" option
* Drop 00git_dev_t_annotation.patch, 00git_testsuite.patch.
* debian/control: Bump libgudev-1.0-dev build dependency as per upstream
  configure.ac.
* debian/udisks2.install: Install umount.udisks2 into /sbin; our old
  util-linux version does not yet find it in /usr/sbin/. (LP: #1019651)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
commit 3b135a8d49a3b10b6b6ac050cfd457fa027f8b73
2
 
Author: Martin Pitt <martinpitt@gnome.org>
3
 
Date:   Wed Sep 5 18:29:21 2012 +0200
4
 
 
5
 
    Add workaround annotation for udisks_client_get_block_for_dev()
6
 
    
7
 
    The gobject-introspection parser does not know how to properly handle dev_t
8
 
    arguments (https://bugzilla.gnome.org/show_bug.cgi?id=584517) and treats them
9
 
    as gint. But as the native API expects a 64 bit integer, you'll get garbage in
10
 
    the upper word on 32 bit platforms, which cause
11
 
    UDisks.Block.get_block_for_dev() to never find a match when using through
12
 
    introspection.
13
 
    
14
 
    https://bugs.freedesktop.org/show_bug.cgi?id=54566
15
 
 
16
 
diff --git a/udisks/udisksclient.c b/udisks/udisksclient.c
17
 
index 17d0914..9981a93 100644
18
 
--- a/udisks/udisksclient.c
19
 
+++ b/udisks/udisksclient.c
20
 
@@ -640,10 +640,13 @@ udisks_client_get_block_for_uuid (UDisksClient        *client,
21
 
 
22
 
 /* ---------------------------------------------------------------------------------------------------- */
23
 
 
24
 
+/* Note: The (type guint64) is a workaround for g-i mishandling dev_t, see
25
 
+ * https://bugzilla.gnome.org/show_bug.cgi?id=584517 */
26
 
+
27
 
 /**
28
 
  * udisks_client_get_block_for_dev:
29
 
  * @client: A #UDisksClient.
30
 
- * @block_device_number: A #dev_t to get a #UDisksBlock for.
31
 
+ * @block_device_number: (type guint64): A #dev_t to get a #UDisksBlock for.
32
 
  *
33
 
  * Gets the #UDisksBlock corresponding to @block_device_number, if any.
34
 
  *