~valavanisalex/ubuntu/oneiric/inkscape/inkscape_0.48.1-2ubuntu4

« back to all changes in this revision

Viewing changes to debian/patches/02-add-shebangs-and-fix-permissions.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Alex Valavanis
  • Date: 2011-02-20 12:07:30 UTC
  • mfrom: (2.5.1 sid)
  • Revision ID: james.westby@ubuntu.com-20110220120730-p7o6sq6i6wwt4398
Tags: 0.48.1-2ubuntu1
* Merge with Debian unstable (LP: #719648, LP: #278307).  Remaining changes:
* debian/control: 
  - Ubuntu maintainers
  - Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
  - Demote pstoedit to Suggests (universe package).
* debian/rules:
  - Run intltool-update on build (Ubuntu-specific).
  - Add translation domain to .desktop files (Ubuntu-specific)
* debian/patches/01_add_unity_quicklist_support.patch:
  - add unity quicklist support for a new entry to inkscape (LP: #676886)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 02-add-shebangs-and-fix-permissions.dpatch by  <wolfi@sigxcpu.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Patch to fix permissions and add missing shebang-lines in scripts.
 
6
## DP: Taken from upstream's Bug tracker at
 
7
## DP: https://bugs.launchpad.net/inkscape/+bug/602005
 
8
## DP: original patch by Leo Jackson
 
9
 
 
10
@DPATCH@
 
11
 
 
12
=== modified file 'share/extensions/Barcode/Base.py'
 
13
--- a/share/extensions/Barcode/Base.py  2008-03-29 10:21:03 +0000
 
14
+++ b/share/extensions/Barcode/Base.py  2010-07-24 17:56:48 +0000
 
15
@@ -1,3 +1,4 @@
 
16
+#!/usr/bin/env python
 
17
 '''
 
18
 Copyright (C) 2007 Martin Owens
 
19
 
 
20
 
 
21
=== modified file 'share/extensions/Barcode/Code128.py'
 
22
--- a/share/extensions/Barcode/Code128.py       2010-02-28 22:40:23 +0000
 
23
+++ b/share/extensions/Barcode/Code128.py       2010-07-24 17:56:48 +0000
 
24
@@ -1,3 +1,4 @@
 
25
+#!/usr/bin/env python 
 
26
 '''
 
27
 Copyright (C) 2007 Martin Owens
 
28
 
 
29
 
 
30
=== modified file 'share/extensions/Barcode/Code39.py'
 
31
--- a/share/extensions/Barcode/Code39.py        2007-04-25 00:53:02 +0000
 
32
+++ b/share/extensions/Barcode/Code39.py        2010-07-24 17:56:48 +0000
 
33
@@ -1,3 +1,4 @@
 
34
+#!/usr/bin/env python
 
35
 '''
 
36
 Copyright (C) 2007 Martin Owens
 
37
 
 
38
 
 
39
=== modified file 'share/extensions/Barcode/Code39Ext.py'
 
40
--- a/share/extensions/Barcode/Code39Ext.py     2007-04-25 00:53:02 +0000
 
41
+++ b/share/extensions/Barcode/Code39Ext.py     2010-07-24 17:56:48 +0000
 
42
@@ -1,3 +1,4 @@
 
43
+#!/usr/bin/env python
 
44
 '''
 
45
 Copyright (C) 2007 Martin Owens
 
46
 
 
47
 
 
48
=== modified file 'share/extensions/Barcode/Code93.py'
 
49
--- a/share/extensions/Barcode/Code93.py        2010-04-27 17:09:54 +0000
 
50
+++ b/share/extensions/Barcode/Code93.py        2010-07-24 17:56:48 +0000
 
51
@@ -1,3 +1,4 @@
 
52
+#!/usr/bin/env python
 
53
 '''
 
54
 Copyright (C) 2007 Martin Owens
 
55
 
 
56
 
 
57
=== modified file 'share/extensions/Barcode/EAN13.py'
 
58
--- a/share/extensions/Barcode/EAN13.py 2009-12-20 22:09:40 +0000
 
59
+++ b/share/extensions/Barcode/EAN13.py 2010-07-24 17:56:48 +0000
 
60
@@ -1,3 +1,4 @@
 
61
+#!/usr/bin/env python
 
62
 '''
 
63
 Copyright (C) 2007 Martin Owens
 
64
 
 
65
 
 
66
=== modified file 'share/extensions/Barcode/EAN5.py'
 
67
--- a/share/extensions/Barcode/EAN5.py  2009-12-22 00:13:41 +0000
 
68
+++ b/share/extensions/Barcode/EAN5.py  2010-07-24 17:56:48 +0000
 
69
@@ -1,3 +1,4 @@
 
70
+#!/usr/bin/env python 
 
71
 ''' 
 
72
 Copyright (C) 2007 Martin Owens 
 
73
 Copyright (C) 2009 Aaron C Spike 
 
74
 
 
75
=== modified file 'share/extensions/Barcode/EAN8.py'
 
76
--- a/share/extensions/Barcode/EAN8.py  2007-04-25 00:53:02 +0000
 
77
+++ b/share/extensions/Barcode/EAN8.py  2010-07-24 17:56:48 +0000
 
78
@@ -1,3 +1,4 @@
 
79
+#!/usr/bin/env python
 
80
 '''
 
81
 Copyright (C) 2007 Martin Owens
 
82
 
 
83
 
 
84
=== modified file 'share/extensions/Barcode/RM4CC.py'
 
85
--- a/share/extensions/Barcode/RM4CC.py 2007-04-25 00:53:02 +0000
 
86
+++ b/share/extensions/Barcode/RM4CC.py 2010-07-24 17:56:48 +0000
 
87
@@ -1,3 +1,4 @@
 
88
+#!/usr/bin/env python
 
89
 '''
 
90
 Copyright (C) 2007 Martin Owens
 
91
 
 
92
 
 
93
=== modified file 'share/extensions/Barcode/UPCA.py'
 
94
--- a/share/extensions/Barcode/UPCA.py  2009-12-20 22:09:40 +0000
 
95
+++ b/share/extensions/Barcode/UPCA.py  2010-07-24 17:56:48 +0000
 
96
@@ -1,3 +1,4 @@
 
97
+#!/usr/bin/env python
 
98
 '''
 
99
 Copyright (C) 2007 Martin Owens
 
100
 
 
101
 
 
102
=== modified file 'share/extensions/Barcode/UPCE.py'
 
103
--- a/share/extensions/Barcode/UPCE.py  2009-12-20 22:09:40 +0000
 
104
+++ b/share/extensions/Barcode/UPCE.py  2010-07-24 17:56:48 +0000
 
105
@@ -1,3 +1,4 @@
 
106
+#!/usr/bin/env python
 
107
 '''
 
108
 Copyright (C) 2007 Martin Owens
 
109
 
 
110
 
 
111
=== modified file 'share/extensions/Barcode/__init__.py'
 
112
--- a/share/extensions/Barcode/__init__.py      2009-12-21 23:48:17 +0000
 
113
+++ b/share/extensions/Barcode/__init__.py      2010-07-24 17:56:48 +0000
 
114
@@ -1,4 +1,4 @@
 
115
-
 
116
+#!/usr/bin/env python
 
117
 '''
 
118
 Barcodes SVG Extention
 
119
 
 
120
 
 
121
=== modified file 'share/extensions/SpSVG.pm'
 
122
--- a/share/extensions/SpSVG.pm 2006-01-16 02:36:01 +0000
 
123
+++ b/share/extensions/SpSVG.pm 2010-07-24 17:56:48 +0000
 
124
@@ -1,4 +1,4 @@
 
125
-#!/usr/bin/perl -w
 
126
+#!/usr/bin/env perl -w
 
127
 #
 
128
 # SpSVG
 
129
 # 
 
130
 
 
131
=== modified file 'share/extensions/color_blackandwhite.py'
 
132
--- a/share/extensions/color_blackandwhite.py   2010-02-14 09:46:42 +0000
 
133
+++ b/share/extensions/color_blackandwhite.py   2010-07-24 17:56:48 +0000
 
134
@@ -1,3 +1,4 @@
 
135
+#!/usr/bin/env python
 
136
 import coloreffect,sys
 
137
 
 
138
 class C(coloreffect.ColorEffect):
 
139
 
 
140
=== modified file 'share/extensions/color_brighter.py'
 
141
--- a/share/extensions/color_brighter.py        2008-03-29 10:21:03 +0000
 
142
+++ b/share/extensions/color_brighter.py        2010-07-24 17:56:48 +0000
 
143
@@ -1,3 +1,4 @@
 
144
+#!/usr/bin/env python
 
145
 import coloreffect
 
146
 
 
147
 class C(coloreffect.ColorEffect):
 
148
 
 
149
=== modified file 'share/extensions/color_custom.py'
 
150
--- a/share/extensions/color_custom.py  2008-03-29 10:21:03 +0000
 
151
+++ b/share/extensions/color_custom.py  2010-07-24 17:56:48 +0000
 
152
@@ -1,3 +1,4 @@
 
153
+#!/usr/bin/env python
 
154
 import coloreffect
 
155
 
 
156
 class C(coloreffect.ColorEffect):
 
157
@@ -22,4 +23,4 @@
 
158
     return '%02x%02x%02x' % (int(round(r2*255)),int(round(g2*255)),int(round(b2*255)))
 
159
 
 
160
 c = C()
 
161
-c.affect()
 
162
\ No newline at end of file
 
163
+c.affect()
 
164
 
 
165
=== modified file 'share/extensions/color_darker.py'
 
166
--- a/share/extensions/color_darker.py  2008-03-29 10:21:03 +0000
 
167
+++ b/share/extensions/color_darker.py  2010-07-24 17:56:48 +0000
 
168
@@ -1,3 +1,4 @@
 
169
+#!/usr/bin/env python
 
170
 import coloreffect
 
171
 
 
172
 class C(coloreffect.ColorEffect):
 
173
 
 
174
=== modified file 'share/extensions/color_desaturate.py'
 
175
--- a/share/extensions/color_desaturate.py      2008-03-29 10:21:03 +0000
 
176
+++ b/share/extensions/color_desaturate.py      2010-07-24 17:56:48 +0000
 
177
@@ -1,3 +1,4 @@
 
178
+#!/usr/bin/env python
 
179
 import coloreffect
 
180
 
 
181
 class C(coloreffect.ColorEffect):
 
182
@@ -7,4 +8,4 @@
 
183
     return '%02x%02x%02x' % (ig,ig,ig)
 
184
 
 
185
 c = C()
 
186
-c.affect()
 
187
\ No newline at end of file
 
188
+c.affect()
 
189
 
 
190
=== modified file 'share/extensions/color_grayscale.py'
 
191
--- a/share/extensions/color_grayscale.py       2008-03-29 10:21:03 +0000
 
192
+++ b/share/extensions/color_grayscale.py       2010-07-24 17:56:48 +0000
 
193
@@ -1,3 +1,4 @@
 
194
+#!/usr/bin/env python
 
195
 import coloreffect
 
196
 
 
197
 class C(coloreffect.ColorEffect):
 
198
@@ -11,4 +12,4 @@
 
199
     return '%02x%02x%02x' % (ig,ig,ig)
 
200
 
 
201
 c = C()
 
202
-c.affect()
 
203
\ No newline at end of file
 
204
+c.affect()
 
205
 
 
206
=== modified file 'share/extensions/color_lesshue.py'
 
207
--- a/share/extensions/color_lesshue.py 2008-03-29 10:21:03 +0000
 
208
+++ b/share/extensions/color_lesshue.py 2010-07-24 17:56:48 +0000
 
209
@@ -1,3 +1,4 @@
 
210
+#!/usr/bin/env python
 
211
 import coloreffect, inkex
 
212
 
 
213
 class C(coloreffect.ColorEffect):
 
214
 
 
215
=== modified file 'share/extensions/color_lesslight.py'
 
216
--- a/share/extensions/color_lesslight.py       2008-03-29 10:21:03 +0000
 
217
+++ b/share/extensions/color_lesslight.py       2010-07-24 17:56:48 +0000
 
218
@@ -1,3 +1,4 @@
 
219
+#!/usr/bin/env python
 
220
 import coloreffect, inkex
 
221
 
 
222
 class C(coloreffect.ColorEffect):
 
223
 
 
224
=== modified file 'share/extensions/color_lesssaturation.py'
 
225
--- a/share/extensions/color_lesssaturation.py  2008-03-29 10:21:03 +0000
 
226
+++ b/share/extensions/color_lesssaturation.py  2010-07-24 17:56:48 +0000
 
227
@@ -1,3 +1,4 @@
 
228
+#!/usr/bin/env python
 
229
 import coloreffect, inkex
 
230
 
 
231
 class C(coloreffect.ColorEffect):
 
232
 
 
233
=== modified file 'share/extensions/color_morehue.py'
 
234
--- a/share/extensions/color_morehue.py 2008-03-29 10:21:03 +0000
 
235
+++ b/share/extensions/color_morehue.py 2010-07-24 17:56:48 +0000
 
236
@@ -1,3 +1,4 @@
 
237
+#!/usr/bin/env python
 
238
 import coloreffect, inkex
 
239
 
 
240
 class C(coloreffect.ColorEffect):
 
241
 
 
242
=== modified file 'share/extensions/color_morelight.py'
 
243
--- a/share/extensions/color_morelight.py       2008-03-29 10:21:03 +0000
 
244
+++ b/share/extensions/color_morelight.py       2010-07-24 17:56:48 +0000
 
245
@@ -1,3 +1,4 @@
 
246
+#!/usr/bin/env python
 
247
 import coloreffect, inkex
 
248
 
 
249
 class C(coloreffect.ColorEffect):
 
250
 
 
251
=== modified file 'share/extensions/color_moresaturation.py'
 
252
--- a/share/extensions/color_moresaturation.py  2008-03-29 10:21:03 +0000
 
253
+++ b/share/extensions/color_moresaturation.py  2010-07-24 17:56:48 +0000
 
254
@@ -1,3 +1,4 @@
 
255
+#!/usr/bin/env python
 
256
 import coloreffect, inkex
 
257
 
 
258
 class C(coloreffect.ColorEffect):
 
259
 
 
260
=== modified file 'share/extensions/color_negative.py'
 
261
--- a/share/extensions/color_negative.py        2008-03-29 10:21:03 +0000
 
262
+++ b/share/extensions/color_negative.py        2010-07-24 17:56:48 +0000
 
263
@@ -1,3 +1,4 @@
 
264
+#!/usr/bin/env python
 
265
 import coloreffect
 
266
 
 
267
 class C(coloreffect.ColorEffect):
 
268
@@ -5,4 +6,4 @@
 
269
     return '%02x%02x%02x' % (255-r,255-g,255-b)
 
270
 
 
271
 c = C()
 
272
-c.affect()
 
273
\ No newline at end of file
 
274
+c.affect()
 
275
 
 
276
=== modified file 'share/extensions/color_randomize.py'
 
277
--- a/share/extensions/color_randomize.py       2008-05-23 06:31:40 +0000
 
278
+++ b/share/extensions/color_randomize.py       2010-07-24 17:56:48 +0000
 
279
@@ -1,3 +1,4 @@
 
280
+#!/usr/bin/env python
 
281
 import coloreffect,random,inkex
 
282
 
 
283
 class C(coloreffect.ColorEffect):
 
284
 
 
285
=== modified file 'share/extensions/color_removeblue.py'
 
286
--- a/share/extensions/color_removeblue.py      2008-03-29 10:21:03 +0000
 
287
+++ b/share/extensions/color_removeblue.py      2010-07-24 17:56:48 +0000
 
288
@@ -1,3 +1,4 @@
 
289
+#!/usr/bin/env python
 
290
 import coloreffect
 
291
 
 
292
 class C(coloreffect.ColorEffect):
 
293
@@ -5,4 +6,4 @@
 
294
     return '%02x%02x%02x' % (r,g,0)
 
295
 
 
296
 c = C()
 
297
-c.affect()
 
298
\ No newline at end of file
 
299
+c.affect()
 
300
 
 
301
=== modified file 'share/extensions/color_removegreen.py'
 
302
--- a/share/extensions/color_removegreen.py     2008-03-29 10:21:03 +0000
 
303
+++ b/share/extensions/color_removegreen.py     2010-07-24 17:56:48 +0000
 
304
@@ -1,3 +1,4 @@
 
305
+#!/usr/bin/env python
 
306
 import coloreffect
 
307
 
 
308
 class C(coloreffect.ColorEffect):
 
309
@@ -5,4 +6,4 @@
 
310
     return '%02x%02x%02x' % (r,0,b)
 
311
 
 
312
 c = C()
 
313
-c.affect()
 
314
\ No newline at end of file
 
315
+c.affect()
 
316
 
 
317
=== modified file 'share/extensions/color_removered.py'
 
318
--- a/share/extensions/color_removered.py       2008-03-29 10:21:03 +0000
 
319
+++ b/share/extensions/color_removered.py       2010-07-24 17:56:48 +0000
 
320
@@ -1,3 +1,4 @@
 
321
+#!/usr/bin/env python
 
322
 import coloreffect
 
323
 
 
324
 class C(coloreffect.ColorEffect):
 
325
@@ -5,4 +6,4 @@
 
326
     return '%02x%02x%02x' % (0,g,b)
 
327
 
 
328
 c = C()
 
329
-c.affect()
 
330
\ No newline at end of file
 
331
+c.affect()
 
332
 
 
333
=== modified file 'share/extensions/color_replace.py'
 
334
--- a/share/extensions/color_replace.py 2008-04-15 16:17:21 +0000
 
335
+++ b/share/extensions/color_replace.py 2010-07-24 17:56:48 +0000
 
336
@@ -1,3 +1,4 @@
 
337
+#!/usr/bin/env python
 
338
 import coloreffect
 
339
 
 
340
 import inkex
 
341
 
 
342
=== modified file 'share/extensions/color_rgbbarrel.py'
 
343
--- a/share/extensions/color_rgbbarrel.py       2008-03-29 10:21:03 +0000
 
344
+++ b/share/extensions/color_rgbbarrel.py       2010-07-24 17:56:48 +0000
 
345
@@ -1,3 +1,4 @@
 
346
+#!/usr/bin/env python
 
347
 import coloreffect
 
348
 
 
349
 class C(coloreffect.ColorEffect):
 
350
@@ -5,4 +6,4 @@
 
351
     return '%02x%02x%02x' % (b,r,g)
 
352
 
 
353
 c = C()
 
354
-c.affect()
 
355
\ No newline at end of file
 
356
+c.affect()
 
357
 
 
358
=== modified file 'share/extensions/dxf_templates.py'
 
359
--- a/share/extensions/dxf_templates.py 2008-12-29 23:08:47 +0000
 
360
+++ b/share/extensions/dxf_templates.py 2010-07-24 17:56:48 +0000
 
361
@@ -1,3 +1,4 @@
 
362
+#!/usr/bin/env python
 
363
 r14_header = '''  0
 
364
 SECTION
 
365
   2
 
366
 
 
367
=== modified file 'share/extensions/inkweb.js'
 
368
--- a/share/extensions/inkweb.js        2009-04-28 22:44:25 +0000
 
369
+++ b/share/extensions/inkweb.js        2010-07-24 17:56:48 +0000
 
370
@@ -1,3 +1,4 @@
 
371
+#!/usr/bin/env js
 
372
 /*
 
373
 **  InkWeb - Inkscape's Javscript features for the open vector web
 
374
 **
 
375
 
 
376
=== modified file 'share/extensions/jessyInk.js'
 
377
--- a/share/extensions/jessyInk.js      2010-06-04 22:18:31 +0000
 
378
+++ b/share/extensions/jessyInk.js      2010-07-24 17:56:48 +0000
 
379
@@ -1,3 +1,4 @@
 
380
+#!/usr/bin/env js
 
381
 // Copyright 2008, 2009 Hannes Hochreiner
 
382
 // This program is free software: you can redistribute it and/or modify
 
383
 // it under the terms of the GNU General Public License as published by
 
384
 
 
385
=== modified file 'share/extensions/jessyInk_core_mouseHandler_noclick.js'
 
386
--- a/share/extensions/jessyInk_core_mouseHandler_noclick.js    2010-06-04 22:18:31 +0000
 
387
+++ b/share/extensions/jessyInk_core_mouseHandler_noclick.js    2010-07-24 17:56:48 +0000
 
388
@@ -1,3 +1,4 @@
 
389
+#!/usr/bin/env js
 
390
 // Copyright 2008, 2009 Hannes Hochreiner
 
391
 // This program is free software: you can redistribute it and/or modify
 
392
 // it under the terms of the GNU General Public License as published by
 
393
 
 
394
=== modified file 'share/extensions/jessyInk_core_mouseHandler_zoomControl.js'
 
395
--- a/share/extensions/jessyInk_core_mouseHandler_zoomControl.js        2010-06-04 22:18:31 +0000
 
396
+++ b/share/extensions/jessyInk_core_mouseHandler_zoomControl.js        2010-07-24 17:56:48 +0000
 
397
@@ -1,3 +1,4 @@
 
398
+#!/usr/bin/env js
 
399
 // Copyright 2008, 2009 Hannes Hochreiner
 
400
 // This program is free software: you can redistribute it and/or modify
 
401
 // it under the terms of the GNU General Public License as published by
 
402
 
 
403
=== modified file 'share/extensions/render_alphabetsoup_config.py'
 
404
--- a/share/extensions/render_alphabetsoup_config.py    2008-05-23 06:31:40 +0000
 
405
+++ b/share/extensions/render_alphabetsoup_config.py    2010-07-24 17:56:48 +0000
 
406
@@ -1,3 +1,4 @@
 
407
+#!/usr/bin/env python
 
408
 # Syntax format: (raise your hand if you know lisp :-)
 
409
 #
 
410
 # 'state0':  ("file.svg", ( ( ('state1', dx, dy, T-B, L|R),),
 
411
 
 
412
=== modified file 'share/extensions/render_barcode.py'
 
413
--- a/share/extensions/render_barcode.py        2009-01-06 16:13:13 +0000
 
414
+++ b/share/extensions/render_barcode.py        2010-07-24 17:56:48 +0000
 
415
@@ -1,3 +1,4 @@
 
416
+#!/usr/bin/env python
 
417
 '''
 
418
 Copyright (C) 2007 Martin Owens
 
419
 
 
420
 
 
421
=== modified file 'share/extensions/run_command.py'
 
422
--- a/share/extensions/run_command.py   2010-02-04 00:32:27 +0000
 
423
+++ b/share/extensions/run_command.py   2010-07-24 17:56:48 +0000
 
424
@@ -1,3 +1,4 @@
 
425
+#!/usr/bin/env python
 
426
 import os
 
427
 import sys
 
428
 import tempfile
 
429
 
 
430
=== modified file 'share/extensions/svg_and_media_zip_output.py'
 
431
--- a/share/extensions/svg_and_media_zip_output.py      2010-03-03 13:04:57 +0000
 
432
+++ b/share/extensions/svg_and_media_zip_output.py      2010-07-24 17:56:48 +0000
 
433
@@ -1,4 +1,4 @@
 
434
-#! /usr/bin/env python
 
435
+#!/usr/bin/env python
 
436
 """
 
437
 svg_and_media_zip_output.py
 
438
 An extention which collects all images to the documents directory and
 
439
 
 
440
=== modified file 'share/extensions/svg_regex.py'
 
441
--- a/share/extensions/svg_regex.py     2009-08-04 20:15:08 +0000
 
442
+++ b/share/extensions/svg_regex.py     2010-07-24 17:56:48 +0000
 
443
@@ -1,3 +1,4 @@
 
444
+#!/usr/bin/env python
 
445
 # This software is OSI Certified Open Source Software.
 
446
 # OSI Certified is a certification mark of the Open Source Initiative.
 
447
 # 
 
448
 
 
449
=== modified file 'share/extensions/text_braille.py'
 
450
--- a/share/extensions/text_braille.py  2008-03-29 10:21:03 +0000
 
451
+++ b/share/extensions/text_braille.py  2010-07-24 17:56:48 +0000
 
452
@@ -1,3 +1,4 @@
 
453
+#!/usr/bin/env python
 
454
 #encoding: utf-8
 
455
 import chardataeffect, inkex, string
 
456
 
 
457
 
 
458
=== modified file 'share/extensions/text_flipcase.py'
 
459
--- a/share/extensions/text_flipcase.py 2008-03-29 10:21:03 +0000
 
460
+++ b/share/extensions/text_flipcase.py 2010-07-24 17:56:48 +0000
 
461
@@ -1,3 +1,4 @@
 
462
+#!/usr/bin/env python
 
463
 import chardataeffect, inkex, string
 
464
 
 
465
 class C(chardataeffect.CharDataEffect):
 
466
 
 
467
=== modified file 'share/extensions/text_lowercase.py'
 
468
--- a/share/extensions/text_lowercase.py        2008-03-29 10:21:03 +0000
 
469
+++ b/share/extensions/text_lowercase.py        2010-07-24 17:56:48 +0000
 
470
@@ -1,3 +1,4 @@
 
471
+#!/usr/bin/env python
 
472
 import chardataeffect, inkex, string
 
473
 
 
474
 class C(chardataeffect.CharDataEffect):
 
475
 
 
476
=== modified file 'share/extensions/text_randomcase.py'
 
477
--- a/share/extensions/text_randomcase.py       2008-03-29 10:21:03 +0000
 
478
+++ b/share/extensions/text_randomcase.py       2010-07-24 17:56:48 +0000
 
479
@@ -1,3 +1,4 @@
 
480
+#!/usr/bin/env python
 
481
 import chardataeffect, inkex, string
 
482
 
 
483
 import random
 
484
 
 
485
=== modified file 'share/extensions/text_replace.py'
 
486
--- a/share/extensions/text_replace.py  2008-05-23 06:15:31 +0000
 
487
+++ b/share/extensions/text_replace.py  2010-07-24 17:56:48 +0000
 
488
@@ -1,3 +1,4 @@
 
489
+#!/usr/bin/env python
 
490
 import chardataeffect, inkex, string
 
491
 
 
492
 class C(chardataeffect.CharDataEffect):
 
493
 
 
494
=== modified file 'share/extensions/text_sentencecase.py'
 
495
--- a/share/extensions/text_sentencecase.py     2008-03-29 10:21:03 +0000
 
496
+++ b/share/extensions/text_sentencecase.py     2010-07-24 17:56:48 +0000
 
497
@@ -1,3 +1,4 @@
 
498
+#!/usr/bin/env python
 
499
 import chardataeffect, inkex, string
 
500
 
 
501
 class C(chardataeffect.CharDataEffect):
 
502
 
 
503
=== modified file 'share/extensions/text_titlecase.py'
 
504
--- a/share/extensions/text_titlecase.py        2008-03-29 10:21:03 +0000
 
505
+++ b/share/extensions/text_titlecase.py        2010-07-24 17:56:48 +0000
 
506
@@ -1,3 +1,4 @@
 
507
+#!/usr/bin/env python
 
508
 import chardataeffect, inkex, string
 
509
 
 
510
 class C(chardataeffect.CharDataEffect):
 
511
 
 
512
=== modified file 'share/extensions/text_uppercase.py'
 
513
--- a/share/extensions/text_uppercase.py        2008-03-29 10:21:03 +0000
 
514
+++ b/share/extensions/text_uppercase.py        2010-07-24 17:56:48 +0000
 
515
@@ -1,3 +1,4 @@
 
516
+#!/usr/bin/env python
 
517
 import chardataeffect, inkex, string
 
518
 
 
519
 class C(chardataeffect.CharDataEffect):
 
520
 
 
521
diff --git a/share/extensions/voronoi.py b/share/extensions/voronoi.py
 
522
index be15fbe..923298d 100644
 
523
--- a/share/extensions/voronoi.py
 
524
+++ b/share/extensions/voronoi.py
 
525
@@ -1,3 +1,4 @@
 
526
+#! /usr/bin/env python
 
527
 #############################################################################
 
528
 #
 
529
 # Voronoi diagram calculator/ Delaunay triangulator
 
530