~valavanisalex/ubuntu/precise/inkscape/fix-943984

« back to all changes in this revision

Viewing changes to debian/patches/50-poppler-API.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Kees Cook
  • Date: 2009-12-23 15:38:43 UTC
  • mfrom: (1.1.11 upstream) (2.2.5 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091223153843-rjy20s7ea3jxp0q5
Tags: 0.47.0-1ubuntu1
* Merge with Debian testing (LP: #498150).  Remaining changes:
  - debian/control:
    - promote python-lxml, python-numpy, python-uniconvertor to Recommends.
    - demote pstoedit to Suggests (universe package).
    - drop libssl-dev, no longer needed (Debian bug 484527).
  - debian/rules:
    - Handle parallel builds via -j (Debian bug 562226).
    - Run intltool-update on build (Ubuntu-specific).
    - Add translation domain to .desktop files (Ubuntu-specific).
  - debian/watch:
    - Correctly handle "pre" versions (Debian bug 562225).
* 50-poppler-API.patch, debian/control: poppler 0.12.2 changed the
  GfxColorSpace API (LP: #487038).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 50-poppler-API.patch.dpatch by Kees Cook <kees@ubuntu.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: https://bugs.launchpad.net/inkscape/+bug/487038
 
6
 
 
7
@DPATCH@
 
8
diff -urNad inkscape~/src/extension/internal/pdfinput/pdf-parser.cpp inkscape/src/extension/internal/pdfinput/pdf-parser.cpp
 
9
--- inkscape~/src/extension/internal/pdfinput/pdf-parser.cpp    2009-10-10 12:17:47.000000000 -0700
 
10
+++ inkscape/src/extension/internal/pdfinput/pdf-parser.cpp     2009-12-23 22:34:13.000000000 -0800
 
11
@@ -809,7 +809,7 @@
 
12
          blendingColorSpace = NULL;
 
13
          isolated = knockout = gFalse;
 
14
          if (!obj4.dictLookup(const_cast<char*>("CS"), &obj5)->isNull()) {
 
15
-           blendingColorSpace = GfxColorSpace::parse(&obj5);
 
16
+           blendingColorSpace = GfxColorSpace::parse(&obj5, NULL);
 
17
          }
 
18
          obj5.free();
 
19
          if (obj4.dictLookup(const_cast<char*>("I"), &obj5)->isBool()) {
 
20
@@ -1009,9 +1009,9 @@
 
21
   state->setFillPattern(NULL);
 
22
   res->lookupColorSpace(args[0].getName(), &obj);
 
23
   if (obj.isNull()) {
 
24
-    colorSpace = GfxColorSpace::parse(&args[0]);
 
25
+    colorSpace = GfxColorSpace::parse(&args[0], NULL);
 
26
   } else {
 
27
-    colorSpace = GfxColorSpace::parse(&obj);
 
28
+    colorSpace = GfxColorSpace::parse(&obj, NULL);
 
29
   }
 
30
   obj.free();
 
31
   if (colorSpace) {
 
32
@@ -1032,9 +1032,9 @@
 
33
   state->setStrokePattern(NULL);
 
34
   res->lookupColorSpace(args[0].getName(), &obj);
 
35
   if (obj.isNull()) {
 
36
-    colorSpace = GfxColorSpace::parse(&args[0]);
 
37
+    colorSpace = GfxColorSpace::parse(&args[0], NULL);
 
38
   } else {
 
39
-    colorSpace = GfxColorSpace::parse(&obj);
 
40
+    colorSpace = GfxColorSpace::parse(&obj, NULL);
 
41
   }
 
42
   obj.free();
 
43
   if (colorSpace) {
 
44
@@ -1101,7 +1101,7 @@
 
45
       builder->updateStyle(state);
 
46
     }
 
47
     if (args[numArgs-1].isName() &&
 
48
-       (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
 
49
+       (pattern = res->lookupPattern(args[numArgs-1].getName(), NULL))) {
 
50
       state->setFillPattern(pattern);
 
51
       builder->updateStyle(state);
 
52
     }
 
53
@@ -1145,7 +1145,7 @@
 
54
       builder->updateStyle(state);
 
55
     }
 
56
     if (args[numArgs-1].isName() &&
 
57
-       (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
 
58
+       (pattern = res->lookupPattern(args[numArgs-1].getName(), NULL))) {
 
59
       state->setStrokePattern(pattern);
 
60
       builder->updateStyle(state);
 
61
     }
 
62
@@ -1543,7 +1543,7 @@
 
63
   double *matrix = NULL;
 
64
   GBool savedState = gFalse;
 
65
 
 
66
-  if (!(shading = res->lookupShading(args[0].getName()))) {
 
67
+  if (!(shading = res->lookupShading(args[0].getName(), NULL))) {
 
68
     return;
 
69
   }
 
70
 
 
71
@@ -2507,7 +2507,7 @@
 
72
       }
 
73
     }
 
74
     if (!obj1.isNull()) {
 
75
-      colorSpace = GfxColorSpace::parse(&obj1);
 
76
+      colorSpace = GfxColorSpace::parse(&obj1, NULL);
 
77
     } else if (csMode == streamCSDeviceGray) {
 
78
       colorSpace = new GfxDeviceGrayColorSpace();
 
79
     } else if (csMode == streamCSDeviceRGB) {
 
80
@@ -2592,7 +2592,7 @@
 
81
          obj2.free();
 
82
        }
 
83
       }
 
84
-      maskColorSpace = GfxColorSpace::parse(&obj1);
 
85
+      maskColorSpace = GfxColorSpace::parse(&obj1, NULL);
 
86
       obj1.free();
 
87
       if (!maskColorSpace || maskColorSpace->getMode() != csDeviceGray) {
 
88
        goto err1;
 
89
@@ -2767,7 +2767,7 @@
 
90
     if (obj1.dictLookup(const_cast<char*>("S"), &obj2)->isName(const_cast<char*>("Transparency"))) {
 
91
       transpGroup = gTrue;
 
92
       if (!obj1.dictLookup(const_cast<char*>("CS"), &obj3)->isNull()) {
 
93
-       blendingColorSpace = GfxColorSpace::parse(&obj3);
 
94
+       blendingColorSpace = GfxColorSpace::parse(&obj3, NULL);
 
95
       }
 
96
       obj3.free();
 
97
       if (obj1.dictLookup(const_cast<char*>("I"), &obj3)->isBool()) {