~valavanisalex/ubuntu/saucy/inkscape/fix-lp1225013

« back to all changes in this revision

Viewing changes to debian/patches/0004-Fix_FTBFS_on_gcc-4.8.patch

  • Committer: Alex Valavanis
  • Date: 2013-09-13 17:14:17 UTC
  • mfrom: (2.5.9 sid)
  • Revision ID: valavanisalex@gmail.com-20130913171417-24ra2uyef45ca3ag
* Merge from Debian Testing (LP: #1225013)
  - debian/control: 
    + Ubuntu maintainers
    + Build against lcms2
    + Promote python-uniconvertor to Recommends.
    + Demote pstoedit to Suggests (universe package).
  - Handle translation tasks for Ubuntu main:
    + debian/control: Build-Depends dh-translations
  - debian/patches/01_add_unity_quicklist_support.patch: add "New Drawing" 
    to Unity quicklist
* debian/control: fields update
  - Duplicate Homepage field removed
  - VCS-* fields repositioned
* debian/watch: path updated
* debian/: dh bump 7 => 9
* debian/source/format: 3.0 (quilt) file added
* debian/patches/: patchset re-worked using gbp-pq
  - patches re-worked using gbp-pq (authorships kept)
  - debian/control: quilt b-dep dropped
  - debian/rules: quilt usage dropped
* debian/gbp.conf: file added
* debian/control: autotools-dev b-dep added
* debian/rules: drastic simplification
* debian/control: S-V bump 3.8.3 => 3.9.4 (no changes needed)
* debian/control: python-lxml Suggests => Recommends (Closes: #389540)
* debian/control: python-numpy Suggests => Recommends (Closes: #440566)
* debian/control: libgnomevfs2-extra Suggests => Recommends
  (Closes: #602599)
* debian/control: skencil Suggests dropped.
  The package has been removed from unstable
  on 2010-09-03 and from testing on 2010-09-04. (Closes: #712192)
* debian/control: transfig added to Recommends (Closes: #601770)
* debian/control: python dropped from Suggests (Closes: #628009)
* debian/control: Package description updated.
  Thanks to Phil Bull <philbull@gmail.com> for the new description.
  (Closes: #635244) (LP: #811634)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: "Matteo F. Vescovi" <mfv.debian@gmail.com>
 
2
Date: Fri, 21 Jun 2013 15:05:53 +0200
 
3
Subject: Fix_FTBFS_on_gcc-4.8
 
4
 
 
5
---
 
6
 src/connector-context.cpp    | 22 +++++++++++-----------
 
7
 src/extension/effect.cpp     |  2 +-
 
8
 src/gradient-drag.cpp        |  2 +-
 
9
 src/libavoid/vpsc.cpp        |  2 +-
 
10
 src/libcola/straightener.cpp |  6 +++---
 
11
 src/libcroco/cr-parser.c     |  2 +-
 
12
 src/libvpsc/block.cpp        |  2 +-
 
13
 src/widgets/desktop-widget.h |  2 +-
 
14
 src/widgets/toolbox.cpp      |  4 ++--
 
15
 9 files changed, 22 insertions(+), 22 deletions(-)
 
16
 
 
17
diff --git a/src/connector-context.cpp b/src/connector-context.cpp
 
18
index f7d18a3..f0dea9a 100644
 
19
--- a/src/connector-context.cpp
 
20
+++ b/src/connector-context.cpp
 
21
@@ -1287,15 +1287,15 @@ cc_connector_rerouting_finish(SPConnectorContext *const cc, Geom::Point *const p
 
22
         if (found) {
 
23
             if (cc->clickedhandle == cc->endpt_handle[0]) {
 
24
                 sp_object_setAttribute(cc->clickeditem,
 
25
-                        "inkscape:connection-start", shape_label, false);
 
26
+                        "inkscape:connection-start", shape_label, NULL);
 
27
                 sp_object_setAttribute(cc->clickeditem,
 
28
-                        "inkscape:connection-start-point", cpid, false);
 
29
+                        "inkscape:connection-start-point", cpid, NULL);
 
30
             }
 
31
             else {
 
32
                 sp_object_setAttribute(cc->clickeditem,
 
33
-                        "inkscape:connection-end", shape_label, false);
 
34
+                        "inkscape:connection-end", shape_label, NULL);
 
35
                 sp_object_setAttribute(cc->clickeditem,
 
36
-                        "inkscape:connection-end-point", cpid, false);
 
37
+                        "inkscape:connection-end-point", cpid, NULL);
 
38
             }
 
39
             g_free(shape_label);
 
40
         }
 
41
@@ -1435,26 +1435,26 @@ spcc_flush_white(SPConnectorContext *cc, SPCurve *gc)
 
42
 
 
43
         bool connection = false;
 
44
         sp_object_setAttribute(cc->newconn, "inkscape:connector-type",
 
45
-                cc->isOrthogonal ? "orthogonal" : "polyline", false);
 
46
+                cc->isOrthogonal ? "orthogonal" : "polyline", NULL);
 
47
         sp_object_setAttribute(cc->newconn, "inkscape:connector-curvature",
 
48
-                Glib::Ascii::dtostr(cc->curvature).c_str(), false);
 
49
+                Glib::Ascii::dtostr(cc->curvature).c_str(), NULL);
 
50
         if (cc->shref)
 
51
         {
 
52
             sp_object_setAttribute(cc->newconn, "inkscape:connection-start",
 
53
-                    cc->shref, false);
 
54
+                    cc->shref, NULL);
 
55
             if (cc->scpid)
 
56
                 sp_object_setAttribute(cc->newconn, "inkscape:connection-start-point",
 
57
-                        cc->scpid, false);
 
58
+                        cc->scpid, NULL);
 
59
             connection = true;
 
60
         }
 
61
 
 
62
         if (cc->ehref)
 
63
         {
 
64
             sp_object_setAttribute(cc->newconn, "inkscape:connection-end",
 
65
-                    cc->ehref, false);
 
66
+                    cc->ehref, NULL);
 
67
             if (cc->ecpid)
 
68
                 sp_object_setAttribute(cc->newconn, "inkscape:connection-end-point",
 
69
-                        cc->ecpid, false);
 
70
+                        cc->ecpid, NULL);
 
71
             connection = true;
 
72
         }
 
73
         // Process pending updates.
 
74
@@ -1937,7 +1937,7 @@ void cc_selection_set_avoid(bool const set_avoid)
 
75
 
 
76
         if (cc_item_is_shape(item)) {
 
77
             sp_object_setAttribute(item, "inkscape:connector-avoid",
 
78
-                    value, false);
 
79
+                    value, NULL);
 
80
             item->avoidRef->handleSettingChange();
 
81
             changes++;
 
82
         }
 
83
diff --git a/src/extension/effect.cpp b/src/extension/effect.cpp
 
84
index 9a22c07..192c72e 100644
 
85
--- a/src/extension/effect.cpp
 
86
+++ b/src/extension/effect.cpp
 
87
@@ -323,7 +323,7 @@ Effect::set_last_effect (Effect * in_effect)
 
88
 Inkscape::XML::Node *
 
89
 Effect::find_menu (Inkscape::XML::Node * menustruct, const gchar *name)
 
90
 {
 
91
-    if (menustruct == NULL) return false;
 
92
+    if (menustruct == NULL) return NULL;
 
93
     for (Inkscape::XML::Node * child = menustruct;
 
94
             child != NULL;
 
95
             child = child->next()) {
 
96
diff --git a/src/gradient-drag.cpp b/src/gradient-drag.cpp
 
97
index 0459cd1..d620817 100644
 
98
--- a/src/gradient-drag.cpp
 
99
+++ b/src/gradient-drag.cpp
 
100
@@ -1969,7 +1969,7 @@ GrDrag::deleteSelected (bool just_one)
 
101
 {
 
102
     if (!selected) return;
 
103
 
 
104
-    SPDocument *document = false;
 
105
+    SPDocument *document = NULL;
 
106
 
 
107
     struct StructStopInfo {
 
108
         SPStop * spstop;
 
109
diff --git a/src/libavoid/vpsc.cpp b/src/libavoid/vpsc.cpp
 
110
index 19d3603..1646dda 100644
 
111
--- a/src/libavoid/vpsc.cpp
 
112
+++ b/src/libavoid/vpsc.cpp
 
113
@@ -422,7 +422,7 @@ Constraint* IncSolver::mostViolated(Constraints &l) {
 
114
     // downwards.  There is always at least 1 element in the
 
115
     // vector because of search.
 
116
     // TODO check this logic and add parens:
 
117
-    if((deletePoint != end) && ((minSlack < ZERO_UPPERBOUND) && !v->active || v->equality)) {
 
118
+    if((deletePoint != end) && (((minSlack < ZERO_UPPERBOUND) && !v->active) || v->equality)) {
 
119
         *deletePoint = l[l.size()-1];
 
120
         l.resize(l.size()-1);
 
121
     }
 
122
diff --git a/src/libcola/straightener.cpp b/src/libcola/straightener.cpp
 
123
index e237c03..7c73cb9 100644
 
124
--- a/src/libcola/straightener.cpp
 
125
+++ b/src/libcola/straightener.cpp
 
126
@@ -108,7 +108,7 @@ namespace straightener {
 
127
     int compare_events(const void *a, const void *b) {
 
128
         Event *ea=*(Event**)a;
 
129
         Event *eb=*(Event**)b;
 
130
-        if(ea->v!=NULL&&ea->v==eb->v||ea->e!=NULL&&ea->e==eb->e) {
 
131
+        if((ea->v!=NULL&&ea->v==eb->v)||(ea->e!=NULL&&ea->e==eb->e)) {
 
132
             // when comparing opening and closing from object
 
133
             // open must come first
 
134
             if(ea->type==Open) return -1;
 
135
@@ -263,8 +263,8 @@ namespace straightener {
 
136
                         // node is on an edge
 
137
                         Edge *edge=(*i)->edge;
 
138
                         if(!edge->isEnd(v->id)
 
139
-                                &&(l!=NULL&&!edge->isEnd(l->id)||l==NULL)
 
140
-                                &&(r!=NULL&&!edge->isEnd(r->id)||r==NULL)) {
 
141
+                                &&((l!=NULL&&!edge->isEnd(l->id))||l==NULL)
 
142
+                                &&((r!=NULL&&!edge->isEnd(r->id))||r==NULL)) {
 
143
                             if(lastNode!=NULL) {
 
144
                                 //printf("  Rule A: Constraint: v%d +g <= v%d\n",lastNode->id,(*i)->id);
 
145
                                 cs.push_back(createConstraint(lastNode,*i,dim));
 
146
diff --git a/src/libcroco/cr-parser.c b/src/libcroco/cr-parser.c
 
147
index 5b0a56f..a8e2de5 100644
 
148
--- a/src/libcroco/cr-parser.c
 
149
+++ b/src/libcroco/cr-parser.c
 
150
@@ -2408,7 +2408,7 @@ cr_parser_parse_stylesheet (CRParser * a_this)
 
151
                                                  import_string,
 
152
                                                  NULL, &location) ;
 
153
 
 
154
-                                        if ((PRIVATE (a_this)->sac_handler->resolve_import == TRUE)) {
 
155
+                                        if (PRIVATE (a_this)->sac_handler->resolve_import == TRUE) {
 
156
                                                 /*
 
157
                                                  *TODO: resolve the
 
158
                                                  *import rule.
 
159
diff --git a/src/libvpsc/block.cpp b/src/libvpsc/block.cpp
 
160
index 221df53..0bd662f 100644
 
161
--- a/src/libvpsc/block.cpp
 
162
+++ b/src/libvpsc/block.cpp
 
163
@@ -72,7 +72,7 @@ void Block::setUpConstraintHeap(PairingHeap<Constraint*>* &h,bool in) {
 
164
                for (Cit j=cs->begin();j!=cs->end();++j) {
 
165
                        Constraint *c=*j;
 
166
                        c->timeStamp=blockTimeCtr;
 
167
-                       if (c->left->block != this && in || c->right->block != this && !in) {
 
168
+                       if ((c->left->block != this && in) || (c->right->block != this && !in)) {
 
169
                                h->insert(c);
 
170
                        }
 
171
                }
 
172
diff --git a/src/widgets/desktop-widget.h b/src/widgets/desktop-widget.h
 
173
index d853e09..aab73c9 100644
 
174
--- a/src/widgets/desktop-widget.h
 
175
+++ b/src/widgets/desktop-widget.h
 
176
@@ -239,7 +239,7 @@ struct SPDesktopWidget {
 
177
 private:
 
178
     GtkWidget *tool_toolbox;
 
179
     GtkWidget *aux_toolbox;
 
180
-    GtkWidget *commands_toolbox,;
 
181
+    GtkWidget *commands_toolbox;
 
182
     GtkWidget *snap_toolbox;
 
183
 
 
184
     static void init(SPDesktopWidget *widget);
 
185
diff --git a/src/widgets/toolbox.cpp b/src/widgets/toolbox.cpp
 
186
index dfa5e08..8c1600d 100644
 
187
--- a/src/widgets/toolbox.cpp
 
188
+++ b/src/widgets/toolbox.cpp
 
189
@@ -7932,7 +7932,7 @@ static void sp_connector_orthogonal_toggled( GtkToggleAction* act, GObject *tbl
 
190
 
 
191
         if (cc_item_is_connector(item)) {
 
192
             sp_object_setAttribute(item, "inkscape:connector-type",
 
193
-                    value, false);
 
194
+                    value, NULL);
 
195
             item->avoidRef->handleSettingChange();
 
196
             modmade = true;
 
197
         }
 
198
@@ -7981,7 +7981,7 @@ static void connector_curvature_changed(GtkAdjustment *adj, GObject* tbl)
 
199
 
 
200
         if (cc_item_is_connector(item)) {
 
201
             sp_object_setAttribute(item, "inkscape:connector-curvature",
 
202
-                    value, false);
 
203
+                    value, NULL);
 
204
             item->avoidRef->handleSettingChange();
 
205
             modmade = true;
 
206
         }