~vanvugt/ubuntu/natty/bcmwl/fix-793890

« back to all changes in this revision

Viewing changes to debian/patches/0002-Makefile.patch

  • Committer: Bazaar Package Importer
  • Author(s): Alberto Milone
  • Date: 2010-02-14 19:58:58 UTC
  • mfrom: (2.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20100214195858-yw9z3vstz9kyw5jl
Tags: 5.60.48.36+bdcom-0ubuntu1
* New upstream release (LP: #432780):
  - Support up to linux kernel 2.6.31. 2.6.32 support is there
    also but not tested (although reports from users suggests it
    works fine).
  - Support for hidden networks.
  - Support for rfkill in kernels < 2.6.31.
  - Setting power level via 'iwconfig eth1 txpower X' is now
    operational
  - Add support for 4313.
  - Additional channels in both 2.4 and 5 Ghz bands.
  - Fix issue with tkip group keys that caused the following
    message to repeat often:
    TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff8800cf80e840
  - Fix a continuous assoc/disassoc loop (in Ubuntu 8.04)
    with suspend/resume with WPA2 and wpa_supplicant.
  - Fix bug affecting Ubuntu 8.04 which prevented from pinging when
    Linux STA is IBSS creator with WEP.
  - Fix bug affecting Ubuntu 9.04 which prevented from connecting to
    hidden networks after suspend/resume.
  - Fix bug which prevented the driver from associating to AP with
    when transitioning from AES to TKIP encryption.
* debian/patches/0002-Makefile.patch:
  - Refresh patch.
* debian/patches/0003-DEV_WL_IF.patch,
  0004-broadcom-sta-5.10.91.9-linux-2.6.30.patch,
  0005-NET_DEVICE_OPS.patch,
  0006-broadcom-sta-5.10.91.9-linux-2.6.32.patch:
  - Drop patches as they are now part of the upstream code.
* debian/dkms.conf.in:
  - Remove the lines about the above mentioned patches.
* debian/bcmwl-kernel-source.postinst:
  - Make use of /usr/lib/dkms/common.postinst (LP: #497149).
* Bump compat to 5.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
index 2ef91b1..6d821a0 100644
2
 
--- src/Makefile.orig
3
 
+++ src/Makefile
4
 
@@ -26,6 +26,12 @@
 
1
diff -Nur src.orig/Makefile src/Makefile
 
2
--- src.orig/Makefile   2010-02-06 02:59:15.000000000 +0100
 
3
+++ src/Makefile        2010-02-14 16:16:10.819815931 +0100
 
4
@@ -13,6 +13,12 @@
5
5
 #
6
 
 # $Id: Makefile_kbuild_portsrc,v 1.1.2.4 2008/05/02 18:33:39 Exp $
 
6
 # $Id: Makefile_kbuild_portsrc,v 1.5.4.1 2009/08/13 21:37:18 Exp $
7
7
 
8
8
+ifeq ($(shell dpkg --print-architecture),amd64)
9
9
+BINARCH = x86_64
14
14
 obj-m              += wl.o
15
15
 
16
16
 wl-objs            := 
17
 
@@ -37,4 +43,4 @@ EXTRA_CFLAGS       :=
 
17
@@ -24,7 +30,7 @@
18
18
 EXTRA_CFLAGS       += -I$(src)/src/include
19
 
 EXTRA_CFLAGS       += -I$(src)/src/wl/sys
 
19
 EXTRA_CFLAGS       += -I$(src)/src/wl/sys -I$(src)/src/wl/phy
20
20
 
21
21
-EXTRA_LDFLAGS      := $(src)/lib/wlc_hybrid.o_shipped
22
22
+EXTRA_LDFLAGS      := $(src)/lib/wlc_hybrid.o_shipped_$(BINARCH)
 
23
 
 
24
 all:
 
25
        KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`