~vorlon/ubuntu/oneiric/cyrus-sasl2/multiarch

« back to all changes in this revision

Viewing changes to debian/patches/0022_gcc4.4_preprocessor_syntax.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2009-06-04 16:03:06 UTC
  • mfrom: (2.1.4 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090604160306-wioioa3amb1up5ws
Tags: 2.1.23.dfsg1-1ubuntu1
* Merge from Debian unstable, remaining changes:
  - Add sysv-rc dependency
  - Since the libsasl2 package description so clearly
    states that the library is "completely useless" without one of the
    libsasl2-modules packages, upgrade the Recommends on a single package
    to an ORd Depends on the complete list of them.
  - Prepend XS-Original- to Vcs-{Browser,Svn}.
  - Remove stop links from rc0 and rc6
  - stop service only when switching to single user mode.
* Dropped changes, superseded in Debian:
  - build-depend on libdb4.6-dev; Debian has moved on to db4.7
  - Added debian/patches/021ubuntu-fix-threaded-sasl.dpatch
    - Fixes SEGV in threaded SASL applications.
* debian/rules: remove all the build-*stamp files on clean, not just
  build-stamp.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 0022_gcc4.4_preprocessor_syntax.dpatch by  <fabbe@paniq.net>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: The #elif preprocessor directive requires a test condition.
 
6
## DP: GCC 4.4 enforces this rule.
 
7
 
 
8
@DPATCH@
 
9
diff -urNad trunk~/plugins/digestmd5.c trunk/plugins/digestmd5.c
 
10
--- trunk~/plugins/digestmd5.c  2006-06-04 12:26:19.000000000 +0300
 
11
+++ trunk/plugins/digestmd5.c   2009-01-26 13:29:40.000000000 +0200
 
12
@@ -2715,7 +2715,7 @@
 
13
        "DIGEST-MD5",                   /* mech_name */
 
14
 #ifdef WITH_RC4
 
15
        128,                            /* max_ssf */
 
16
-#elif WITH_DES
 
17
+#elif defined(WITH_DES)
 
18
        112,
 
19
 #else 
 
20
        1,
 
21
@@ -4034,7 +4034,7 @@
 
22
        "DIGEST-MD5",
 
23
 #ifdef WITH_RC4                                /* mech_name */
 
24
        128,                            /* max ssf */
 
25
-#elif WITH_DES
 
26
+#elif defined(WITH_DES)
 
27
        112,
 
28
 #else
 
29
        1,