~xnox/ubuntu/quantal/mdadm/merge

« back to all changes in this revision

Viewing changes to debian/patches/debian/disable-incremental.diff

  • Committer: Dmitrijs Ledkovs
  • Author(s): Clint Byrum
  • Date: 2011-12-16 11:06:12 UTC
  • mfrom: (1.1.26 sid)
  • Revision ID: dmitrijs.ledkovs@canonical.com-20111216110612-f91bfvyfvxc1t0rq
Tags: 3.2.2-1ubuntu1
* Merge from debian unstable.  Remaining changes:
  - Call checks in local-premount to avoid race condition with udev
    and opening a degraded array.
  - d/initramfs/mdadm-functions: Record in /run when boot-degraded 
    question has been asked so that it is only asked once
  - pass --test to mdadm to enable result codes for degraded arrays. 
  - Build udeb with -O2 on ppc64, working around a link error.
  - debian/control: we need udev and util-linux in the right version. We
    also remove the build dependency from quilt and docbook-to-man as both
    are not used in Ubuntus mdadm.
  - debian/initramfs/hook: kept the Ubuntus version for handling the absence
    of active raid arrays in <initramfs>/etc/mdadm/mdadm.conf
  - debian/initramfs/script.local-top.DEBIAN, debian/mdadm-startall,
    debian/mdadm.raid.DEBIAN: removed. udev does its job now instead.
  - debian/mdadm-startall.sgml, debian/mdadm-startall.8: documentation of
    unused startall script
  - debian/mdadm.config, debian/mdadm.postinst - let udev do the handling
    instead. Resolved merge conflict by keeping Ubuntu's version.
  - debian/mdadm.postinst, debian/mdadm.config, initramfs/init-premount:
    boot-degraded enablement; maintain udev starting of RAID devices;
    init-premount hook script for the initramfs, to provide information at
    boot
  - debian/mkconf.in is the older mkconf. Kept the Ubuntu version.
  - debian/rules: Kept Ubuntus version for installing apport hooks, not
    installing un-used startall script and for adding a udev rule
    corresponding to mdadm.
  - debian/install-rc, check.d/_numbers, check.d/root_on_raid: Ubuntu partman
    installer changes
  - debian/presubj: Dropped this unused bug reporting file. Instead use
    source_mdadm.py act as an apport hook for bug handling.
  - rename debian/mdadm.vol_id.udev to debian/mdadm.mdadm-blkid.udev so that
    the rules file ends up with a more reasonable name
  - d/p/debian-changes-3.1.4-1+8efb9d1ubuntu4: mdadm udev rule
    incrementally adds mdadm member when detected. Starting such an
    array in degraded mode is possible by mdadm -IRs. Using mdadm
    -ARs without stopping the array first does nothing when no
    mdarray-unassociated device is available. Using mdadm -IRs to
    start a previously partially assembled array through incremental
    mode. Keeping the mdadm -ARs for assembling arrays which were for
    some reason not assembled through incremental mode (i.e through
    mdadm's udev rule).
* Disabling -fno-strict-aliasing as according to debian bug 375876 it
  has been unnecessary since mdadm 2.5.2
* Dropped changes:
  - applied upstream
  - d/rules: fix FTBFS by adding -Wno-unused-but-set-variable to
    compiler flags until upstream solves the issue. (fixed upstream)
  - d/control: add dependency on initscripts >= 2.88dsf-13.3 to ensure
    /run exists per http://wiki.debian.org/ReleaseGoals/RunDirectory
    (change also done in debian)
* d/rules: add 'man' to build mdadm.8

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: martin f. krafft <madduck@debian.org>
2
 
Subject: Disable udev incremental assembly
3
 
 
4
 
Upstream enabled incremental assembly in the udev rules by default for 3.1.3,
5
 
but this is too early given the pending release of squeeze. Hence, this patch
6
 
simply reverts the change.
7
 
 
8
 
Signed-off-by: martin f. krafft <madduck@debian.org>
9
 
 
10
 
---
11
 
 udev-md-raid.rules |   13 ++++++-------
12
 
 1 files changed, 6 insertions(+), 7 deletions(-)
13
 
 
14
 
diff --git a/udev-md-raid.rules b/udev-md-raid.rules
15
 
index f9607f3..c9a4f0e 100644
16
 
--- a/udev-md-raid.rules
17
 
+++ b/udev-md-raid.rules
18
 
@@ -1,13 +1,13 @@
19
 
 # do not edit this file, it will be overwritten on update
20
 
 
21
 
 SUBSYSTEM!="block", GOTO="md_end"
22
 
-
23
 
-# handle potential components of arrays
24
 
-ENV{ID_FS_TYPE}=="linux_raid_member", ACTION=="remove", RUN+="/sbin/mdadm -If $name"
25
 
-ENV{ID_FS_TYPE}=="linux_raid_member", ACTION=="add", RUN+="/sbin/mdadm --incremental $env{DEVNAME}"
26
 
-
27
 
-# handle md arrays
28
 
 ACTION!="add|change", GOTO="md_end"
29
 
+ACTION=="change", GOTO="md_no_incr"
30
 
+
31
 
+# import data from a raid member and activate it
32
 
+#ENV{ID_FS_TYPE}=="linux_raid_member", IMPORT{program}="/sbin/mdadm --examine --export $tempnode", RUN+="/sbin/mdadm --incremental $env{DEVNAME}"
33
 
+# import data from a raid set
34
 
+LABEL="md_no_incr"
35
 
 KERNEL!="md*", GOTO="md_end"
36
 
 
37
 
 # partitions have no md/{array_state,metadata_version}, but should not
38
 
@@ -32,7 +32,6 @@ ENV{DEVTYPE}=="partition", ENV{MD_DEVNAME}=="*[0-9]", SYMLINK+="md/$env{MD_DEVNA
39
 
 
40
 
 IMPORT{program}="/sbin/blkid -o udev -p $tempnode"
41
 
 OPTIONS+="link_priority=100"
42
 
-OPTIONS+="watch"
43
 
 ENV{ID_FS_USAGE}=="filesystem|other|crypto", ENV{ID_FS_UUID_ENC}=="?*", SYMLINK+="disk/by-uuid/$env{ID_FS_UUID_ENC}"
44
 
 ENV{ID_FS_USAGE}=="filesystem|other", ENV{ID_FS_LABEL_ENC}=="?*", SYMLINK+="disk/by-label/$env{ID_FS_LABEL_ENC}"
45
 
 
46
 
tg: (deb573e..) debian/disable-incremental (depends on: master)