~yolanda.robla/ubuntu/trusty/memcached/add_distribution

« back to all changes in this revision

Viewing changes to debian/patches/fix-ubuntu-ftbfs.patch

  • Committer: Bazaar Package Importer
  • Author(s): David Martínez Moreno
  • Date: 2010-05-12 11:41:22 UTC
  • mfrom: (1.1.7 upstream) (3.3.3 squeeze)
  • Revision ID: james.westby@ubuntu.com-20100512114122-e2dphwiezevuny1t
Tags: 1.4.5-1
* New upstream release.  Main changes since 1.4.2 are:
  New features:
  - Support for SASL authentication.
  - New script damemtop - a memcached top.
  - Slab optimizations.
  - New stats, for reclaimed memory and SASL events.
  Bugs fixed:
  - Malicious input can crash server (CVE-2010-1152).  Closes: #579913.
  - Fixed several problems with slab handling and growth.
  - Provide better error reporting.
  - Fix get stats accounting.
  - Fixed backwards compatibility with delete 0.
  - Documentation fixes.
  - Various build fixes, among others, fixed FTBFS with gcc-4.5 (closes:
    #565033).
* Refreshed and renamed 01_init_script_compliant_with_LSB.patch.
* Fixed lintian warnings by adding $remote_fs to init.d script.
* Removed non-existent document (doc/memory_management.txt).
* debian/control: Bumped Standards-Version to 3.8.4 (no changes).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: memcached-1.4.2/memcached.c
2
 
===================================================================
3
 
--- memcached-1.4.2.orig/memcached.c    2010-04-17 03:27:20.155037988 +0100
4
 
+++ memcached-1.4.2/memcached.c 2010-04-17 03:28:00.506769722 +0100
5
 
@@ -2922,7 +2922,7 @@
6
 
                 }
7
 
 
8
 
                 if (ptr - c->rcurr > 100 ||
9
 
-                       strcmp(ptr, "get ") && strcmp(ptr, "gets ")) {
10
 
+                       (strcmp(ptr, "get ") && strcmp(ptr, "gets "))) {
11
 
                     conn_set_state(c, conn_closing);
12
 
                     return 1;
13
 
                 }