~zeitgeist/activity-log-manager/fix-bug-1058037

« back to all changes in this revision

Viewing changes to debian/patches/fix-i18n.patch

  • Committer: Package Import Robot
  • Author(s): Didier Roche
  • Date: 2012-03-05 17:30:46 UTC
  • mfrom: (1.1.4)
  • Revision ID: package-import@ubuntu.com-20120305173046-0kf6bzadvw116i5k
Tags: 0.9.3-0ubuntu1
* New upstream release
  - Application blacklist does not block application launches (LP: #930093)
  - Application selection TreeView should show last used and usage
    (LP: #925638)
  - Typo in /src/history-widget.vala:68 (LP: #944993)
  - The Application selection list shows usage of applications
  - Some whoopsie related files have been added to i18n system
* debian/patches/fix-i18n.patch:
  - removed, usptreamed

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
## Description: fix i18n problems in activity-log-manager
2
 
## Origin/Author: Gabor Kelemen <kelemeng@gnome.hu>
3
 
## Bug: https://bugs.launchpad.net/activity-log-manager/+bug/944362
4
 
Index: activity-log-manager/po/POTFILES.in
5
 
===================================================================
6
 
--- activity-log-manager.orig/po/POTFILES.in    2012-03-02 09:52:22.900456011 +0100
7
 
+++ activity-log-manager/po/POTFILES.in 2012-03-02 10:02:17.704464937 +0100
8
 
@@ -6,4 +6,5 @@
9
 
 src/applications-widget.vala
10
 
 src/files-widget.vala
11
 
 src/history-widget.vala
12
 
-src/diagnostics/whoopsie.ui
13
 
+src/diagnostics/com.ubuntu.whoopsiepreferences.policy.in
14
 
+[type: gettext/glade]src/diagnostics/whoopsie.ui
15
 
Index: activity-log-manager/src/diagnostics/com.ubuntu.whoopsiepreferences.policy
16
 
===================================================================
17
 
--- activity-log-manager.orig/src/diagnostics/com.ubuntu.whoopsiepreferences.policy     2012-03-02 09:52:22.876456011 +0100
18
 
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
19
 
@@ -1,18 +0,0 @@
20
 
-<?xml version="1.0" encoding="UTF-8"?>
21
 
-<!DOCTYPE policyconfig PUBLIC
22
 
- "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
23
 
- "http://www.freedesktop.org/standards/PolicyKit/1.0/policyconfig.dtd">
24
 
-<policyconfig>
25
 
-  <vendor>Ubuntu crash reporting</vendor>
26
 
-  <vendor_url>https://launchpad.net/whoopsie-daisy</vendor_url>
27
 
-  <icon_name>stock_lock</icon_name>
28
 
-  <action id="com.ubuntu.whoopsiepreferences.change">
29
 
-    <description gettext-domain="whoopsie">Privacy settings</description>
30
 
-    <message gettext-domain="whoopsie">To change your privacy settings you need to authenticate.</message>
31
 
-    <defaults>
32
 
-      <allow_any>auth_admin</allow_any>
33
 
-      <allow_inactive>auth_admin</allow_inactive>
34
 
-      <allow_active>auth_admin_keep</allow_active>
35
 
-    </defaults>
36
 
- </action>
37
 
-</policyconfig>
38
 
Index: activity-log-manager/src/diagnostics/Makefile.am
39
 
===================================================================
40
 
--- activity-log-manager.orig/src/diagnostics/Makefile.am       2012-03-02 09:52:22.852456011 +0100
41
 
+++ activity-log-manager/src/diagnostics/Makefile.am    2012-03-02 10:02:17.708464937 +0100
42
 
@@ -20,17 +20,20 @@
43
 
        $(POLKIT_LIBS) \
44
 
        $(GIO_UNIX_LIBS)
45
 
 
46
 
+policykit_in_files = \ 
47
 
+       com.ubuntu.whoopsiepreferences.policy.in
48
 
+
49
 
 EXTRA_DIST = \
50
 
        whoopsie-preferences.xml \
51
 
        com.ubuntu.WhoopsiePreferences.service \
52
 
        com.ubuntu.WhoopsiePreferences.conf \
53
 
-       com.ubuntu.whoopsiepreferences.policy \
54
 
+       $(policykit_in_files) \
55
 
        whoopsie.ui
56
 
 
57
 
 gnomeccui_DATA = \
58
 
        whoopsie.ui
59
 
 policykit_DATA = \
60
 
-       com.ubuntu.whoopsiepreferences.policy
61
 
+       $(policykit_in_files:.policy.in=.policy)
62
 
 dbussystem_DATA = \
63
 
        com.ubuntu.WhoopsiePreferences.conf
64
 
 dbusservice_DATA = \
65
 
@@ -41,4 +44,6 @@
66
 
                --generate-c-code whoopsie-generated \
67
 
                $<
68
 
 
69
 
-CLEANFILES = whoopsie-generated.[ch]
70
 
+CLEANFILES = whoopsie-generated.[ch] \
71
 
+       $(policykit_DATA)
72
 
+@INTLTOOL_POLICY_RULE@
73
 
Index: activity-log-manager/src/diagnostics/com.ubuntu.whoopsiepreferences.policy.in
74
 
===================================================================
75
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
76
 
+++ activity-log-manager/src/diagnostics/com.ubuntu.whoopsiepreferences.policy.in       2012-03-02 10:03:20.480465876 +0100
77
 
@@ -0,0 +1,18 @@
78
 
+<?xml version="1.0" encoding="UTF-8"?>
79
 
+<!DOCTYPE policyconfig PUBLIC
80
 
+ "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
81
 
+ "http://www.freedesktop.org/standards/PolicyKit/1.0/policyconfig.dtd">
82
 
+<policyconfig>
83
 
+  <vendor>Ubuntu crash reporting</vendor>
84
 
+  <vendor_url>https://launchpad.net/whoopsie-daisy</vendor_url>
85
 
+  <icon_name>stock_lock</icon_name>
86
 
+  <action id="com.ubuntu.whoopsiepreferences.change">
87
 
+    <_description>Privacy settings</_description>
88
 
+    <_message>To change your privacy settings you need to authenticate.</_message>
89
 
+    <defaults>
90
 
+      <allow_any>auth_admin</allow_any>
91
 
+      <allow_inactive>auth_admin</allow_inactive>
92
 
+      <allow_active>auth_admin_keep</allow_active>
93
 
+    </defaults>
94
 
+ </action>
95
 
+</policyconfig>