~ubuntu-branches/ubuntu/oneiric/gnome-panel/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/31_fix_crash_second_screen.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2009-07-10 14:24:56 UTC
  • mfrom: (1.2.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20090710142456-i431i68lcp91i69e
Tags: 1:2.26.3-0ubuntu1
* New upstream version
* debian/control.in:
  - typo fix
* debian/patches/18_lockdown_lock_editor.patch:
  - change to have lockdown locking the menu editor (lp: #4712, #385596)
* debian/patches/31_fix_crash_second_screen.patch:
  - the change is in the new version

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
This patch fixes a crash when clicking on a launcher located on a second
2
 
screen. Patch by Gerd Kohlberger.
3
 
 
4
 
Ubuntu: https://bugs.edge.launchpad.net/bugs/256041
5
 
Upstream: http://bugzilla.gnome.org/show_bug.cgi?id=551879
6
 
Patch: http://bugzilla.gnome.org/attachment.cgi?id=119520&action=view
7
 
 
8
 
Index: gnome-panel-2.26.2/gnome-panel/xstuff.c
9
 
===================================================================
10
 
--- gnome-panel-2.26.2.orig/gnome-panel/xstuff.c        2009-06-30 12:12:45.882704594 +0200
11
 
+++ gnome-panel-2.26.2/gnome-panel/xstuff.c     2009-06-30 12:13:28.882704116 +0200
12
 
@@ -410,6 +410,7 @@
13
 
 
14
 
        win = gtk_window_new (GTK_WINDOW_POPUP);
15
 
 
16
 
+       gtk_window_set_screen (GTK_WINDOW (win), gscreen);
17
 
        gtk_window_set_keep_above (GTK_WINDOW (win), TRUE);
18
 
        gtk_window_set_decorated (GTK_WINDOW (win), FALSE);
19
 
        gtk_widget_set_app_paintable(win, TRUE);