~angelsl/ubuntu/wily/gcc-5/mips-cross

« back to all changes in this revision

Viewing changes to debian/patches/gcc-auto-build.diff

  • Committer: angelsl
  • Date: 2015-10-30 03:30:35 UTC
  • Revision ID: angelsl-20151030033035-rmug41zm8hyjgisg
Original import

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
# DP: Fix cross building a native compiler.
 
2
 
 
3
Index: b/src/gcc/configure.ac
 
4
===================================================================
 
5
--- a/src/gcc/configure.ac
 
6
+++ b/src/gcc/configure.ac
 
7
@@ -1628,7 +1628,7 @@ else
 
8
        # Clearing GMPINC is necessary to prevent host headers being
 
9
        # used by the build compiler.  Defining GENERATOR_FILE stops
 
10
        # system.h from including gmp.h.
 
11
-       CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD}" \
 
12
+       CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD} -DGENERATOR_FILE" \
 
13
        CXX="${CXX_FOR_BUILD}" CXXFLAGS="${CXXFLAGS_FOR_BUILD}" \
 
14
        LD="${LD_FOR_BUILD}" LDFLAGS="${LDFLAGS_FOR_BUILD}" \
 
15
        GMPINC="" CPPFLAGS="${CPPFLAGS} -DGENERATOR_FILE" \