~angelsl/ubuntu/wily/gcc-5/mips-cross

« back to all changes in this revision

Viewing changes to debian/patches/gotools-configury.diff

  • Committer: angelsl
  • Date: 2015-10-30 03:30:35 UTC
  • Revision ID: angelsl-20151030033035-rmug41zm8hyjgisg
Original import

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
# DP: Fix gotools cross build.
 
2
 
 
3
        * Makefile.am: Use GOC configured in configure.ac for cross builds.
 
4
        * configure.ac: Fix NATIVE conditional.
 
5
        * Makefile.in, configure: Regenerate.
 
6
 
 
7
Index: b/src/gotools/Makefile.am
 
8
===================================================================
 
9
--- a/src/gotools/Makefile.am
 
10
+++ b/src/gotools/Makefile.am
 
11
@@ -33,7 +33,7 @@ if NATIVE
 
12
 # Use the compiler we just built.
 
13
 GOCOMPILER = $(GOC_FOR_TARGET)
 
14
 else
 
15
-GOCOMPILER = $(GOC)
 
16
+GOCOMPILER = @GOC@
 
17
 endif
 
18
 
 
19
 GOCFLAGS = $(CFLAGS_FOR_TARGET)
 
20
Index: b/src/gotools/Makefile.in
 
21
===================================================================
 
22
--- a/src/gotools/Makefile.in
 
23
+++ b/src/gotools/Makefile.in
 
24
@@ -226,7 +226,7 @@ PWD_COMMAND = $${PWDCMD-pwd}
 
25
 STAMP = echo timestamp >
 
26
 libgodir = ../$(target_noncanonical)/libgo
 
27
 LIBGODEP = $(libgodir)/libgo.la
 
28
-@NATIVE_FALSE@GOCOMPILER = $(GOC)
 
29
+@NATIVE_FALSE@GOCOMPILER = @GOC@
 
30
 
 
31
 # Use the compiler we just built.
 
32
 @NATIVE_TRUE@GOCOMPILER = $(GOC_FOR_TARGET)
 
33
Index: b/src/gotools/configure.ac
 
34
===================================================================
 
35
--- a/src/gotools/configure.ac
 
36
+++ b/src/gotools/configure.ac
 
37
@@ -46,7 +46,7 @@ AC_PROG_INSTALL
 
38
 AC_PROG_CC
 
39
 AC_PROG_GO
 
40
 
 
41
-AM_CONDITIONAL(NATIVE, test "$cross_compiling" = no)
 
42
+AM_CONDITIONAL(NATIVE, test "$host" = "$target")
 
43
 
 
44
 dnl Test for -lsocket and -lnsl.  Copied from libjava/configure.ac.
 
45
 AC_CACHE_CHECK([for socket libraries], gotools_cv_lib_sockets,