~apw/procps/kernel-version-fix

« back to all changes in this revision

Viewing changes to debian/patches/10_ps.1.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Kees Cook
  • Date: 2010-06-08 11:45:44 UTC
  • mfrom: (2.1.12 squeeze)
  • Revision ID: james.westby@ubuntu.com-20100608114544-9jyvbwg9txv7tntb
Tags: 1:3.2.8-9ubuntu1
* Merge with Debian unstable; remaining changes:
  - debian/rules (Ubuntu-specific):
    - use upstart for init script.
    - install sysctl files from new sysctl.d directory.
  - debian/sysctl.d (Ubuntu-specific):
    - 10-console-messages.conf: stop low-level kernel messages on console.
    - 10-network-security.conf: enable rp_filter and SYN-flood protection.
    - 10-keyboard.conf.powerpc: mouse button emulation on PowerPC.
    - 10-zeropage.conf: safe mmap_min_addr value for graceful fall-back.
    - README: describe how this directory is supposed to work.
  - debian/upstart, debian/postinst (Ubuntu-specific):
    - upstart configuration to replace old style sysv init script.
* Fixed upstream: debian/patches/60_linux_version_init.dpatch
* Added debian/sysctl.d/10-ptrace.conf: describe new PTRACE setting.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 10_ps.1.dpatch by  <csmall@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: ps.1 normal indent widths
6
 
## DP: pri field explained #465761
7
 
## DP: --no-heading comment is an alias for --no-headers
8
 
## DP: Removed setproctitle(1) reference #529045
9
 
 
10
 
@DPATCH@
11
 
diff -urNad procps-3.2.8~/ps/ps.1 procps-3.2.8/ps/ps.1
12
 
--- procps-3.2.8~/ps/ps.1       2009-05-28 17:40:42.000000000 +1000
13
 
+++ procps-3.2.8/ps/ps.1        2009-05-28 17:41:32.000000000 +1000
14
 
@@ -18,12 +18,6 @@
15
 
 .nh
16
 
 .if n .ss 12 0
17
 
 .\"
18
 
-.\" See /usr/share/groff/current/tmac/an-old.tmac for what these do.
19
 
-.\" Setting them to zero provides extra space, but only do that for
20
 
-.\" plain text output. PostScript and such will remain indented.
21
 
-.if n .nr IN 0n
22
 
-.if n .nr an-prevailing-indent 0n
23
 
-.\"
24
 
 .\"
25
 
 .\" ColSize is used for the format spec table.
26
 
 .\" It's the left margin, minus the right, minus
27
 
@@ -499,7 +493,7 @@
28
 
 .opt c
29
 
 Show the true command name. This is derived from the name of the
30
 
 executable file, rather than from the argv value. Command arguments
31
 
-and any modifications to them (see\ \fIsetproctitle\fR(3)) are
32
 
+and any modifications to them  are
33
 
 thus not shown. This option
34
 
 effectively turns the \fBargs\fR format keyword into the \fBcomm\fR
35
 
 format keyword; it is useful with the \fB\-f\fR format option and with
36
 
@@ -588,7 +582,8 @@
37
 
 repeat header lines, one per page of output
38
 
 
39
 
 .opt \-\-no\-headers
40
 
-print no header line at all
41
 
+print no header line at all. \-\-no\-heading is an alias for this
42
 
+option.
43
 
 
44
 
 .opt \-\-lines \ n
45
 
 set screen height
46
 
@@ -1159,6 +1154,10 @@
47
 
 parent process ID.
48
 
 T}
49
 
 
50
 
+pri    PRI     T{
51
 
+priority of the process. Higher number means lower priority
52
 
+T}
53
 
+
54
 
 psr    PSR     T{
55
 
 processor that process is currently assigned to.
56
 
 T}