~apw/procps/kernel-version-fix

« back to all changes in this revision

Viewing changes to debian/patches/10_w_time.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Kees Cook
  • Date: 2010-06-08 11:45:44 UTC
  • mfrom: (2.1.12 squeeze)
  • Revision ID: james.westby@ubuntu.com-20100608114544-9jyvbwg9txv7tntb
Tags: 1:3.2.8-9ubuntu1
* Merge with Debian unstable; remaining changes:
  - debian/rules (Ubuntu-specific):
    - use upstart for init script.
    - install sysctl files from new sysctl.d directory.
  - debian/sysctl.d (Ubuntu-specific):
    - 10-console-messages.conf: stop low-level kernel messages on console.
    - 10-network-security.conf: enable rp_filter and SYN-flood protection.
    - 10-keyboard.conf.powerpc: mouse button emulation on PowerPC.
    - 10-zeropage.conf: safe mmap_min_addr value for graceful fall-back.
    - README: describe how this directory is supposed to work.
  - debian/upstart, debian/postinst (Ubuntu-specific):
    - upstart configuration to replace old style sysv init script.
* Fixed upstream: debian/patches/60_linux_version_init.dpatch
* Added debian/sysctl.d/10-ptrace.conf: describe new PTRACE setting.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 30_w_time.dpatch by  <csmall@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Let fprintf print locale-friendly seconds #252575
6
 
 
7
 
@DPATCH@
8
 
diff -urNad procps-3.2.7~/w.c procps-3.2.7/w.c
9
 
--- procps-3.2.7~/w.c   2009-01-09 15:56:04.000000000 +1100
10
 
+++ procps-3.2.7/w.c    2009-01-09 16:14:56.000000000 +1100
11
 
@@ -83,7 +83,7 @@
12
 
     else if (t > 60)                           /* > 1 minute */
13
 
        fprintf(fout, " %2lu:%02u ", t/60, (unsigned) t%60);
14
 
     else
15
 
-       fprintf(fout, " %2lu.%02us", t, centi_sec);
16
 
+    fprintf(fout, " %2lu.%02us", t, centi_sec);
17
 
 }
18
 
 
19
 
 /**** stat the device file to get an idle time */