~barry/gedit/bug-788514

« back to all changes in this revision

Viewing changes to debian/patches/01_lpi.patch

  • Committer: Sebastien Bacher
  • Date: 2011-05-04 10:36:14 UTC
  • Revision ID: seb128@ubuntu.com-20110504103614-26pgl25lkfufs9z9
* Resynchronize on Debian, remaining diffs
  - Build-Depends on dh-autoreconf, gnome-common, liblaunchpad-integration
  - Conflicts gir1.2-gedit-3.0 for ppa upgrades, Debian ship the gir in gedit
  - don't Recommends python-gnome2
  - don't Build-Depends on libgconf2-dev nor libx11-dev
* debian/gedit.install:
  - install the gi override
* debian/rules:
  - Use autoreconf.mk
* New upstream release
* Updated build-dependencies
* Added gobject introspection integration
* debian/patches/03_python_path.patch
  debian/patches/04_link_against_libICE.patch
  debian/patches/10_pt_BR_po.patch:
  - Dropped obsolete patches
* debian/patches/90_autoreconf.patch
  debian/patches/99_ltmain_as-needed.patch:
  -  Refreshed
* Recommend yelp. Closes: #600055.
* 10_pt_BR_po.patch: fix an important mistake in the Brazilian 
  Portuguese translation. Closes: #603502.
* New upstream translation release.
* 90_autoreconf.patch: updated for the new version.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Launchpad integration.
2
 
Author: Daniel Holbach <daniel.holbach@ubuntu.com>
3
 
 
4
 
Index: gedit-2.30.2/configure.ac
 
1
Index: gedit-3.0.0/configure.ac
5
2
===================================================================
6
 
--- gedit-2.30.2.orig/configure.ac      2010-04-19 05:30:19.000000000 +1000
7
 
+++ gedit-2.30.2/configure.ac   2010-05-27 14:57:00.895446399 +1000
8
 
@@ -275,6 +275,7 @@
9
 
        gtk+-2.0 >= 2.16.0
10
 
        gtksourceview-2.0 >= 2.9.7
11
 
        gconf-2.0 >= 1.1.11
12
 
+       launchpad-integration
 
3
--- gedit-3.0.0.orig/configure.ac
 
4
+++ gedit-3.0.0/configure.ac
 
5
@@ -331,6 +331,7 @@
 
6
        libpeas-1.0 >= 0.7.3
 
7
        libpeas-gtk-1.0 >= 0.7.3
 
8
        gsettings-desktop-schemas
 
9
+       launchpad-integration-3.0
13
10
 ])
14
11
 
15
12
 if test "$os_osx" = "no" &&
16
 
Index: gedit-2.30.2/gedit/gedit-ui.h
 
13
Index: gedit-3.0.0/gedit/gedit-ui.h
17
14
===================================================================
18
 
--- gedit-2.30.2.orig/gedit/gedit-ui.h  2010-03-27 22:02:52.000000000 +1100
19
 
+++ gedit-2.30.2/gedit/gedit-ui.h       2010-05-27 14:57:00.895446399 +1000
 
15
--- gedit-3.0.0.orig/gedit/gedit-ui.h
 
16
+++ gedit-3.0.0/gedit/gedit-ui.h
20
17
@@ -36,6 +36,7 @@
21
18
 #endif
22
19
 
25
22
 
26
23
 #include "gedit-commands.h"
27
24
 
28
 
Index: gedit-2.30.2/gedit/gedit-ui.xml
 
25
Index: gedit-3.0.0/gedit/gedit-ui.xml
29
26
===================================================================
30
 
--- gedit-2.30.2.orig/gedit/gedit-ui.xml        2010-03-23 08:56:56.000000000 +1100
31
 
+++ gedit-2.30.2/gedit/gedit-ui.xml     2010-05-27 14:57:00.895446399 +1000
32
 
@@ -147,6 +147,7 @@
 
27
--- gedit-3.0.0.orig/gedit/gedit-ui.xml
 
28
+++ gedit-3.0.0/gedit/gedit-ui.xml
 
29
@@ -151,6 +151,7 @@
33
30
 
34
31
     <menu name="HelpMenu" action="Help">
35
32
       <menuitem name="HelpContentsMenu" action="HelpContents"/>
37
34
       <menuitem name="HelpAboutMenu" action="HelpAbout"/>
38
35
     </menu>
39
36
   </menubar>
40
 
Index: gedit-2.30.2/gedit/gedit-window.c
 
37
Index: gedit-3.0.0/gedit/gedit-window.c
41
38
===================================================================
42
 
--- gedit-2.30.2.orig/gedit/gedit-window.c      2010-04-18 03:21:14.000000000 +1000
43
 
+++ gedit-2.30.2/gedit/gedit-window.c   2010-05-27 14:57:00.895446399 +1000
44
 
@@ -1594,6 +1594,11 @@
 
39
--- gedit-3.0.0.orig/gedit/gedit-window.c
 
40
+++ gedit-3.0.0/gedit/gedit-window.c
 
41
@@ -1640,6 +1640,11 @@
45
42
        }
46
 
 #endif
 
43
        g_free (ui_file);
47
44
 
48
45
+       /* Add lpi items */
49
46
+       launchpad_integration_add_ui (manager,