~barry/gedit/bug-788514

« back to all changes in this revision

Viewing changes to debian/patches/02_gconf_import.patch

  • Committer: Sebastien Bacher
  • Date: 2011-05-04 10:36:14 UTC
  • Revision ID: seb128@ubuntu.com-20110504103614-26pgl25lkfufs9z9
* Resynchronize on Debian, remaining diffs
  - Build-Depends on dh-autoreconf, gnome-common, liblaunchpad-integration
  - Conflicts gir1.2-gedit-3.0 for ppa upgrades, Debian ship the gir in gedit
  - don't Recommends python-gnome2
  - don't Build-Depends on libgconf2-dev nor libx11-dev
* debian/gedit.install:
  - install the gi override
* debian/rules:
  - Use autoreconf.mk
* New upstream release
* Updated build-dependencies
* Added gobject introspection integration
* debian/patches/03_python_path.patch
  debian/patches/04_link_against_libICE.patch
  debian/patches/10_pt_BR_po.patch:
  - Dropped obsolete patches
* debian/patches/90_autoreconf.patch
  debian/patches/99_ltmain_as-needed.patch:
  -  Refreshed
* Recommend yelp. Closes: #600055.
* 10_pt_BR_po.patch: fix an important mistake in the Brazilian 
  Portuguese translation. Closes: #603502.
* New upstream translation release.
* 90_autoreconf.patch: updated for the new version.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Patch to fix ubuntu bug #654867
2
 
 This patch fixes ubuntu bug #654867 by making sure the PythonConsoleConfig
3
 
 gconf class is used in the python console plugin configuration dialog.
4
 
 Patch created by Jason Conti
5
 
 
6
 
Bug-Ubuntu: https://launchpad.net/bugs/654867
7
 
--- a/plugins/pythonconsole/pythonconsole/config.py-backup      2010-10-04 17:37:27.634246001 -0400
8
 
+++ b/plugins/pythonconsole/pythonconsole/config.py     2010-10-04 17:38:39.034246002 -0400
9
 
@@ -68,7 +68,7 @@
10
 
             return default
11
 
 
12
 
         val = PythonConsoleConfig.gconf.client_get_default().get(key)
13
 
-        if val is not None and val.type == gconf.VALUE_STRING:
14
 
+        if val is not None and val.type == PythonConsoleConfig.gconf.VALUE_STRING:
15
 
             return val.get_string()
16
 
         else:
17
 
             return default
18
 
@@ -78,7 +78,7 @@
19
 
         if not PythonConsoleConfig.gconf:
20
 
             return
21
 
 
22
 
-        v = PythonConsoleConfig.gconf.Value(gconf.VALUE_STRING)
23
 
+        v = PythonConsoleConfig.gconf.Value(PythonConsoleConfig.gconf.VALUE_STRING)
24
 
         v.set_string(value)
25
 
         PythonConsoleConfig.gconf.client_get_default().set(key, v)
26