~bratsche/ubuntu/maverick/gtk+2.0/menu-activation-fix

« back to all changes in this revision

Viewing changes to debian/patches/005_support_disabling_x11_extensions.patch

  • Committer: Bazaar Package Importer
  • Author(s): Robert Ancell
  • Date: 2010-07-22 21:41:30 UTC
  • mfrom: (1.11.7 upstream) (72.1.16 experimental)
  • Revision ID: james.westby@ubuntu.com-20100722214130-5uzyvpb9g4m0ts2c
Tags: 2.21.5-1ubuntu1
* Merge with Debian experimental, Ubuntu changes:
* debian/control.in:
  - Add introspection build-depends
  - Add Vcs-Bzr link
  - Add gir1.0-gtk-2.0 package
  - libgtk2.0-dev replaces gir-repository-dev
  - Conflict with appmenu-gtk (<< 0.1.3) to prevent menu proxy breakage
* debian/rules:
  - Build with --enable-introspection
  - Add gir1.0-gtk-2.0 package to BINARY_ARCH_PKGS
  - Add dh_girepository call
  - Disable devhelp files
* debian/dh_gtkmodules.in:
  - Remove obsolete script content
* debian/libgtk2.0-0.symbols:
  - Add Ubuntu specific symbols
* debian/libgtk2.0-dev.install.in:
  - Add gir files
* debian/libgtk2.0-doc.install.in
  - Disable devhelp files
* debian/gir1.0-gtk-2.0.install.in
  - Introspection package
* debian/patches/043_menu_proxy.patch
  - Add GtkMenuProxy support for remoting menus.
* debian/patches/062_dnd_menubar.patch:
  - Allow click on menubars for dnd
* debian/patches/063_treeview_almost_fixed.patch:
  - Add an ubuntu-almost-fixed-height-mode property, (required for
    software-center)
* debian/patches/071_no_offscreen_widgets_grabbing.patch:
  - Don't let offscreen widgets do grabbing
* debian/patches/072_indicator_menu_update.patch:
  - change by Cody Russell to send an update event on menu changes,
    should make the bluetooth indicator refresh correctly
* debian/patches/091_bugzilla_tooltip_refresh.patch:
  - Upstream bugzilla change to have better looking tooltips the gtk theme
    need to set "new-tooltip-style" to use those
* debian/watch:
  - Watch for unstable versions

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
 
4
4
Support disabling X11 extensions
5
5
 
6
 
Index: b/configure.in
 
6
Index: gtk+2.0-2.21.5/configure.in
7
7
===================================================================
8
 
--- a/configure.in      2010-04-10 14:52:07.373945222 +0200
9
 
+++ b/configure.in      2010-04-10 14:52:08.109945409 +0200
10
 
@@ -253,6 +253,18 @@
 
8
--- gtk+2.0-2.21.5.orig/configure.in    2010-07-22 17:54:32.685052226 +0200
 
9
+++ gtk+2.0-2.21.5/configure.in 2010-07-22 17:54:36.285051810 +0200
 
10
@@ -241,6 +241,18 @@
11
11
               [AC_HELP_STRING([--enable-xinerama],
12
12
                              [support xinerama extension if available [default=yes]])],,
13
13
               [enable_xinerama="yes"])
26
26
 AC_ARG_ENABLE(rebuilds,
27
27
               [AC_HELP_STRING([--disable-rebuilds],
28
28
                               [disable all source autogeneration rules])],,
29
 
@@ -1590,7 +1602,8 @@
 
29
@@ -1187,7 +1199,8 @@
30
30
   AM_CONDITIONAL(XINPUT_XFREE, test x$with_xinput = xxfree || test x$with_xinput = xyes)
31
31
 
32
32
   # Check for the RANDR extension
36
36
      AC_DEFINE(HAVE_RANDR, 1, [Have the Xrandr extension library])
37
37
 
38
38
      X_PACKAGES="$X_PACKAGES xrandr"
39
 
@@ -1606,7 +1619,8 @@
 
39
@@ -1203,7 +1216,8 @@
40
40
 
41
41
   # Checks for XFixes extension
42
42
   
46
46
     AC_DEFINE(HAVE_XFIXES, 1, [Have the XFIXES X extension])
47
47
     
48
48
     X_PACKAGES="$X_PACKAGES xfixes"
49
 
@@ -1615,7 +1629,8 @@
 
49
@@ -1212,7 +1226,8 @@
50
50
 
51
51
   # Checks for Xcomposite extension
52
52
 
56
56
     AC_DEFINE(HAVE_XCOMPOSITE, 1, [Have the XCOMPOSITE X extension])
57
57
 
58
58
     X_PACKAGES="$X_PACKAGES xcomposite"
59
 
@@ -1624,7 +1639,7 @@
 
59
@@ -1221,7 +1236,7 @@
60
60
 
61
61
   # Checks for Xdamage extension
62
62