~bratsche/ubuntu/maverick/gtk+2.0/menu-activation-fix

« back to all changes in this revision

Viewing changes to debian/patches/022_module-files-append-compat-module-files-d.patch

  • Committer: Bazaar Package Importer
  • Author(s): Robert Ancell
  • Date: 2010-07-22 21:41:30 UTC
  • mfrom: (1.11.7 upstream) (72.1.16 experimental)
  • Revision ID: james.westby@ubuntu.com-20100722214130-5uzyvpb9g4m0ts2c
Tags: 2.21.5-1ubuntu1
* Merge with Debian experimental, Ubuntu changes:
* debian/control.in:
  - Add introspection build-depends
  - Add Vcs-Bzr link
  - Add gir1.0-gtk-2.0 package
  - libgtk2.0-dev replaces gir-repository-dev
  - Conflict with appmenu-gtk (<< 0.1.3) to prevent menu proxy breakage
* debian/rules:
  - Build with --enable-introspection
  - Add gir1.0-gtk-2.0 package to BINARY_ARCH_PKGS
  - Add dh_girepository call
  - Disable devhelp files
* debian/dh_gtkmodules.in:
  - Remove obsolete script content
* debian/libgtk2.0-0.symbols:
  - Add Ubuntu specific symbols
* debian/libgtk2.0-dev.install.in:
  - Add gir files
* debian/libgtk2.0-doc.install.in
  - Disable devhelp files
* debian/gir1.0-gtk-2.0.install.in
  - Introspection package
* debian/patches/043_menu_proxy.patch
  - Add GtkMenuProxy support for remoting menus.
* debian/patches/062_dnd_menubar.patch:
  - Allow click on menubars for dnd
* debian/patches/063_treeview_almost_fixed.patch:
  - Add an ubuntu-almost-fixed-height-mode property, (required for
    software-center)
* debian/patches/071_no_offscreen_widgets_grabbing.patch:
  - Don't let offscreen widgets do grabbing
* debian/patches/072_indicator_menu_update.patch:
  - change by Cody Russell to send an update event on menu changes,
    should make the bluetooth indicator refresh correctly
* debian/patches/091_bugzilla_tooltip_refresh.patch:
  - Upstream bugzilla change to have better looking tooltips the gtk theme
    need to set "new-tooltip-style" to use those
* debian/watch:
  - Watch for unstable versions

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: b/gtk/gtkimmodule.c
2
 
===================================================================
3
 
--- a/gtk/gtkimmodule.c 2010-04-10 14:52:09.765946296 +0200
4
 
+++ b/gtk/gtkimmodule.c 2010-04-10 14:52:10.681942580 +0200
5
 
@@ -29,6 +29,7 @@
6
 
 #include <stdio.h>
7
 
 #include <stdlib.h>
8
 
 #include <string.h>
9
 
+#include <unistd.h>
10
 
 
11
 
 #include <glib/gstdio.h>
12
 
 #include <gmodule.h>
13
 
@@ -489,10 +490,32 @@
14
 
                                                   GTK_BINARY_VERSION,
15
 
                                                   "immodule-files.d",
16
 
                                                   NULL);
17
 
+
18
 
+#if defined(__linux__) && defined (__i386__)
19
 
+  gchar *compat_im_module_files_d_str = g_build_filename ("/usr/lib32/gtk-2.0",
20
 
+                                                  GTK_BINARY_VERSION,
21
 
+                                                  "immodule-files.d",
22
 
+                                                  NULL);
23
 
+#elif defined(__linux__) && ( defined (__x86_64__) || defined(__ia64__) )
24
 
+  gchar *compat_im_module_files_d_str = g_build_filename ("/usr/lib64/gtk-2.0",
25
 
+                                                  GTK_BINARY_VERSION,
26
 
+                                                  "immodule-files.d",
27
 
+                                                  NULL);
28
 
+#endif
29
 
   FILE *file;
30
 
   gchar *list_str;
31
 
   char **files;
32
 
   int n;
33
 
+#if defined(__linux__) && ( defined(__i386__) || defined (__x86_64__) || defined(__ia64__) )
34
 
+  /* prefer compat_im_module_files_d_str over im_module_files_d_str on the
35
 
+   * above arches if it's usable */
36
 
+  if (! g_access(compat_im_module_files_d_str, R_OK|X_OK))
37
 
+      list_str = g_strjoin (G_SEARCHPATH_SEPARATOR_S,
38
 
+                           compat_im_module_files_d_str,
39
 
+                           im_module_file_str,
40
 
+                           NULL);
41
 
+  else /* continued below */
42
 
+#endif
43
 
 
44
 
   list_str = g_strjoin (G_SEARCHPATH_SEPARATOR_S,
45
 
                        im_module_files_d_str,
46
 
@@ -544,6 +567,9 @@
47
 
 
48
 
   g_strfreev (files);
49
 
   g_free (list_str);
50
 
+#if defined(__linux__) && ( defined(__i386__) || defined (__x86_64__) || defined(__ia64__) )
51
 
+  g_free (compat_im_module_files_d_str);
52
 
+#endif
53
 
   g_free (im_module_files_d_str);
54
 
   g_free (im_module_file_str);
55
 
 }
56
 
Index: b/gdk-pixbuf/gdk-pixbuf-io.c
57
 
===================================================================
58
 
--- a/gdk-pixbuf/gdk-pixbuf-io.c        2010-04-10 14:52:10.065944562 +0200
59
 
+++ b/gdk-pixbuf/gdk-pixbuf-io.c        2010-04-10 14:52:10.685945884 +0200
60
 
@@ -554,6 +554,18 @@
61
 
 #ifdef USE_GMODULE
62
 
        GIOChannel *channel;
63
 
        gchar *gdkpixbuf_module_file_str = gdk_pixbuf_get_module_file ();
64
 
+
65
 
+#if defined(__linux__) && defined (__i386__)
66
 
+       gchar *compat_gdkpixbuf_module_files_d_str = g_build_filename ("/usr/lib32/gtk-2.0",
67
 
+                                                       GTK_BINARY_VERSION,
68
 
+                                                       "loader-files.d",
69
 
+                                                       NULL);
70
 
+#elif defined(__linux__) && ( defined (__x86_64__) || defined(__ia64__) )
71
 
+       gchar *compat_gdkpixbuf_module_files_d_str = g_build_filename ("/usr/lib64/gtk-2.0",
72
 
+                                                       GTK_BINARY_VERSION,
73
 
+                                                       "loader-files.d",
74
 
+                                                       NULL);
75
 
+#endif
76
 
        gchar *list_str;
77
 
        char **files;
78
 
        GError *error = NULL;
79
 
@@ -640,6 +652,18 @@
80
 
 #undef load_one_builtin_module
81
 
 
82
 
 #ifdef USE_GMODULE
83
 
+
84
 
+#if defined(__linux__) && ( defined(__i386__) || defined (__x86_64__) || defined(__ia64__) )
85
 
+  /* prefer compat_gdkpixbuf_module_files_d_str over PIXBUF_FILES_LIBDIR
86
 
+   * on the above arches if it's usable */
87
 
+  if (! g_access(compat_gdkpixbuf_module_files_d_str, R_OK|X_OK))
88
 
+      list_str = g_strjoin (G_SEARCHPATH_SEPARATOR_S,
89
 
+                           gdkpixbuf_module_file_str,
90
 
+                           compat_gdkpixbuf_module_files_d_str,
91
 
+                           NULL);
92
 
+  else /* continued below */
93
 
+#endif
94
 
+
95
 
        list_str = g_strjoin (G_SEARCHPATH_SEPARATOR_S,
96
 
                              gdkpixbuf_module_file_str,
97
 
                              PIXBUF_FILES_LIBDIR,
98
 
@@ -695,6 +719,10 @@
99
 
        }
100
 
 
101
 
        g_strfreev (files);
102
 
+#if defined(__linux__) && ( defined(__i386__) || defined (__x86_64__) || defined(__ia64__) )
103
 
+
104
 
+       g_free (compat_gdkpixbuf_module_files_d_str);
105
 
+#endif
106
 
        g_free (list_str);
107
 
        g_free (gdkpixbuf_module_file_str);
108
 
 #endif