~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/do-not-use-bundled-clang

  • Committer: Olivier Tilloy
  • Date: 2018-02-12 09:35:31 UTC
  • mfrom: (1358.1.71 artful-dev)
  • Revision ID: olivier.tilloy@canonical.com-20180212093531-8e8kr2s6xo3dligh
* Upstream beta channel update: 65.0.3325.51
* debian/rules: remove use_gconf build flag
* debian/patches/3-chrome-xid.patch: removed, unused
* debian/patches/5-desktop-integration-settings.patch: removed, unused
* debian/patches/6-passwordless-install-support.patch: removed, unused
* debian/patches/7-npapi-permission-not-defaults-to-unauthorized.patch: removed, unused
* debian/patches/additional-search-engines.patch: refreshed
* debian/patches/breakpad: removed, unused
* debian/patches/cups-include-deprecated-ppd: removed, unused
* debian/patches/define__libc_malloc.patch: refreshed
* debian/patches/disable-sse2: updated
* debian/patches/display-scaling-default-value: removed, unused
* debian/patches/do-not-use-bundled-clang: removed, unused
* debian/patches/enable-chromecast-by-default.patch: refreshed
* debian/patches/enable_vaapi_on_linux.diff: removed, unused
* debian/patches/flash-redirection: removed, unused
* debian/patches/format-flag.patch: removed, unused
* debian/patches/gpu_default_disabled: removed, unused
* debian/patches/gsettings-display-scaling: removed, unused
* debian/patches/ld-memory-32bit.patch: removed, unused
* debian/patches/linker-asneeded-bug.patch: removed, unused
* debian/patches/lp-translations-paths: removed, unused
* debian/patches/mir-ozone-module: removed, unused
* debian/patches/mir-support: removed, unused
* debian/patches/revert-Xclang-instcombine-lower-dbg-declare.patch: refreshed
* debian/patches/search-credit.patch: refreshed
* debian/patches/set-rpath-on-chromium-executables.patch: refreshed
* debian/patches/suppress-newer-clang-warning-flags.patch: refreshed
* debian/patches/title-bar-default-system.patch-v35: refreshed
* debian/patches/use-clang-versioned.patch: refreshed
* debian/patches/wayland-ozone: removed, unused
* debian/patches/xdg-settings-multiexec-desktopfiles.patch: removed, unused
* debian/known_gn_gen_args-*: remove use_gconf build flag

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/build/config/linux/gconf/BUILD.gn
2
 
+++ b/build/config/linux/gconf/BUILD.gn
3
 
@@ -11,7 +11,7 @@ assert(!is_chromeos && use_gconf)
4
 
 # These packages should _only_ be expected when building for a target.
5
 
 # If these extra checks are not run, gconf is required when building host
6
 
 # tools for a CrOS build.
7
 
-assert(current_toolchain == default_toolchain)
8
 
+#assert(current_toolchain == default_toolchain)
9
 
 
10
 
 pkg_config("gconf") {
11
 
   packages = [ "gconf-2.0" ]
12
 
--- a/build/toolchain/gcc_toolchain.gni
13
 
+++ b/build/toolchain/gcc_toolchain.gni
14
 
@@ -482,9 +482,8 @@ template("clang_toolchain") {
15
 
   }
16
 
 
17
 
   gcc_toolchain(target_name) {
18
 
-    prefix = rebase_path("$clang_base_path/bin", root_build_dir)
19
 
-    cc = "$prefix/clang"
20
 
-    cxx = "$prefix/clang++"
21
 
+    cc = "clang"
22
 
+    cxx = "clang++"
23
 
     ld = cxx
24
 
 
25
 
     readelf = "${toolprefix}readelf"