~chromium-team/chromium-browser/beta

« back to all changes in this revision

Viewing changes to debian/patches/ffmpeg-gyp-config.patch

  • Committer: Chad Miller
  • Date: 2013-08-27 16:58:09 UTC
  • mfrom: (915.1.13 saucy-working)
  • Revision ID: chad.miller@canonical.com-20130827165809-up7594cwptx3v6mz
* New release 29.0.1547.57:  (LP: #1215361)
  - CVE-2013-2900: Incomplete path sanitization in file handling.
  - CVE-2013-2905: Information leak via overly broad permissions on shared
    memory files.
  - CVE-2013-2901: Integer overflow in ANGLE.
  - CVE-2013-2902: Use after free in XSLT.
  - CVE-2013-2903: Use after free in media element.
  - CVE-2013-2904: Use after free in document parsing.
  - CVE-2013-2887: Various fixes from internal audits, fuzzing and other
    initiatives (Chrome 29).
* debian/rules: Fix packaging-sanity test.
* debian/patches/search-credit.patch:  Update URLs.
* debian/patches/disable_dlog_and_dcheck_in_release_builds.patch,
  debian/patches/wehkit_rev_parser.patch,
    No longer necessary.  Deleted.
* debian/chromium-browser.sh.in: Include command-line parameters for
  registered plugins.
* Since we include remoting locales too, also split its locales info 
  into the -l10n package correctly.
* debian/rules: Disable arm_neon_optional. Impossible with sandbox, AND
  breaks build right now.
* debian/rules:
  - Make unused-file matches simpler, and install rule more descriptive.
  - get-orig-source has to make the directory for the orig contents. 
* debian/source/lintian-overrides:
  - Add old-fsf-address-in-copyright-file and image-file-in-usr-lib
  - Fix setuid-binary to be "source". Seems like it should be "binary". :(
* debian/checkout-orig-source.mk: Remove tests and add unofficialness
  marker file to orig tarball when we can't use upstream orig releases.
* debian/control: Set VCS URL to be accurate.
* debian/rules: Start rule to create patch that includes Launchpad
  translations.  Never change upstream orig tarball.  This will be a 
  release-time manual rule that updates a quilt patch.
* New release 28.0.1500.95:
  - CVE-2013-2881: Origin bypass in frame handling.
  - CVE-2013-2882: Type confusion in V8.
  - CVE-2013-2883: Use-after-free in MutationObserver.
  - CVE-2013-2884: Use-after-free in DOM.
  - CVE-2013-2885: Use-after-free in input handling.
  - CVE-2013-2886: Various fixes from internal audits, fuzzing and other
    initiatives.
* debian/rules:
  - Keepalive in tests rule, to keep builder machines from reaping.
  - Further exclude a few tests that interact with fakeroot,
    ReadOnlyFileUtilTest.
* debian/rules:
  - Disable logging calls in chromium binary to save several MB of executable
    size.
* debian/patches/linker-asneeded-bug.patch:
  - Add patch to work around linker bug.
* debian/keep-alive.sh:
  - Treat disappearing /proc as error, and quit. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
                                                                       
3
3
--- a/src/third_party/ffmpeg/ffmpeg.gyp
4
4
+++ b/src/third_party/ffmpeg/ffmpeg.gyp
5
 
@@ -418,6 +418,9 @@
 
5
@@ -431,6 +431,9 @@
6
6
   'targets': [
7
7
     {
8
8
       'target_name': 'ffmpeg',
12
12
       'sources': [
13
13
         # Files needed for stub generation rules.
14
14
         '<@(sig_files)',
15
 
@@ -506,6 +509,7 @@
 
15
@@ -519,6 +522,7 @@
16
16
           'type': '<(component)',
17
17
           'include_dirs': [
18
18
             '<(output_root)',
20
20
             '../..',  # The chromium 'src' directory.
21
21
             '<(platform_config_root)',
22
22
             '.',
23
 
@@ -627,6 +631,10 @@
 
23
@@ -640,6 +644,10 @@
24
24
         ],
25
25
         'yasm_output_path': '<(shared_generated_dir)/yasm'
26
26
       },